Bug #4152

Kernel 4.4+ Possible SYN flooding on port 9981/9982. Sending cookies.

Added by saen acro almost 2 years ago. Updated almost 2 years ago.

Status:FixedStart date:2016-12-30
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:User Interface
Target version:-
Found in version:4.1.x Affected Versions:

Description

There is a problem with new standard kernel 4.4 and newer.
After more then 128 pps was make kernel start to drop packages
this make channel switching slow, web interface also.

kernel: [   40.170303] TCP: request_sock_TCP: Possible SYN flooding on port 9981. Sending cookies.  Check SNMP counters.
kernel: [   40.185854] TCP: request_sock_TCP: Possible SYN flooding on port 9982. Sending cookies.  Check SNMP counters.

solution was found in other projects
https://github.com/zaphoyd/websocketpp/issues/549
https://access.redhat.com/solutions/30453

bitrate.GIF - bitrate in TVH is wrong in KODI correct (304 KB) saen acro, 2016-12-31 19:09

blur.PNG (108 KB) saen acro, 2016-12-31 19:16

Associated revisions

Revision 1f894a69
Added by Jaroslav Kysela almost 2 years ago

tcp: change listen backlog from 1 to 511 (like apache default), fixes #4152

Revision 63c10341
Added by Jaroslav Kysela almost 2 years ago

tcp: change listen backlog from 1 to 511 (like apache default), fixes #4152

History

#1 Updated by Jaroslav Kysela almost 2 years ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

#2 Updated by Jaroslav Kysela almost 2 years ago

Applied to both 4.1 and 4.0 branches.

#3 Updated by saen acro almost 2 years ago

Jaroslav Kysela wrote:

Applied in changeset tvheadend|1f894a6951ec17d07679b4e7f7ba85681df04d93.

one idea better but if tv watched web interface is very slow and loading with blurred background show for 10+ seconds
channel switching 1 of 5-15 click succes

there is also very wrong values for stream bitrate jumping x3 x6 times

mpegts: too much queued table input data (over 2MB), discarding new

#4 Updated by Jaroslav Kysela almost 2 years ago

Continue this reporting in bug #3971 . I don't have an idea what's wrong, because I cannot reproduce this here, so I rely only on the feedback from users.

Also available in: Atom PDF