Project

General

Profile

Bug #4055

user defined stream profile is not working

Added by Raymond Paulsen about 4 years ago. Updated about 4 years ago.

Status:
New
Priority:
Normal
Category:
Transcoding
Target version:
-
Start date:
2016-10-29
Due date:
% Done:

0%

Estimated time:
Found in version:
latest version
Affected Versions:

Description

Explisit setting a stream/transcoding profile to a user is not honored.

I have set a user with a vp8 transcoding profile, this user uses tvh android app.
Upon starting the streams the user deffined profile is not used.
The profile set globaly to default is used. So the users stream profile is not used.

The problem seems to be tvheadend is using the globaly default stream profile and not the user deffined profile.

Changing the globaly default profile forces the tvh app to use the default profile, rendring the user configured profile not used.

History

#1

Updated by Jaroslav Kysela about 4 years ago

Is tvh client authenticated properly to get the stream? See '--trace access' or disable authentication based on IP masks. https://tvheadend.org/projects/tvheadend/wiki/Traces

#2

Updated by Raymond Paulsen about 4 years ago

Hi

I have tried with multiple clients, kodi, tvhguide and vlc. its the same issue every time.
the client is assigned the global default streamprofile and not the user selected one.

i have tried disabling: Use HTTP digest authentication: without any changes.

how do i disable authentication based on ip masks?

i am using the ready compipled APT packages for debian, i belive debugging is disabled in those packages?

#3

Updated by Jaroslav Kysela about 4 years ago

Disable all '*' lines with matching IPs from ACL grid.

#4

Updated by Raymond Paulsen about 4 years ago

I didnt understand what you meant by the asterisk above, i dont have any entrys in ACL grid, i dont have any accounts using * for username, password or ACL. i use a plain account with basic login and the profile set for the user is NOT working.

i did try and add a account with * as username and assigned it a streamprofile other than global default and that worked as intended.

so it seems the problem only exist on user accounts that login is actualy performed on

Also available in: Atom PDF