Project

General

Profile

Bug #4047

Hardware CAM for CAID 098c and oscam for CAID 1830 descrambling did not work

Added by Manuel Menz about 6 years ago. Updated over 5 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Descrambling
Target version:
-
Start date:
2016-10-27
Due date:
% Done:

0%

Estimated time:
Found in version:
4.1-2286~gb15b02c
Affected Versions:

Description

Hi,

i have a problem with my setup. I have a Hardware CAM wich can descramble CAID 098c. This works fine. Then i have a card connected via Smartmouse and oscam. This card could descramble CAID 1830. When i run both separate it works perfect. But when i run the Hardware CAM and the SoftCAM both activated only the Channels from the Hardware CAM would be descrambled. The Channels that should be descrambled from the oscam did not work. When i disable the Hardware CAM the SoftCAM would be descrambled. I've attached an debug output when i have both enabled (Hard and SoftCAM) an swtich to a channel that should be descrambled from the SoftCAM.

If you need further informations, please let me know.

Regards
Manuel


Files

debug_1830_channel.txt (6.51 KB) debug_1830_channel.txt Manuel Menz, 2016-10-27 22:16
tvheadend.log (14.8 KB) tvheadend.log Clemens Gonaus, 2017-08-30 16:27

History

#1

Updated by Hanspeter Müller about 6 years ago

I don't know for what reason, but this was changed a few days ago:

descrambler: DVBCAM (HW CAM) - do not try to use sw descrambler for HW CAM CAIDs

https://github.com/tvheadend/tvheadend/commit/39108cea4d93e85f0db852a30ba5a90b0458eb17

I don't have a hardware cam, but i was afraid that exactly your scenario would no longer work. Can someone explain why this was done? I guess it makes some sense to send CAIDs that a CAM claim directly to that CAM, but why does it not at least fallback on SoftCAM when it fails to descramble a channel?

#2

Updated by Jaroslav Kysela over 5 years ago

Have you tried the latest tvheadend?

#3

Updated by Clemens Gonaus over 5 years ago

Jaroslav Kysela wrote:

Have you tried the latest tvheadend?

I have tried this with the latest tvheadend two weeks ago.
Slightly different CAIDs but same result.
It's not possible to use HW-CAM for some channels and OSCAM for others.
HW-CAM: 098C
OSCAM: 0D98

HW-CAM active: 098C gets decrypted, 0D98 not decrypted
HW-CAM disabled in config: 0D98 gets decrypted using the information provided by OSCAM.

Also available in: Atom PDF