Project

General

Profile

Bug #3978

Build fails Xenial

Added by Stephan Oelze over 4 years ago. Updated over 4 years ago.

Status:
New
Priority:
Normal
Category:
Transcoding
Target version:
-
Start date:
2016-09-14
Due date:
% Done:

0%

Estimated time:
Found in version:
git
Affected Versions:

Description

Hello!

I am trying to compile tvheadend in ubuntu xenial.
For using Nvidias nvenc(gtx980) i need ffmpeg static, which is not aviable for xenial.

[email protected]:~/tvheadend# make
make -f Makefile.ffmpeg
make[1]: Entering directory '/root/tvheadend'
DOWNLOAD        https://dl.bintray.com/tvheadend/misc/staticlib/xenial/amd64/ffmpeg-0f0d717b4f5492eb025d57bc85e8eb6c6e66f42f.tgz
--2016-09-14 11:49:20--  https://dl.bintray.com/tvheadend/misc/staticlib/xenial/amd64/ffmpeg-0f0d717b4f5492eb025d57bc85e8eb6c6e66f42f.tgz
Resolving dl.bintray.com (dl.bintray.com)... 159.122.18.156, 5.153.35.248
Connecting to dl.bintray.com (dl.bintray.com)|159.122.18.156|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2016-09-14 11:49:20 ERROR 404: Not Found.

FAILED TO DOWNLOAD https://dl.bintray.com/tvheadend/misc/staticlib/xenial/amd64/ffmpeg-0f0d717b4f5492eb025d57bc85e8eb6c6e66f42f.tgz (BUT THIS IS NOT A FATAL ERROR! DO NOT REPORT THAT!)

Yes "dont report that" maybe its that easy to just copy a vivid one there?
I Tried to edit support/lib.sh to "another url".
https://dl.bintray.com/tvheadend/misc/staticlib/trusty/amd64/ffmpeg-0f0d717b4f5492eb025d57bc85e8eb6c6e66f42f.tgz
https://dl.bintray.com/tvheadend/misc/staticlib/vivid/amd64/ffmpeg-0f0d717b4f5492eb025d57bc85e8eb6c6e66f42f.tgz

that did not work ofcourse :).

So i build my own ffmpeg, sample encoding/transcoding is working with this ffmpeg(3.1) really fast, 120 - 250 fps depending on settings.
In result i tried to compile tvheadend like:
./configure --enable-nvenc --prefix=/bin --enable-zlib --enable-libav --enable-bundle --disable-avahi --disable-ffmpeg_static

which results in:

[email protected]:~/tvheadend# ./configure --enable-nvenc --prefix=/bin --enable-zlib --enable-libav --enable-bundle --disable-avahi --disable-ffmpeg_static
Checking support/features
  checking for cc execinfo.h ...                    ok
  checking for cc -mmmx ...                         ok
  checking for cc -msse2 ...                        ok
  checking for cc -Wunused-result ...               ok
  checking for cc getloadavg ...                    ok
  checking for cc atomic64 ...                      ok
  checking for cc atomic_time_t ...                 ok
  checking for cc bitops64 ...                      ok
  checking for cc lockowner ...                     ok
  checking for cc qsort_r ...                       ok
  checking for cc stime ...                         ok
  checking for cc gmtoff ...                        ok
  checking for cc recvmmsg ...                      ok
  checking for cc sendmmsg ...                      ok
  checking for cc libiconv ...                      fail
  checking for cc libdvben50221 ...                 fail
  checking for cc ifnames ...                       ok
  checking for py module gzip ...                   ok
  checking for pkg-config ...                       ok
  checking for xgettext ...                         ok
  checking for msgmerge ...                         ok
  checking for gzip ...                             ok
  checking for bzip2 ...                            ok
  checking for pkg openssl  ...                     ok (detected 1.0.2g)
  checking for cc linux/dvb/version.h ...           ok
  checking for pkg zlib  ...                        ok (detected 1.2.8)
  checking for pkg liburiparser  ...                ok (detected 0.8.4)
  checking for pkg libavfilter >=6.31.100 ...       fail (detected 5.0.0)
  checking for pkg libswresample >=2.0.101 ...      fail (detected 1.2.101)
  checking for pkg libavresample >=3.0.0 ...        fail (detected 2.1.0)
  checking for pkg libswscale >=4.0.100 ...         fail (detected 3.0.0)
  checking for pkg libavformat >=57.25.100 ...      fail (detected 56.1.0)
  checking for pkg libavcodec >=57.24.102 ...       fail (detected 56.1.0)
  checking for pkg libavutil >=55.17.103 ...        fail (detected 54.3.0)

Before i messarround with all those librarys i thought there is an easyer way.
simply include a correct static library/ffmpeg :)

Thanks.

History

#1

Updated by B C over 4 years ago

well you should not report the DL error as it is unlikely it is causing any problems, but we don't know your compilation error after that message so it will be hard to help you. I get the same message on debian but it builds fine with ffmpeg_static, just as the message says.

#2

Updated by Stephan Oelze over 4 years ago

B C wrote:

well you should not report the DL error as it is unlikely it is causing any problems, but we don't know your compilation error after that message so it will be hard to help you. I get the same message on debian but it builds fine with ffmpeg_static, just as the message says.

Sorry for being that unclear!
Download of ffmpeg sources failed -> ffmpeg isnt build -> only System ffmpeg is used

I was able to build a working system ffmpeg which is working great with nvenc. But in Future it could be easier for other users by building a static ffmpeg.

#3

Updated by B C over 4 years ago

ffmpeg_static builds fine with this error, so we still do not know how to help you

Also available in: Atom PDF