Project

General

Profile

Bug #3898

HTTP Authentication always fails

Added by Goncalo Luiz over 3 years ago. Updated over 3 years ago.

Status:
New
Priority:
Normal
Category:
Streaming
Target version:
-
Start date:
2016-07-16
Due date:
% Done:

0%

Estimated time:
Found in version:
HTS Tvheadend 4.1-2140~gf34fac1~wily
Affected Versions:

Description

Hi,

I am using HTS Tvheadend 4.1-2140~gf34fac1~wily

Clients using HTSP can correctly access the API and the streams but HTTP clients, like VLC, prompt for authentication. Even when providing the correct credentials, the stream never starts (depending on the client this results in an error, or prompting for credentials again).

There is no information in TVH logs.

Am I missing something ?

History

#1

Updated by Goncalo Luiz over 3 years ago

Hi,

I am using HTS Tvheadend 4.1-2140~gf34fac1~wily

Clients using HTSP can correctly access the API and the streams but HTTP clients, like VLC, prompt for authentication. Even when providing the correct credentials, the stream never starts (depending on the client this results in an error, or prompting for credentials again).

There is no information in TVH logs.

The user in question has all the checkboxes ticket (full access HTSP and HTTP + admin)

Am I missing something ?

#2

Updated by Goncalo Luiz over 3 years ago

Am I alone?

#3

Updated by Mark Clarkstone over 3 years ago

Goncalo Luiz wrote:

Am I alone?

I've just tested this and only needed to supply the correct credentials to VLC once, I do remember this happening quite often though in the past. Using VLC 2.2.4 here.

#4

Updated by Goncalo Luiz over 3 years ago

Mark Clarkstone wrote:

Goncalo Luiz wrote:

Am I alone?

I've just tested this and only needed to supply the correct credentials to VLC once, I do remember this happening quite often though in the past. Using VLC 2.2.4 here.

Whicj TVH version are you on? Do you mind sharing the settings for the user you are successfully authenticating with?

#5

Updated by Mark Clarkstone over 3 years ago

Goncalo Luiz wrote:

Mark Clarkstone wrote:

Goncalo Luiz wrote:

Am I alone?

I've just tested this and only needed to supply the correct credentials to VLC once, I do remember this happening quite often though in the past. Using VLC 2.2.4 here.

Whicj TVH version are you on? Do you mind sharing the settings for the user you are successfully authenticating with?

4.1.2126, as for the user I just checked all the boxes :)

#6

Updated by Goncalo Luiz over 3 years ago

Mark Clarkstone wrote:

Goncalo Luiz wrote:

Mark Clarkstone wrote:

Goncalo Luiz wrote:

Am I alone?

I've just tested this and only needed to supply the correct credentials to VLC once, I do remember this happening quite often though in the past. Using VLC 2.2.4 here.

Whicj TVH version are you on? Do you mind sharing the settings for the user you are successfully authenticating with?

4.1.2126, as for the user I just checked all the boxes :)

Not sure what changed, but it does work now, with VLC. I might have fiddled with digest/plain HTTP authentication.

TvhPlayer (OSx player) still repeatedly asks for the password, though.

Also available in: Atom PDF