Project

General

Profile

Feature #3852

Feature #3793: TVheadend should care about Power

Should get an Inhibitor from systemd when has active subscriptions

Added by Daniel Ribeiro about 6 years ago. Updated about 6 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
General
Target version:
-
Start date:
2016-06-11
Due date:
% Done:

0%

Estimated time:

Description

Hello,

Tvheadend should use the Inhibitor API (1) from systemd/logind to prevent/delay system suspend when it has active subscriptions.

I am currently using a python script that parses status.xml (2) and sets up a lock, but it's far from ideal.

(1) https://www.freedesktop.org/wiki/Software/systemd/inhibit/
(2) http://127.0.0.1:9981/status.xml

History

#1

Updated by Jaroslav Kysela about 6 years ago

  • Status changed from New to Rejected
  • Parent task set to #3793

Rejected as a duplicate of #3793 .

Also available in: Atom PDF