Project

General

Profile

Bug #3827

EMMs on a TivuSat card (nagra)

Added by Mario D over 3 years ago. Updated over 3 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-05-27
Due date:
% Done:

0%

Estimated time:
Found in version:
4.1-2074~gafae049
Affected Versions:

Description

Some weeks ago I pulled out of the drawer a TivuSat card (Nagra 183D) that I used more than one year ago. This kind of card doesn't expire but need a periodic refreshment of the rights.

I'm not able to make it work again using tvheadend + oscam (capmt net interface) sending it EMMs. I'm not sure if my oscam/tvheadend configurations are correct but I can't see any kind of EMM-related activities in tvheadend logs. Could you help in understanding if tvheadend is correctly forwarding the EMMs for my cards to oscam? It would be useful to indicate in what kind of log/trace of tvheadend or oscam I should be supposed to see an EMM-related activities of the two programs.

Is it a bug of tvheadend? I can't say yes but I can't say no...

tvheadend version: 4.1-2074~gafae049
tvheadend capmt configuration:

{
        "mode": 5,
        "camdfilename": "sauron",
        "port": 9000,
        "class": "caclient_capmt",
        "index": 1,
        "enabled": true,
        "name": "oscam" 
}

oscam version: 1.20-unstable_svn build r11194
oscam.conf:

[global]
logfile                       = syslog
clienttimeout                 = 15000
clientmaxidle                 = 1200
nice                          = -2
maxlogsize                    = 0
waitforcards                  = 0
lb_mode                       = 10
lb_nbest_readers              = 2

[dvbapi]
enabled                       = 1
au                            = 1
pmt_mode                      = 4
listen_port                   = 9000
user                          = mario
read_sdt                      = 1
write_sdt_prov                = 1
boxtype                       = pc

oscam.user:

[account]
user                          = mario
pwd                           = ******
caid                          = 183D
monlevel                      = 4
au                            = tivusat # it was '1' but it didn't change anything
group                         = 2
ident                         = 183D:000000

oscam.server:

[reader]
label                         = tivusat
description                   = TivSat smart-card
protocol                      = pcsc
device                        = 0:
caid                          = 183D
rsakey                        = **********
detect                        = cd
nagra_read                    = 1
ident                         = 183D:000000,005411
group                         = 2
emmcache                      = 1,3,15,0
auprovid                      = 005411 # added only on my latest tests

History

#1

Updated by Gigius 2016 over 3 years ago

Mario D wrote:

Some weeks ago I pulled out of the drawer a TivuSat card (Nagra 183D) that I used more than one year ago. This kind of card doesn't expire but need a periodic refreshment of the rights.

I'm not able to make it work again using tvheadend + oscam (capmt net interface) sending it EMMs. I'm not sure if my oscam/tvheadend configurations are correct but I can't see any kind of EMM-related activities in tvheadend logs. Could you help in understanding if tvheadend is correctly forwarding the EMMs for my cards to oscam? It would be useful to indicate in what kind of log/trace of tvheadend or oscam I should be supposed to see an EMM-related activities of the two programs.

Is it a bug of tvheadend? I can't say yes but I can't say no...

tvheadend version: 4.1-2074~gafae049
tvheadend capmt configuration:
[...]

oscam version: 1.20-unstable_svn build r11194
oscam.conf:
[...]

oscam.user:
[...]

oscam.server:
[...]

Hi Mario,
seem to be a configuration problem. I have a TivuSat 183E working with tvheadend and oscam with dvbapi net protocol.
I suggest you to open a thread in the forum, we will discuss it there.
Gigius

#2

Updated by Mario D over 3 years ago

I opened a thread on the forum: https://tvheadend.org/boards/13/topics/21141

#3

Updated by Mario D over 3 years ago

Dear Gigius, could you provide any hint on the configuration?

#4

Updated by Mario D over 3 years ago

As you can read from the thread on the forum, I solved my problem using a specific instruction in the oscam.dvbapi file. I don't understand why, but some notes should go in tvheadend documentation.

You can close this report.

#5

Updated by Jaroslav Kysela over 3 years ago

  • Status changed from New to Invalid

I am sorry, but it's out-of-scope of TVH to write specific hints for all crypto-systems. It's really an oscam config issue, so closing as 'Invalid'.

Also available in: Atom PDF