Project

General

Profile

Bug #3778

cannot (auto)build on Raspberry Pi 2

Added by g siviero over 4 years ago. Updated over 4 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
General
Target version:
-
Start date:
2016-05-05
Due date:
% Done:

0%

Estimated time:
Found in version:
4.1-1970~g06fdb8b
Affected Versions:

Description

using AUTOBUILD_CONFIGURE_EXTRA=--disable-libx265 ./Autobuild.sh the build process fails with:

...
CC              tvheadend
/usr/bin/ld: /opt/tvheadend/build.linux/ffmpeg/build/ffmpeg/lib/libx264.a(common.o): relocation R_ARM_MOVW_ABS_NC against `a local symbol' can not be used when making a shared object; recompile with -fPIC
/opt/tvheadend/build.linux/ffmpeg/build/ffmpeg/lib/libx264.a: error adding symbols: Bad value
collect2: error: ld returned 1 exit status
Makefile:609: set di istruzioni per l'obiettivo "/opt/tvheadend/build.linux/tvheadend" non riuscito
make[2]: *** [/opt/tvheadend/build.linux/tvheadend] Errore 1
make[2]: uscita dalla directory "/opt/tvheadend" 
debian/rules:11: set di istruzioni per l'obiettivo "override_dh_auto_build" non riuscito
make[1]: *** [override_dh_auto_build] Errore 2
make[1]: uscita dalla directory "/opt/tvheadend" 
debian/rules:5: set di istruzioni per l'obiettivo "build" non riuscito
make: *** [build] Errore 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Shouls I really "recompile with -fPIC" ?

History

#1

Updated by Jaroslav Kysela over 4 years ago

Could you test v4.1-1975-g0faba8a? Add '--disable-pie' to AUTOBUILD_CONFIGURE_EXTRA .

#2

Updated by g siviero over 4 years ago

I can confirm that version 4.1-1978~g496bc26 builds correctly or Rpi2 with the following command:

AUTOBUILD_CONFIGURE_EXTRA=--disable-libx265\ --disable-pie ./Autobuild.sh

(I still have to install and test it though)

#3

Updated by Jaroslav Kysela over 4 years ago

  • Status changed from New to Fixed

Also available in: Atom PDF