Project

General

Profile

Bug #3769

Truncated EPG

Added by Bengt Madeberg about 6 years ago. Updated over 5 years ago.

Status:
New
Priority:
Normal
Assignee:
Category:
EPG
Target version:
-
Start date:
2016-05-02
Due date:
% Done:

0%

Estimated time:
Found in version:
HTS Tvheadend 4.1-1933~g7f24603
Affected Versions:

Description

For some time (2-3 month ?) my OTA EIT EPG via Boxer in Sweden has been truncated. Sometimes only a word or two is shown. Sometimes a little bit more. During the time I have upgraded a couple of times without any improvements. Is there any setting I missed ?

XML EPG and Freesat/Open EPG does not have this issue.


Files

EPG2.png (115 KB) EPG2.png Bengt Madeberg, 2016-05-02 21:57
EPG3.png (130 KB) EPG3.png Bengt Madeberg, 2016-05-02 22:03
mux1021.ts (92.8 MB) mux1021.ts Bengt Madeberg, 2016-05-09 22:13
BBC.png (125 KB) BBC.png Bengt Madeberg, 2016-11-17 17:08
NRK.png (109 KB) NRK.png Bengt Madeberg, 2016-11-17 17:08
svt2.png (114 KB) svt2.png Bengt Madeberg, 2016-11-17 17:09
TV3.png (156 KB) TV3.png Bengt Madeberg, 2016-11-17 17:13
kodi_svt.png (181 KB) kodi_svt.png Bengt Madeberg, 2016-11-17 17:25
Kodi_BBC.png (249 KB) Kodi_BBC.png Bengt Madeberg, 2016-11-17 17:27
kodi_NRK.png (180 KB) kodi_NRK.png Bengt Madeberg, 2016-11-17 17:29
kodi_tv3.png (65.9 KB) kodi_tv3.png Bengt Madeberg, 2016-11-17 17:31
samsung_tv3.png (4.74 MB) samsung_tv3.png Bengt Madeberg, 2016-11-17 20:41
samsung_svt.png (5.18 MB) samsung_svt.png Bengt Madeberg, 2016-11-17 20:42

History

#1

Updated by Jaroslav Kysela about 6 years ago

Does other reception devices (TV, set-top-box) show this beahaviour, too?

Capture cca 30 seconds of your mux data (use the play link in the mux tab and wget or curl to save the contents to a file, attach it here).

#2

Updated by Bengt Madeberg about 6 years ago

Ok, I have been busy but here is a approx 30 s capture of one mux.

#3

Updated by Bengt Madeberg about 6 years ago

Ok I'm now use HTS Tvheadend 4.1-2045~gf027e3c since a week or so but still have the same EPG problems. In my TV the EPG is fine. Is the supplied file enough to analyze or should I do anything else ? Can my EPG database be corrupt ?

#4

Updated by Bengt Madeberg about 6 years ago

So is this a problem that can be solved or not ? I mean since version 2.12 of tvh to recently I had never any issues with the EPG. I don't think the operator has done any dramatic changes in the EPG protocol.

#5

Updated by Bengt Madeberg almost 6 years ago

So, is there any plan for this one ? Now using 4.1-2135 but still a lot of EPG issues. Please advice me if my setup is wrong and what I shall do...

#6

Updated by Mark Clarkstone almost 6 years ago

Bengt Madeberg wrote:

So, is there any plan for this one ? Now using 4.1-2135 but still a lot of EPG issues. Please advice me if my setup is wrong and what I shall do...

There is definitely something amiss with Tvheadend here, looking at your sample I can see complete (as in full descriptions are there) epg data in VLC.

Just some ideas, but..

  • Have you tried changing the charset?
  • Have you tried 4.0.9?
#7

Updated by Bengt Madeberg almost 6 years ago

Ok, thanks for suggestions. I will test to change the charset. I guess I can do it on MUX level. Right now it's not set at all. I have never changed it before. Secondly I will "downgrade" to 4.0.9.

#8

Updated by Bengt Madeberg almost 6 years ago

Tested with charset "auto", "UTF-8" and "ISO-8859-1" without success. When I "downgraded" to 4.0.9 all channels and muxes disappeared so it seems that some major configuration is changed..I have to setup a separate PC to test this since I don't want to destroy my main server. Or I go for XMLTV which seems to work without any issues...

#9

Updated by Bengt Madeberg over 5 years ago

I'm still struggling with this one. How to trace the problem ? Which text is used in kodi ?
This was working at least a year ago. I tried a lot of settings with charset etc without any success.

EPG over Freesat, works perfect...


EPG with XML, works perfect...


OTA EPG over the local DVB-T/T2 network does not work...Sometimes it looks like this...In Kodi there is just "Fråge..." and "Även i SVT..." which is shown perfect.


Sometimes like this...


#10

Updated by Bengt Madeberg over 5 years ago

I just want to add that except for the normal Swedish character åäö, ÅÄÖ ther are some other characters that I can se in my Samsung tv EPG, e.g. some commas ,,, colons :: and question marks ?? etc. Which should not be any special I guess.

From my Samsung TV

#11

Updated by Jaroslav Kysela over 5 years ago

Try to force charset ISO-6937. It's the default DVB charset.

#12

Updated by Bengt Madeberg over 5 years ago

Well, I did this test. Changed the character set under "network". It seems to be better from the truncated perspective. However the Swedish characters åöä are "sometimes" not shown properly. Some other strange characters are shown. Even the channel names where are changed in som cases. So this was not the solution. What about "language" settings in the general tab ?

#14

Updated by Bengt Madeberg over 5 years ago

Ok I have tested "Character Set: ISO-8859-15" a couple of days and I thought initially that it helped but now the EPG is worse than ever. Essentially, I think ISO-6937 was the right one except that it destroyed ÅÄÖ. I can't understand why this should be so difficult to get it right. Ok I will continue to experiment...

Also available in: Atom PDF