Project

General

Profile

Bug #363

Tvh git 6fa99fbd5* crash - gdb

Added by RoboSK - almost 12 years ago. Updated over 10 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Demultiplex
Target version:
Start date:
2011-01-27
Due date:
% Done:

0%

Estimated time:
Found in version:
unknown
Affected Versions:

Description

Unable to allocate 182402368 bytes

Program received signal SIGABRT, Aborted.
[Switching to Thread 0xb645bb70 (LWP 5384)]
0xb7fe1424 in kernel_vsyscall ()
(gdb)
--- --- --- --- --- ---
(gdb) info reg
eax 0x0 0
ecx 0x1508 5384
edx 0x6 6
ebx 0x1500 5376
esp 0xb645a7a8 0xb645a7a8
ebp 0xb645a7c0 0xb645a7c0
esi 0xadf3d40 182402368
edi 0xb7e08ff4 1210019852
eip 0xb7fe1424 0xb7fe1424 <__kernel_vsyscall+16>
eflags 0x200206 [ PF IF ID ]
cs 0x73 115
ss 0x7b 123
ds 0x7b 123
es 0x7b 123
fs 0x0 0
gs 0x33 51
(gdb)
--
--- --- --- --- ---
(gdb) disassemble $pc-32,$pc+32
Dump of assembler code from 0xb7fe1404 to 0xb7fe1444:
0xb7fe1404 <__kernel_sigreturn+4>: add al,(%eax)
0xb7fe1406 <__kernel_sigreturn+6>: int $0x80
0xb7fe1408 <__kernel_sigreturn+8>: nop
0xb7fe1409: lea 0x0(%esi),%esi
0xb7fe140c <__kernel_rt_sigreturn+0>: mov $0xad,%eax
0xb7fe1411 <__kernel_rt_sigreturn+5>: int $0x80
0xb7fe1413 <__kernel_rt_sigreturn+7>: nop
0xb7fe1414 <__kernel_vsyscall+0>: push %ecx
0xb7fe1415 <__kernel_vsyscall+1>: push %edx
0xb7fe1416 <__kernel_vsyscall+2>: push %ebp
0xb7fe1417 <__kernel_vsyscall+3>: mov %esp,%ebp
0xb7fe1419 <__kernel_vsyscall+5>: sysenter
0xb7fe141b <__kernel_vsyscall+7>: nop
0xb7fe141c <__kernel_vsyscall+8>: nop
0xb7fe141d <__kernel_vsyscall+9>: nop
0xb7fe141e <__kernel_vsyscall+10>: nop
0xb7fe141f <__kernel_vsyscall+11>: nop
0xb7fe1420 <__kernel_vsyscall+12>: nop
0xb7fe1421 <__kernel_vsyscall+13>: nop
0xb7fe1422 <__kernel_vsyscall+14>: jmp 0xb7fe1417 <__kernel_vsyscall+3>
=> 0xb7fe1424 <__kernel_vsyscall+16>: pop %ebp
0xb7fe1425 <__kernel_vsyscall+17>: pop %edx
0xb7fe1426 <__kernel_vsyscall+18>: pop %ecx
0xb7fe1427 <__kernel_vsyscall+19>: ret
0xb7fe1428: add %ch,(%esi)
0xb7fe142a: jae 0xb7fe1494
0xb7fe142c: jae 0xb7fe14a2
0xb7fe142e: jb 0xb7fe14a4
0xb7fe1430: popa
0xb7fe1431: bound %eax,(%eax)
0xb7fe1433: cs
0xb7fe1434: push $0x687361
0xb7fe1439: cs
0xb7fe143a: fs
0xb7fe143b: jns 0xb7fe14ab
0xb7fe143d: jae 0xb7fe14b8
0xb7fe143f: insl (%dx),%es:(%edi)
0xb7fe1440: add %ch,(%esi)
0xb7fe1442: fs
0xb7fe1443: jns 0xb7fe14b3
End of assembler dump.
(gdb)
--- --- --- --- --- ---
(gdb) bt full
#0 0xb7fe1424 in _kernel_vsyscall ()
No symbol table info available.
#1 0xb7cebc91 in raise () from /lib/libc.so.6
No symbol table info available.
#2 0xb7ced51e in abort () from /lib/libc.so.6
No symbol table info available.
#3 0x0805d8c9 in parse_mpeg2video (t=0x83ae310, st=0x83ae550, len=11114, next_startcode=256, sc_offset=18478)
at /DATA/_source
/tvheadend/tvheadend-git_2011_01_25+patchset-001/src/Tvheadend-git-build/src/parsers.c:1022
pkt = <value optimized out>
buf = <value optimized out>
bs = {
rdata = 0x2878a83a "*r\301\223\233|\t\177\372\304x\222\061\216\035\234\267\300\065\216\343\350p\310f\214Ď\250\341\064\346
\250\bC\026\006\240\063\230\265\306S\266\216\212\227\300\220\\\245^P\316\006\300gb\343f\350\002ab\247\021\205Ó\n\264\331\342[\034\036×´!\200\262%\234|\234\354G\320\017\251\326\b\020\254\330\370MR\026\325L8f\fK*\234\322\324\342\004\032y\267Nk\371\224\342\004$\313\326mg\021\062x\235t8T(\005\203\020)\341\233\063\232.x\bQSX\225\240*\207\335\352U(8f\f\265\017\367\214\021I\270T\324\070T\f\001\nÓĽŃż\235p\305P\341\220\060\302\[email protected]\031\371-\235\311]\203Q\200\371\246\001\271"..., wdata = 0x0,
offset = 0, len = 88880}
frametype = <value optimized out>
#4 0x0805c411 in parse_sc (t=0x83ae310, st=0x83ae550, data=0xad7b4410 "", len=184, vp=0x805d440 <parse_mpeg2video>)
at /DATA/_source_/tvheadend/tvheadend-git_2011_01_25+patchset-001/src/Tvheadend-git-build/src/parsers.c:328
sc = 256
i = <value optimized out>
r = <value optimized out>
_PRETTY_FUNCTION
= "parse_sc"
#5 0x0805e93f in ts_recv_packet0 (t=0x83ae310, st=<value optimized out>, tsb=0xad7b440c "GA\222\030")
at /DATA/_source
/tvheadend/tvheadend-git_2011_01_25+patchset-001/src/Tvheadend-git-build/src/tsdemux.c:122
off = <value optimized out>
pusi = 1
cc = <value optimized out>
error = 0
#6 0x08070050 in cwc_descramble (td=0xad78d7c8, t=0x83ae310, st=0x83ae550,
tsb=0xb645ae1c "G\001\222\321\357\006\310k]Čżb\267\337a\a\n\202\356\212\377|x\bv\312\320(\247\071xH\347Ä­&\244\003\002\340#K\021\032k\361\025e\a/\232\023\215>\r\267\225Lq\266\350EB\217\255\\\340\236m\\\240\353\273\030\274CÎ\274Ta\316W\252\030q\321\070\002<\251>NR\260\277Z\350\032\322\343\020Ó\331\330\034`\346\371M\037\rÉ") at /DATA/_source_/tvheadend/tvheadend-git_2011_01_25+patchset-001/src/Tvheadend-git-build/src/cwc.c:1645
i = <value optimized out>
t0 = 0xad7b440c "GA\222\030"
ct = 0xad78d7c8
r = 133
vec = {
0xad7b879c "G\001\222\333I\206\344\243\314\002\302~v\214L\277\372\277k\241\310\030\276/\201\372$\243\377\237\366l5\r\312[\002\245\264\330\367s\031}\211\063hDPQ\034\071\027\260\241\063\061/\227\017eU\316\352\204[\304\373\322\005\340\354\026\235T\273'\022\325\350\336D\275K\025\347\320NO\356\027\\h\244P\232t\333\377\365=;Z\026\064\333:\327|\303e\024É
PRETTY_FUNCTION = "cwc_descramble"
#7 0x0805edd5 in ts_recv_packet1 (t=0x83ae310,
tsb=0xb645ae1c "G\001\222\321\357\006\310k]Čżb\267\337a\a\n\202\356\212\377|x\bv\312\320(\247\071xH\347Ä­&\244\003\002\340#K\021\032k\361\025e\a/\232\023\215>\r\267\225Lq\266\350EB\217\255\\\340\236m\\\240\353\273\030\274CÎ\274Ta\316W\252\030q\321\070\002<\251>NR\260\277Z\350\032\322\343\020Ó\331\330\034`\346\371M\037\rÉ", pcrp=0x0) at /DATA/_source_/tvheadend/tvheadend-git_2011_01_25+patchset-001/src/Tvheadend-git-build/src/tsdemux.c:239
st = 0x83ae550
n = 1
m = <value optimized out>
r = <value optimized out>
td = 0xad78d7c8
error = 0
#8 0x08080258 in dvb_adapter_input_dvr (aux=0x81f0cc8)
at /DATA/_source_/tvheadend/tvheadend-git_2011_01_25+patchset-001/src/Tvheadend-git-build/src/dvb/dvb_adapter.c:540
tda = 0x81f0cc8
fd = 11
i = <value optimized out>
r = 1880 \213/\254\265\310)\212\027C\302\026O\277\270\061\307kg\002\241Y\221e\226 \234L<\217\351q\020\357\366;\341\335R\b\036\250\032Z\266\247o\346e\034\216\250{\253D\256\267z\024\331\345\030\272\032\241Uq\365AX(\357\342\066\252YP_a\250\365\272k\003\222\361\362\263[\[email protected]\a\347c\232e\363Ea\023\vu\204\376\332oA\322\333\031UE\325\360\"\177C\024\232T\253\300iÜŁ\210JP\261\244:j\036\251\375Cz\022\312\a\201\023\---Type <return> to continue, or q <return> to quit---
366i\210{\351\356g\323\061h\357vaČš\250\314\367\202}\"\\\372\316\323t<G\001\222ß
+\273E\244\310\t\246\030\263\304\tÎ\032\020R\332\312%\223\020\241\354~Em\361#\\`K\017\301Vk\271\204h\326y\337N8C\[email protected]_\200\264\316\352\\\201{\255K\306\002BZ\216\232\a\256\071i\371\071\274\361\033\361\000\323'\365i\312\b\310d\273\373fY8x\024t\t\320\360z\204\005\064uҵt2o\003\363h\224\342\330\"t;\375\360\372\360\030\247\027C\211\246\215\372\264\067\250\070\\\004\f\227\347\066\263V\207<T\022Fc\f\301\033\357#\305>\355\212\024\250ɦV\247\324$\034\231\326w\311\307P#Î
:\277n\223\331\005\005\326\035"...
t = 0x83ae310
#9 0xb7e12dd0 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#10 0xb7d8fd2e in clone () from /lib/libc.so.6
No symbol table info available.
(gdb)
--- --- --- --- --- ---

History

#1

Updated by Andreas Smas over 11 years ago

  • Category set to Demultiplex
  • Status changed from New to Accepted
  • Assignee set to Andreas Smas
  • Target version set to 2.13

This is an old issue that i've not been able to figure out the root cause of.

#2

Updated by Adam Sutton over 10 years ago

  • Status changed from Accepted to Rejected
  • Found in version set to unknown

No idea if this is still an issue but the report is very old, if its still happening with latest code can you please re-submit.

Also available in: Atom PDF