Project

General

Profile

Bug #3602

Package repository not functioning properly

Added by Diego Rivera almost 4 years ago. Updated almost 4 years ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
-
Start date:
2016-02-29
Due date:
% Done:

0%

Estimated time:
Found in version:
N/A (APT repository)
Affected Versions:

Description

After following the instructions at https://tvheadend.org/projects/tvheadend/wiki/AptRepository , I get the following errors:

W: Failed to fetch http://dl.bintray.com/tvheadend/deb/dists/trusty/Release  Unable to find expected entry 'trusty/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

This also happens with wheezy on a Raspberry PI (though the error is obviously slightly different due to the different targets).

This is the content of the tvheadend.list package declaration file:

deb http://dl.bintray.com/tvheadend/deb trusty trusty stable
# deb-src http://dl.bintray.com/tvheadend/deb trusty trusty stable

However, using the old repository still works fine:

deb http://apt.tvheadend.org/stable trusty main
# deb-src http://apt.tvheadend.org/stable trusty main

History

#1

Updated by Diego Rivera almost 4 years ago

UPDATE: I found the issue with the instructions. These incorrectly indicate that one should add the DISTRO as part of the apt-add-repository command, but this shouldn't be the case. The correct instructions should read:

sudo apt-add-repository "http://dl.bintray.com/tvheadend/deb BUILDTYPE" 
sudo apt-get update
sudo apt-get install tvheadend

Importantly, the source DEB packages aren't available via the new repository (deb-src), so rebuilding the TVH DEB packages via the Deb/dpkg build toolset is impossible at this time (using the new repository). This should be corrected ASAP as it limits the ability of folks that need to cook their own versions (i.e. with libhdhomerun support).

Cheers!

#2

Updated by Mark Clarkstone almost 4 years ago

Diego Rivera wrote:

UPDATE: I found the issue with the instructions. These incorrectly indicate that one should add the DISTRO as part of the apt-add-repository command, but this shouldn't be the case. The correct instructions should read:

[...]

Importantly, the source DEB packages aren't available via the new repository (deb-src), so rebuilding the TVH DEB packages via the Deb/dpkg build toolset is impossible at this time (using the new repository). This should be corrected ASAP as it limits the ability of folks that need to cook their own versions (i.e. with libhdhomerun support).

Cheers!

I've corrected the instructions, thanks for pointing this out :)

#3

Updated by James Denney almost 4 years ago

Wiki instructions are incorrect for Raspberry Pi Jessie sources.list as of 3/12/16. Previous suggestions are incorrect. Took me a minute to figure it out - correct entry sould read:

deb http://dl.bintray.com/tvheadend/deb/ jessie release

"release" is the only up-to-date BUILDTYPE selection.

#4

Updated by Mark Clarkstone almost 4 years ago

  • Status changed from New to Accepted

I'm setting this as accepted as there's some obvious issues with the repositories.

I've double checked on three of my systems and the old "distro buildtype" was correct and I've updated the wiki yet again. I've also made a few alterations and added a note about raspberry pi builds.

Also available in: Atom PDF