Project

General

Profile

Bug #3549

TVHeadend does not detect HDHomeRun adapters that appear after starting

Added by Michael Marley over 5 years ago. Updated about 5 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
DVB
Target version:
Start date:
2016-02-03
Due date:
% Done:

100%

Estimated time:
Found in version:
4.0.8
Affected Versions:

Description

I am using TVHeadend with an HDHomeRun Connect device using the native interface (not dvbhdhomerun). I have noticed that if for any reason the HDHomeRun is not accessible on the network when TVHeadend starts, the tuner will never become available and TVHeadend must be manually restarted to make it work again. This is an issue for me because my network switch takes significantly longer to boot than my TVHeadend box, so if all the devices are started at the same time, manual intervention is required to make TVHeadend detect the HDHomeRun.

Associated revisions

Revision 99f0a450 (diff)
Added by Jaroslav Kysela over 5 years ago

tvhdhomerun: add discovery thread (interval 15 seconds), fixes #3549

History

#1

Updated by Jaroslav Kysela over 5 years ago

  • Target version set to 4.2
#2

Updated by Jaroslav Kysela over 5 years ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100
#3

Updated by Jaroslav Kysela over 5 years ago

If would be nice, if you could test the latest tvh code - v4.1-1467-g99f0a45 . I might eventually backport this to 4.0.x ...

#4

Updated by Asko Soukka about 5 years ago

I also had this issue with 4.0.x, but the latest code has been working for me.

Also available in: Atom PDF