Project

General

Profile

Bug #3320

mpeg2 video / kodi: dropped and skipped frames

Added by Jerome Wilkins over 5 years ago. Updated about 5 years ago.

Status:
Invalid
Priority:
Normal
Category:
-
Target version:
Start date:
2015-11-18
Due date:
% Done:

0%

Estimated time:
Found in version:
4.1-999
Affected Versions:

Description

Getting a lot of dropped and skipped frames in koi frontend.
when starting certain channels I get this in the log
ERROR: ffmpeg[7FE92AFFD700]: [mpeg2video] Invalid frame dimensions 0x0.
I can also reproduce using the webui to stream a channel.


Files

kodi.log (2.64 MB) kodi.log Jelly Frog, 2016-03-30 17:48
hts.log (5.33 KB) hts.log Jelly Frog, 2016-03-30 17:55

Associated revisions

Revision 12be36f6 (diff)
Added by Jaroslav Kysela over 5 years ago

parser: copy metadata to the first frame, fixes #3320

History

#1

Updated by steve miller over 5 years ago

Jerome Wilkins wrote:

ERROR: ffmpeg[7FE92AFFD700]: [mpeg2video] Invalid frame dimensions 0x0.
I can also reproduce using the webui to stream a channel.

Confirmed. I get these errors as well with choppy video usually 1080 or 720. I do not have a problem in the web GUI.

I also get:
21:35:36 T:139663922677504 ERROR: Decode - avcodec_decode_video returned failure

System:
Kodi v15.2 “Isengard” on a Dell GX620
HDHR tuner. (just using one tuner for OTA)
Wired Network
no CPU issues.
TVheadend is on another GX620.

LOGS:
PastBin: http://paste.ubuntu.com/14728555/

Configure arguments:
--build=i686-linux-gnu --prefix=/usr --includedir=${prefix}/include --mandir=${prefix}/share/man --infodir=${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --libexecdir=${prefix}/lib/tvheadend --disable-maintainer-mode --disable-dependency-tracking

Compiler:
Using C compiler: cc
Build for arch: x86_64

Binaries:
Using PYTHON: python
Using GZIP: gzip
Using BZIP2: bzip2

Options:
cwc yes
capmt yes
constcw yes
linuxdvb yes
satip_server yes
satip_client yes
hdhomerun_client yes
hdhomerun_static yes
iptv yes
tsfile yes
dvbscan yes
timeshift yes
trace yes
imagecache yes
avahi yes
zlib yes
libav yes
libffmpeg_static yes
libx264_static yes
libx265 no
libx265_static no
vdpau no
nvenc no
libmfx no
libmfx_static no
inotify yes
epoll yes
uriparser yes
ccache no
tvhcsa yes
bundle no
dvbcsa no
dvben50221 no
kqueue no
dbus_1 yes
android no
tsdebug no
gtimer_check no
libsystemd_daemon no
bintray_cache yes
execinfo yes
mmx yes
sse2 yes
W_unused_result yes
getloadavg yes
atomic64 yes
atomic_time_t yes
lockowner yes
qsort_r yes
stime yes
gmtoff yes
recvmmsg yes
sendmmsg yes
ifnames yes
py_gzip yes
bin_pkg_config yes
bin_xgettext yes
bin_msgmerge yes
bin_gzip yes
bin_bzip2 yes
ssl yes
linuxdvbapi yes
upnp yes
inotify_h yes
mpegts yes
mpegts_dvb yes

Packages:
openssl 1.0.1f
zlib 1.2.8
liburiparser 0.7.5
avahi-client 0.6.31
dbus-1 1.6.18

Installation paths:
Prefix: /usr
Binaries: ${prefix}/bin
Libraries: ${prefix}/lib
Data files: ${prefix}/share
Man pages: /usr/share/man

#2

Updated by steve miller over 5 years ago

TVheadend version:
Build: 4.1-1408~g045f739~trusty (2016-01-21T00:35:22+0000)

#3

Updated by Jaroslav Kysela over 5 years ago

Could you try to disable hardware video decoder in kodi?

#4

Updated by steve miller over 5 years ago

Jaroslav Kysela wrote:

Could you try to disable hardware video decoder in kodi?

When I disable DXVA2 hardware acceleration the symptom goes away. Hardware acceleration is preferable of course, but the CPU can handle decoding just fine. So while the problem is not fixed, the symptom is!

#5

Updated by Jaroslav Kysela over 5 years ago

  • Status changed from New to Invalid

But it's kodi issue then... Report this there..

#6

Updated by Jaroslav Kysela over 5 years ago

Could you try v4.1-1459-gc8810d2 ? Also, could you report your result for the hw decoder when 'use packet backlog' in the general configuration is turned on ?

#7

Updated by Jerome Wilkins over 5 years ago

The issue still persist with latest version of tvheadend. I turned on packet backlog and I still get those errors in the log with a lot of drops and skips. I tried with mpeg2 decoding disabled and I get the same results.
http://paste.ubuntu.com/14954229/

#8

Updated by Jaroslav Kysela over 5 years ago

  • Subject changed from dropped and skipped frames to mpeg2 video / kodi: dropped and skipped frames
#9

Updated by Jaroslav Kysela over 5 years ago

  • Assignee set to Jaroslav Kysela
  • Target version set to 4.2

OK. So this bug is in tvh 3.9+ (any version), isn't ? The backlog is only implemented for h264 for the moment. I should read the error line more carefully next time.

#10

Updated by Jerome Wilkins about 5 years ago

I tried out the mpeg2 packet backlog version and sometimes when the video start I get green artifacts or the whole screen would be distorted, however when checking the kodi logs I dont get this error no more. ERROR: ffmpeg[7FE92AFFD700]: [mpeg2video] Invalid frame dimensions 0x0.

#11

Updated by Jaroslav Kysela about 5 years ago

Jerome Morrow: The problems are at the video start only or also when the stream continues ? As I understand correctly, do you use Intel GMA 950 graphics?

#12

Updated by B C about 5 years ago

isn't this expected as the backlog must not start on an I frame?

#13

Updated by Jerome Wilkins about 5 years ago

Yes it happens at the start of the video and as the video continues. I use intel haswell graphics.

#14

Updated by Jelly Frog about 5 years ago

Having the same issues, stuttering, skipped frames... Playing the source (http iptv) directly works flawless
See attached logs from kodi/hts

Using:
Tvheadend 4.1-1724~g41707e1~trusty
Kodi 16.1 RC2

Also available in: Atom PDF