Project

General

Profile

Bug #3316

No channels will start playback

Added by Martin Ayla over 5 years ago. Updated over 5 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-11-18
Due date:
% Done:

0%

Estimated time:
Found in version:
4.1-998~gcf47a5d
Affected Versions:

Description

Hi

Yesterday all channel playback stopped working (I had not changed anything in Tvheadend or Kodi).

I'm using Tvheadend on Debian with two HDHomerun HDHR3-EU and Kodi 15.2 as the client with the built-in pvr.hts add-on.

If I use another client to do the playback, directly from the HDHomerun's, without using Tvheadend, all channels work fine, so the problem must be between Tvh and Kodi.

When starting playback, Kodi says "buffering..." and it just hangs there.

Tvh outputs this in the log:
Nov 18 09:50:20 debian_tvh tvheadend[2719]: tvhdhomerun: failed to set target: 0
Nov 18 09:50:20 debian_tvh tvheadend[2719]: tvhdhomerun: failed to set_tuner_filter: 0
Nov 18 09:50:20 debian_tvh tvheadend[2719]: tvhdhomerun: failed to set_tuner_filter: 0
Nov 18 09:50:20 debian_tvh tvheadend[2719]: tvhdhomerun: failed to set_tuner_filter: 0
Nov 18 09:50:20 debian_tvh tvheadend[2719]: tvhdhomerun: failed to set_tuner_filter: 0
Nov 18 09:50:20 debian_tvh tvheadend[2719]: tvhdhomerun: failed to set_tuner_filter: 0
Nov 18 09:50:20 debian_tvh tvheadend[2719]: tvhdhomerun: failed to set_tuner_filter: 0
Nov 18 09:50:20 debian_tvh tvheadend[2719]: tvhdhomerun: failed to set_tuner_filter: 0
Nov 18 09:50:20 debian_tvh tvheadend[2719]: tvhdhomerun: failed to set_tuner_filter: 0
Nov 18 09:50:20 debian_tvh tvheadend[2719]: tvhdhomerun: failed to set_tuner_filter: 0
Nov 18 09:52:20 debian_tvh tvheadend[2719]: tvhdhomerun: failed to set_tuner_filter: 0
Nov 18 09:52:20 debian_tvh tvheadend[2719]: tvhdhomerun: failed to set_tuner_filter: 0
Nov 18 09:52:20 debian_tvh tvheadend[2719]: tvhdhomerun: failed to set_tuner_filter: 0
Nov 18 09:53:20 debian_tvh tvheadend[2719]: subscription: 0007: service instance is bad, reason: No input detected
Nov 18 09:54:20 debian_tvh tvheadend[2719]: subscription: 0007: No input source available for subscription "10.0.1.199 ... "DR3"

Any ideas?

Thanks,

History

#1

Updated by Martin Ayla over 5 years ago

Some extra info:

If I restart the Tvheadend service, I can always start the first channel and it works fine, but I can do any subsequent channel changes, if I try and change the channel the above errors happen.

#2

Updated by Martin Ayla over 5 years ago

Also: Sometimes (but not always) the channel starts to play after several minutes of waiting.

#3

Updated by Martin Ayla over 5 years ago

Update: I was scanning my syslog and noticed these errors:
systemd-timesyncd[215]: interval/delta/delay/jitter/drift 32s/-73.623s/0.010s/55.650s/+0ppm
systemd-timesyncd[215]: interval/delta/delay/jitter/drift 64s/+0.000s/0.014s/55.650s/+0ppm
systemd-timesyncd[215]: System time changed. Resyncing.

So I disabled my systems ntp time sync (through systemd) and immediately Tvheadend started working!?

Anyone know how that can be, how the ntp time sync can be connected to Tvheadend not tuning any channels and timing out?

Also available in: Atom PDF