Project

General

Profile

Bug #3272

atsc epg data not populated - possible regression

Added by Steve Smith almost 6 years ago. Updated almost 6 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
Category:
EPG
Target version:
-
Start date:
2015-11-05
Due date:
% Done:

0%

Estimated time:
Found in version:
4.1-855-g646a663
Affected Versions:

Description

I installed v4.1-855-g646a663 because of the atsc-epg crash fix. Had it running for three days but noticed only some of the shows were recorded. Most every channel did not have any epg data. Only the channels that have several days of epg data was populated. I manually updated the epg data and noticed the status of that was fine, however the epg data did not show up in the program guide. This is a possible regression from the crash fix in version v4.1-822-g18d993f where the epg data problem was fixed. I tried restarting tvheadend and then my computer to no avail. I have enclosed a before and after snapshot of the configuration and a debug log. Thank you.


Files

tvheadend.debug.log (1.78 MB) tvheadend.debug.log Steve Smith, 2015-11-05 13:34
tvheadend.zip (238 KB) tvheadend.zip before Steve Smith, 2015-11-05 13:35
tvheadend.zip (211 KB) tvheadend.zip after Steve Smith, 2015-11-05 13:35
tvheadend.debug.log (387 KB) tvheadend.debug.log debug log with psip trace enabled Steve Smith, 2015-11-05 17:59
tvheadend.debug.log (984 KB) tvheadend.debug.log Steve Smith, 2015-11-05 20:19

History

#1

Updated by Jaroslav Kysela almost 6 years ago

Debug log is not enough, provide --trace psip - https://tvheadend.org/projects/tvheadend/wiki/Traces when you tune to a channel where EPG is missing.

#2

Updated by Steve Smith almost 6 years ago

I have enabled the psip trace as per your request. I restarted and let it scan the psip data for each channel.

#3

Updated by Jaroslav Kysela almost 6 years ago

Do you have mapped all channels or only some ? Which channel from the above log has missing EPG ?

#4

Updated by Steve Smith almost 6 years ago

WNDY, WTHR, WISH, and WFYI are completely empty. Basically, ABC, CBS, NBC, and PBS. WXIN (FOX) and WTTK is populated but I am unsure if it is updating as it populates for several days. I have rescanned about six times to no avail. I am thinking but am unsure that when I installed it on Nov 3, at 21:59 it didn't work then but I didn't notice it because most of my shows that I record are on WXIN and WTTK. None of the shows on the other channels recorded so I am thinking that this version never updated the epg.

#5

Updated by Steve Smith almost 6 years ago

Oh, all of the channels are mapped except for WTTV which is WTTK but further away from me. WIPX is mapped but is non-tunable, should I remove it?

#6

Updated by Jaroslav Kysela almost 6 years ago

It should not harm.

Please, upgrade to v4.1-871-ga84fdaa and provide this log again with this version.

#7

Updated by Steve Smith almost 6 years ago

Erm... I don't think this was supposed to happen but after updating to v4.1-871-ga84fdaa the epg is now working. I didn't do anything to the configuration or restart or anything. I used the exact same compilation method. I guess I'll keep an eye on it. Still enclosed the log anyway. I honestly don't know what happened. I only changed one thing. I disabled WIPX in my channel list and remapped but that couldn't affect it.

#8

Updated by Jaroslav Kysela almost 6 years ago

Hi, I need help with testing. I added new code and improved almost everything in the psip grabber. Could you, please, retest ? v4.1-894-ga27b0af

#9

Updated by Steve Smith almost 6 years ago

OK. I've downloaded the latest version and am now testing it with psip debug logging turned on. I am running it through valgrind as per the instructions on another issue #3274. Thank you for adding atsc-epg to tvheadend.

#10

Updated by Steve Smith almost 6 years ago

I just thought I would check in and tell you that I have been running v4.1-894-ga27b0af for 5 days straight and have had no problems whatsoever. I don't use all of the features though. I only schedule OTA recordings and record them in raw format. When I was using the fork from Lauri Mylläri, I noticed that would schedule the wrong recordings sometimes but that hasn't happened with this version. It still requires more testing but I believe it has come a long way.
Thanks again!

#11

Updated by Jaroslav Kysela almost 6 years ago

  • Status changed from New to Fixed

Thanks for the feedback. I'm closing this. Please, open a new issue, if you have any issues.

Also available in: Atom PDF