Project

General

Profile

Bug #3259

http mpeg-ts gstreamer broken

Added by Christian Brauwers almost 7 years ago. Updated almost 7 years ago.

Status:
Invalid
Priority:
Normal
Category:
Streaming
Target version:
-
Start date:
2015-11-03
Due date:
% Done:

0%

Estimated time:
Found in version:
4.1-830~gaeb20ca
Affected Versions:

Description

Hey,
i'm trying to stream with gstreamer souphttpsrc via Raspberry Pi.
I'm using patched omx version on rpi2 from gkreidl ... sometimes i have luck an can stream a channel.

But almost i only see the connect from gstreamer to tvheadend, i see the Tuner is tuning .. then a few seconds Input and Output are good, then output goes to zero (without any log entries) ... Input still up and running ...

Tried with User/Pass and without ...
Whats going Wrong?

History

#1

Updated by Jaroslav Kysela almost 7 years ago

I think that I analyzed a stream from raspberry a few days ago and there were missing timing information (in VUI block) which should be broadcasted in regular intervals. TVH takes this stream as invalid.

#2

Updated by Christian Brauwers almost 7 years ago

Jaroslav Kysela wrote:

I think that I analyzed a stream from raspberry a few days ago and there were missing timing information (in VUI block) which should be broadcasted in regular intervals. TVH takes this stream as invalid.

i think you missunderstood me : I want to stream from TVHeadend over an rpi2 (with gstreamer) ...

#3

Updated by Jaroslav Kysela almost 7 years ago

Have you tried wget ? Just to make sure that TVH delivers the stream? It seems that your "comsumer" application stalled.

#4

Updated by Christian Brauwers almost 7 years ago

Jaroslav Kysela wrote:

Have you tried wget ? Just to make sure that TVH delivers the stream? It seems that your "comsumer" application stalled.

I have 2 RPi2 with Kodi up and running without problems (HTSP) and also i can use VLC direct without problem.
Internal transcoding is working too ...

Sometimes it is working with the http-launch ... but most off the time not ... very strange

#5

Updated by Jaroslav Kysela almost 7 years ago

Just try 'wget -O /dev/null <tvh_streaming_url>' - you'll see if the stream is delivered fine. If the output statistics is not updated it means that TVH cannot send more data through the network connection (the other side does not accept them).

#6

Updated by Christian Brauwers almost 7 years ago

Jaroslav Kysela wrote:

Just try 'wget -O /dev/null <tvh_streaming_url>' - you'll see if the stream is delivered fine. If the output statistics is not updated it means that TVH cannot send more data through the network connection (the other side does not accept them).

works without any problems ... stream is running ...

#7

Updated by Jaroslav Kysela almost 7 years ago

  • Status changed from New to Invalid

OK. Then check why your app stalls - use strace or check CPU usage (if it's 100% then the application has a deadlock). The network/data transfer seems fine. Anyway, it's out of scope of TVH support. Closing as invalid.

Also available in: Atom PDF