Project

General

Profile

Bug #3137

Increasing service list

Added by Raymond Paulsen about 6 years ago. Updated about 6 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
Service Mapping
Target version:
Start date:
2015-10-07
Due date:
% Done:

100%

Estimated time:
Found in version:
HTS Tvheadend 4.1-560~g5355464
Affected Versions:

Description

It seems to me the idle scan routine or something like that is creating a bunch of new services on each run.
i doubt it should be like this, some muxes has almost 400 services?

it cant be that my digbit r1 satip tuner with satip-axe firmware is doing some kind of rewrite og the pmt/sdt tables?

attached some pictures of the problem.


Files

nr1.jpg (83.3 KB) nr1.jpg Raymond Paulsen, 2015-10-07 19:53
nr2.jpg (382 KB) nr2.jpg Raymond Paulsen, 2015-10-07 19:53
nr3.jpg (146 KB) nr3.jpg Raymond Paulsen, 2015-10-07 19:53

Associated revisions

Revision e79ea981 (diff)
Added by Jaroslav Kysela about 6 years ago

SAT>IP client: add 'Skip TS packets (0-200)' option, fixes #3137

History

#1

Updated by Jaroslav Kysela about 6 years ago

  • Target version set to 4.2
#2

Updated by Jaroslav Kysela about 6 years ago

Minisatip does not do any rewrites. The reason might be that mpeg-ts packets from previous mux are sent to the client (some remaining driver problem) after a new tune, or it's TVH bug somewhere. Note that the idle scan is not recommended for standard installation (what's the benefit to endlessly scan a network?).

I'll give a quick look when my time permits.

#3

Updated by Jaroslav Kysela about 6 years ago

I can confirm that behaviour. It seems that few starting mpeg-ts packets are old from a fifo in some cases. I'll try do further investigation.

#4

Updated by Jaroslav Kysela about 6 years ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100
#5

Updated by Jaroslav Kysela about 6 years ago

It's definitely problem with the satip-axe firmware. I added new option 'Skip TS packets' to the SAT>IP server settings. With value 30, I can do safe scans. I created new issue for the satip-axe firmware to resolve this directly in the firmware: https://github.com/perexg/satip-axe/issues/33 .

TVH version: v4.1-580-ge79ea98

#6

Updated by Raymond Paulsen about 6 years ago

Thank you, fast guy i see :-)

I was also considering it to be a problem related to diseq switching. I remember there
was a issue with tvheadend regarding this when diseq 1.1 was implemented, same error signature.

ok so i understand you skip the 30 first packets on incoming flow from minisatip server.

so the problem is a buffer is not flushed after/before new tune on the minisatip server?

is there coming a v11 of satip-axe?

Also available in: Atom PDF