Project

General

Profile

Bug #3066

Choppy playback: asked for new data packet, with nothing available

Added by J H about 5 years ago. Updated about 5 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-09-05
Due date:
% Done:

0%

Estimated time:
Found in version:
4.1-389~g10d7654
Affected Versions:

Description

HTS Tvheadend 4.1-389~g10d7654
Problem occurs on Kodi 15.1 (Mac OS, OSMC, Kodibuntu, W10) and VLC 2.2.1 (Mac OS)
VLC (Mac OS)

Choppy playback on certain "Stingray Music" channels. Streams are MPEG-2 Video. When starting such a channel playback starts choppy, Kodi shows "Buffering..." After a while playback is fine. No weird messages in TVH. Kodi logs does show "WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available" when the playback is interrupted. Please take a look at the kodi.log file I added.

Playback of H.264 channels is just fine.


Files

kodi.log (64.4 KB) kodi.log J H, 2015-09-05 13:51

History

#1

Updated by J H about 5 years ago

I found out it's only a problem with MPEG-2 with encryption. Unencrypted MPEG-2 channels show the same "asked for new data packet, with nothing available" in kodi.log, but the playback stays smooth.

#2

Updated by J H about 5 years ago

A new discovery; I start a radio station on my Kodi mediacenter in the living room. Playback is ok, no stuttering. I go to the mediacenter upstairs with Kodi and start the same radio channel to be clear the mediacenter in the living room is still playing said channel and Kodi upstairs plays with stuttering.

Anyone an idea?

TVH shows 0 BER, 0 uncorrectable blocks, 0 transport errors, 0 continuity errors. SNR and signal strength @ 100%

#3

Updated by J H about 5 years ago

to be clear the mediacenter in the living room is still playing said channel should be

"to be clear the mediacenter in the living room is still playing said channel"

#4

Updated by Jaroslav Kysela about 5 years ago

  • Status changed from New to Invalid

If you like report a kodi pvr.hts plugin issue - their bugtracker is here: https://github.com/kodi-pvr/pvr.hts/issues

Also available in: Atom PDF