Project

General

Profile

Bug #2973

Bug #2473: Missing EPG data

EPG - missing events

Added by Lifelogger - almost 7 years ago. Updated over 6 years ago.

Status:
New
Priority:
Normal
Assignee:
Category:
EPG
Target version:
-
Start date:
2015-06-25
Due date:
% Done:

0%

Estimated time:
Found in version:
4.1.245
Affected Versions:

Description

Since I am using version 4.1.245 I am having trouble with the EPG.

The EPG is not loading fully anymore. It always seems to stop around 3 am in the morning with filling the data correctly (see image). I never had this with older version of TVHeadend.

Also Kodi 15.2 beta will not load the EPG at all anymore now. The EPG now stays empty.This used to work fine before too.


Files

Schermafbeelding 2015-06-25 om 11.56.10.png (130 KB) Schermafbeelding 2015-06-25 om 11.56.10.png Lifelogger -, 2015-06-25 12:12
epg.jpg (472 KB) epg.jpg Piotr Kuchciak, 2015-06-26 07:38
epg2.jpg (185 KB) epg2.jpg Piotr Kuchciak, 2015-06-26 10:56
epg3.jpg (162 KB) epg3.jpg Piotr Kuchciak, 2015-06-26 11:01
Schermafbeelding 2015-06-26 om 21.31.43.png (175 KB) Schermafbeelding 2015-06-26 om 21.31.43.png Lifelogger -, 2015-06-26 21:32
miss epg.jpg (466 KB) miss epg.jpg Piotr Kuchciak, 2015-06-29 08:49
fox.jpg (465 KB) fox.jpg Piotr Kuchciak, 2015-06-29 10:28
fox-teleman.jpg (222 KB) fox-teleman.jpg Piotr Kuchciak, 2015-06-29 10:29
epg polsat.jpg (396 KB) epg polsat.jpg Piotr Kuchciak, 2015-06-29 11:13
polsat teleman.jpg (368 KB) polsat teleman.jpg Piotr Kuchciak, 2015-06-29 11:13
polsat.xmltv (28.7 KB) polsat.xmltv Piotr Kuchciak, 2015-06-29 16:52
polsat.xmltv (28.4 KB) polsat.xmltv Piotr Kuchciak, 2015-06-29 18:47
date as title.jpg (360 KB) date as title.jpg Piotr Kuchciak, 2015-06-29 20:52
polsat.xmltv (174 KB) polsat.xmltv Piotr Kuchciak, 2015-06-29 22:36
FOX.xmltv (246 KB) FOX.xmltv Piotr Kuchciak, 2015-06-30 09:05
TVP-Historia.xmltv (161 KB) TVP-Historia.xmltv Piotr Kuchciak, 2015-06-30 09:05

History

#1

Updated by Lifelogger - almost 7 years ago

Network is Ziggo Netherlands. Before it was UPC.

#2

Updated by Piotr Kuchciak almost 7 years ago

Hello
I also have this problem from some days ago... I think that is problem with external grabber epg but i send info to developer and he check it and it works OK. That is problem in TVHeadend in EPG.
Please help...

#3

Updated by Piotr Kuchciak almost 7 years ago

I use tvheadend 4.1.307 but this problem beggin in back version... about maybe 4.1.200

#4

Updated by Piotr Kuchciak almost 7 years ago

I yesteday all files from grabber cache and file from epg from tvheadend. Then turn on my grabber and show ok EPG but today is still problem... still not fully show.

#5

Updated by Jaroslav Kysela almost 7 years ago

So, you're talking about EIT (EPG from the broadcaster - MPEG-TS DVB) or XMLTV ?

#6

Updated by Piotr Kuchciak almost 7 years ago

I talk about XMLTV... i use external grabber.

#7

Updated by Piotr Kuchciak almost 7 years ago

#8

Updated by Lifelogger - almost 7 years ago

I am talking about EIT.

#9

Updated by Piotr Kuchciak almost 7 years ago

For channel which is no XMLTV i also use EIT.

#10

Updated by Piotr Kuchciak almost 7 years ago

#11

Updated by Piotr Kuchciak almost 7 years ago

Maybe changes in 13 Jun destroy this ? I dont know.

#12

Updated by B C almost 7 years ago

I just checked my epg and do not have a single hole, can you erase/clear your db and repopulate it? maybe there was a version inbetween which spoiled the db?

#13

Updated by Piotr Kuchciak almost 7 years ago

Can you tell me step by step how erase/clear db ?

#14

Updated by Lifelogger - almost 7 years ago

B C wrote:

I just checked my epg and do not have a single hole, can you erase/clear your db and repopulate it? maybe there was a version inbetween which spoiled the db

If you can tell me where to find and how to clear it, I can try.

#15

Updated by B C almost 7 years ago

the file is .hts/tvheadend/epgdb.v2 in the home dir of the user tvheadend is running. configuration data for epg is in .hts/tvheadend/epggrab/ but i would not recomend to touch this atm

#16

Updated by Piotr Kuchciak almost 7 years ago

I deleted .hts/tvheadend/epgdb.v2 and then run again epg grabber but grabber works ok but file again is now not create.

#17

Updated by B C almost 7 years ago

did you restart tvheadend?

#18

Updated by Piotr Kuchciak almost 7 years ago

yes

#19

Updated by B C almost 7 years ago

well the db is saved depending on the frequency you set in the guy, i think it will also be written when you change the schedule

#20

Updated by Lifelogger - almost 7 years ago

Piotr Kuchciak wrote:

yes

Is the problem now fixed for you?

#21

Updated by Lifelogger - almost 7 years ago

Removed my EPG db. Restarted TVHeadend. DB is not created and the problem is still there. The EPG is loaded fully until 3 am. After 3 am all program names are empty, even though I can see all channel names, etc. etc.

#22

Updated by Piotr Kuchciak almost 7 years ago

I have still problem...

#23

Updated by saen acro almost 7 years ago

Piotr Kuchciak wrote:

I have still problem...

Are you sure that this is not a operator problem?

#24

Updated by Lifelogger - almost 7 years ago

saen acro wrote:

Piotr Kuchciak wrote:

I have still problem...

Are you sure that this is not a operator problem?

In my case it used to work fine. The egg also works on other devices. So I doubt it's the operator

#25

Updated by Jaroslav Kysela almost 7 years ago

  • Parent task set to #2473

Provide some logs (for EIT):

1) remove the <cfgdir>/epgdb.* file
2) start tvh
3) trigger EPG scan (in the config/channels/epg dialog - there's a button on top)
4) wait until this scan finishes
5) wait for EPG holes (if they're not visible immediatelly after scan)
6) provide the logs and describe them (channel, time)

Subsystem to trace (--trace epg,eit), tvh binary must be compiled with --enable-trace.

THE LOGS WILL BE HUGE!!!! You need a lot of disc space. It may be more clever to try this on a debug tvh instance with one channel only with the missing EPG.

#26

Updated by Jaroslav Kysela almost 7 years ago

  • Subject changed from EPG nog fully loading to EPG - missing events
#27

Updated by Lifelogger - almost 7 years ago

I have posted a log of mine: https://mega.co.nz/#!RlcTyYrS!WDMpE7x2B6gYOoJC9sW8Iwv_mJ5wh7gGRNrSVEnmEr0

I removed the DB and started TVHeadend. The DB for EPG is not re-created.

My problem happens with following channels:
NPO 1
NPO 2
NP) 3
RTL 4
RTL 5
SBS 6
RTL 7
Veronica / Disney XD
Net 5
RTL 8
TLC
Comedy Central
Nickelodeon
Ketnet
Disney Channel
Discovery
National Geographic Channel
één
Canvas
BBC One
BBC two
MTV
CNN
BBC World News

All events are loaded until 3 am in the morning. After that the event's are not correctly displayed.

#28

Updated by Jaroslav Kysela almost 7 years ago

Binary must be compiled with --enable-trace (or install the debug version of the package). There should be TRACE lines in log. And before you ask me how to do it - please - check wiki.

#29

Updated by Lifelogger - almost 7 years ago

Hmmm ok. I install it as a Synology package that is compiled by someone else.

#30

Updated by Piotr Kuchciak almost 7 years ago

I still have problem.
When i delete epgdb file then start force epg scan... file epgdb is now to today not create. I still have blank info for some channels. Look at the screen.

#31

Updated by Lifelogger - almost 7 years ago

Seeing the screenshot I see that that rules out the possibility of an provider issue. You have it with channels in a whole different country then me.

#32

Updated by Piotr Kuchciak almost 7 years ago

I am from POLAND. But i think why epgdb is not create after delete and Force Scan ? This is probably problem.

#33

Updated by Piotr Kuchciak almost 7 years ago

In past sometimes i deleted this file and when i run scan EPG this file was create immediately.

#34

Updated by Lifelogger - almost 7 years ago

I am from the Netherlands. The DB is not created anymore in my case too. Before it was. However, even with the DB before, it still had this problem.

#35

Updated by Piotr Kuchciak almost 7 years ago

Jaroslav help us and fix this problem please...

#36

Updated by B C almost 7 years ago

without logs.....

#37

Updated by Piotr Kuchciak almost 7 years ago

Ok but tell me step by step how i can do logs and put it this.

#38

Updated by Piotr Kuchciak almost 7 years ago

I am begginner user...

#39

Updated by B C almost 7 years ago

well everything is in the wiki.....

I just did add all Cyfrowy Polsat channels to my channel list (I assume that's the provider you are having trouble with), I have epg for these channels without any blank entry. Maybe we are looking at the wrong place. Could it be that it is just a displaying problem? Some of the entries have fancy characters in my local. Could you check if missing entries start with a special character for your country ?

#40

Updated by Piotr Kuchciak almost 7 years ago

I use epg grabber whichc download programm from www.teleman.pl and www.gazeta.pl and change it to xmltv. For example i have a problem with channel FOX whicc is download from teleman.pl

On screen 1 is show what show tvheadend but on screen 2 is what i see on www.telema.pl when i open channel FOX. Show whichc character is on this page.

#41

Updated by Piotr Kuchciak almost 7 years ago

And can you give me ink to wiki whichc show how i can do logs ?

#42

Updated by B C almost 7 years ago

well so we are mixing up two different things in this bug report, it was originally opened for eit epg and your problem is with xmltv. I would suggest you upload the file you are importing.
For tracing: http://tvheadend.org/projects/tvheadend/wiki/Traces

#43

Updated by Piotr Kuchciak almost 7 years ago

I show that all title for FOX has on teleman.pl number episod... , for other channel POLSAT in EPG show only programm which has no number episod... for example screen.
Program WYDARZENIA at 15:50 is show OK but programm name Dlaczego Ja?(543) at 16:45 not show in epg because this program has number episod 543.

#44

Updated by B C almost 7 years ago

i can only tell you that we will not be able to help you with screen shots.....

#45

Updated by Piotr Kuchciak almost 7 years ago

My xmltv for Polsat channel

#46

Updated by B C almost 7 years ago

well this has no entries for today, first entry is after midnight, what entry is missing for tomorrow so we can check? Is EIT disabled for these channels so that data isn't mixed?

#47

Updated by Piotr Kuchciak almost 7 years ago

WHere i can disable EIT for one channel ?

Sorry this file is for today.

#48

Updated by Jaroslav Kysela almost 7 years ago

In the service settings. Could you give us an xml file for a week ?

#49

Updated by Piotr Kuchciak almost 7 years ago

In the service settings don see settings to disable EPG scan. I found EPG scan on tab MUX. It is this ?

Ok i generate xmltv for POLSAT channel for week and upload.

#50

Updated by Piotr Kuchciak almost 7 years ago

And next problem is that for some program for title has show date production movie or program...

#52

Updated by Jaroslav Kysela almost 7 years ago

Piotr Kuchciak wrote:

In the service settings don see settings to disable EPG scan. I found EPG scan on tab MUX. It is this ?

I have 'Ignore EPG (EIT)' for each services - just click to 'Edit' button when you select one service.

#53

Updated by Piotr Kuchciak almost 7 years ago

Ok i select Ignore EPG (EIT) but nothing change. Still EPG is wrong as i show on screens.

#54

Updated by Piotr Kuchciak almost 7 years ago

xmltv for Polsat channel for week.

#56

Updated by Jaroslav Kysela almost 7 years ago

I tried this file and I see only gap in this file after the midnight - it's caused by program "Tajemnice losu" - the start time is equal to the stop time - tvh ignores these events. What do you expect from it ?

  <programme start="20150630033000 +0200" stop="20150630033000 +0200" channel="Polsat">
    <title>Tajemnice losu</title>
    <desc><![CDATA[program rozrywkowy]]></desc>
    <category language="en">Leisure hobbies</category>
    <category language="pl">program rozrywkowy</category>
  </programme>
  <programme start="20150702023500 +0200" stop="20150702023500 +0200" channel="Polsat">
    <title>Tajemnice losu</title>
    <desc><![CDATA[program rozrywkowy]]></desc>
    <category language="en">Leisure hobbies</category>
    <category language="pl">program rozrywkowy</category>
  </programme>
#57

Updated by Piotr Kuchciak almost 7 years ago

Look for to other file where is also problem...
FOX and TVP-Historia

#58

Updated by Jaroslav Kysela almost 7 years ago

The files are perfect and tvh parses all events in my test environment. As I wrote before in comment 25, I need full traces for the epg subsystem for your environenent as stated in comment#25 . Also, it would be good to check, if your grabber works correctly. It would be better to use the xml file you provided me and use this simple grabber - name this script as 'tv_grab_test'.

#!/bin/bash

if test "$1" = "--description"; then
  echo "Test XMLTV grabber" 
else
  cat $HOME/a.xmltv
fi

Replace the $HOME/a.xmltv with your xmltv file... Remove the broken epgdb.v2 file before any tests....

#59

Updated by Lifelogger - almost 7 years ago

I run the latest build from Dierkse on my Synology NAS (4.1.322) and the EPG is running normal again. No problems anymore.

#60

Updated by Piotr Kuchciak almost 7 years ago

I have still problem

#61

Updated by Piotr Kuchciak almost 7 years ago

I delete my tvheadend and again install and configure and still have problem that for title have for some channels date and for some channels have no title...

#62

Updated by Piotr Kuchciak almost 7 years ago

Jarolav please describe me manual step by step how i can do this trace subsystem EPG.
I have installed TVHeadend on Debian Chroot on Synology. It is debian.

#63

Updated by Piotr Kuchciak almost 7 years ago

Hello
Problem resolved by developer grabber.

#64

Updated by Lifelogger - almost 7 years ago

I was too early. It looked fine yesterday. However, after the last time TVH grabbed the epg, it has empty program names again. :-(

#65

Updated by Paolo Roascio over 6 years ago

Piotr Kuchciak wrote:

Jarolav please describe me manual step by step how i can do this trace subsystem EPG.
I have installed TVHeadend on Debian Chroot on Synology. It is debian.

Better way is to test on a PC. It's necessary the compile stuff (gcc and so on):

- in a console do: git clone https://github.com/tvheadend/tvheadend
- cd tvheadend
- ./configure --enable-trace
- make
- (as root) make install

At this point you can find your tvheadend binary in /usr/local/bin.

As Jaroslav wrote in comment #25

1) remove the <cfgdir>/epgdb.* file
2) start tvh
3) trigger EPG scan (in the config/channels/epg dialog - there's a button on top)
4) wait until this scan finishes
5) wait for EPG holes (if they're not visible immediatelly after scan)
6) provide the logs and describe them (channel, time)

the command to start tvh in trace mode (point 2) is

tvheadend -l tvheadend.log --trace epg,eit

Also available in: Atom PDF