Project

General

Profile

Bug #2894

Records view is displayed as flatten list in Kodi

Added by Sebastian K. about 7 years ago. Updated about 7 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
Category:
PVR / DVR
Target version:
-
Start date:
2015-05-21
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Found in version:
4.1.13~g3a36e86-dirty
Affected Versions:

Description

Prior to commit 3a36e86 (https://github.com/tvheadend/tvheadend/commit/3a36e86b164fae4171027003587ea44797e6bf99) records would be shown as hierarchical folder structure in Kodi. Since that it's just a plain List.

May be a feature not a bug?

Bug #2867 (https://tvheadend.org/issues/2867) described the same...


Subtasks

Bug #2867: recording->d.v.r. profiles-> filename options have become directory optionsInvalid

Actions

Associated revisions

Revision c90fb418 (diff)
Added by Jaroslav Kysela about 7 years ago

HTSP: Fix the files/path field for dvrentry, fixes #2894

History

#1

Updated by Jaroslav Kysela about 7 years ago

TVH should serve same information. It appears like an issue in the kodi plugin.

#2

Updated by blue note about 7 years ago

Jaroslav Kysela wrote:

TVH should serve same information. It appears like an issue in the kodi plugin.

With same plugin, this appears to still happen with newest compiles. I'm now running 4.1-117~gf27ac40

#3

Updated by Rob Rob about 7 years ago

Also seeing this in 4.1-117.
This is not a plugin issue - plugin has remained a constant before and after these bugs appeared.

1. upgraded from 3.9.xxx to 4.1.18, prior to this recordings working fine and on a directory/per day appearing basis in both client and server side. After this, recordings appeared "flat" in Kodi but recordings still being done in correct directory on server side.
Recordings would not play/start, no response to play button.
2. Recent bugfix corrected recordings so they would play, this corrected the issue for new recordings so they will play and record correctly - but a new bug emerged, the recordings are now being located in the root of the specified recording directory and "make new directories" is non funtional in the tvheadend webgui.

Effectively at this point. 4.1.117...

Old recordings - that is ones that are in a directory created on the per day rule - do not play.
New recordings - work and play fine but don't obey "create directories" rule
Recordings are "flat" in Kodi

pvr.hts plugin 2.1.8.

#4

Updated by Rob Rob about 7 years ago

Rob Rob wrote:

Also seeing this in 4.1-117.
This is not a plugin issue - plugin has remained a constant before and after these bugs appeared.

1. upgraded from 3.9.xxx to 4.1.18, prior to this recordings working fine and on a directory/per day appearing basis in both client and server side. After this, recordings appeared "flat" in Kodi but recordings still being done in correct directory on server side.
Recordings would not play/start, no response to play button.
2. Recent bugfix corrected recordings so they would play, this corrected the issue for new recordings so they will play and record correctly - but a new bug emerged, the recordings are now being located in the root of the specified recording directory and "make new directories" is non funtional in the tvheadend webgui.

Effectively at this point. 4.1.117...

Old recordings - that is ones that are in a directory created on the per day rule - do not play.
New recordings - work and play fine but don't obey "create directories" rule
Recordings are "flat" in Kodi

pvr.hts plugin 2.1.8.

It looks like this is all related to the new

"full pathname specification" field in the "Recording" tab.
This new entry is not migrating over the checkboxes that are ticked, it's also not updating correctly when new boxes are ticked for "create directories per day" under certain circumstances.

This can be worked around easily enough by clearing the new "full pathname specification" field then selecting deseried checkbox setting, reload and then correct format will be displayed...

%F/$t$n.$x

Prior to this only "$t$n.$x" was available...even with "%F/" checked.

Sorry for rambling...hope that's clear.

#5

Updated by Jaroslav Kysela about 7 years ago

The wrong pathname for old configs should be fixed in v4.1-126-g145ca52 . Thanks.

#6

Updated by Rob Rob about 7 years ago

Jaroslav Kysela wrote:

The wrong pathname for old configs should be fixed in v4.1-126-g145ca52 . Thanks.

Thanks.
Just updated to v4.1-126
Deleted all previous recordings physicall and in gui, set recording rules.
Recordings now in correct directories but still in Kodi appear in flattened view - not days etc.
So a bug is still there, the recordings do play though.
This makes it look like it's the addon at fault, but how can that be so when it was working fine and repeatably working fine prior to 4.1.18.

Anyway that's all I can say :)
Thanks for looking into it.

#7

Updated by Jaroslav Kysela about 7 years ago

  • Status changed from New to Fixed
#8

Updated by Rob Rob about 7 years ago

Jaroslav Kysela wrote:

Applied in changeset tvheadend|c90fb4180b6f06bf6d5bf28b3697e726dc9a6a92.

Thanks so much :)

#9

Updated by blue note about 7 years ago

Jaroslav Kysela wrote:

Applied in changeset tvheadend|c90fb4180b6f06bf6d5bf28b3697e726dc9a6a92.

On a fresh compile this now presents foldered results in the client, thank you :)

Also available in: Atom PDF