Project

General

Profile

Bug #2752

Summertime Change incorrect EPG

Added by Batuhan Topbaş almost 7 years ago. Updated almost 7 years ago.

Status:
New
Priority:
Normal
Assignee:
Category:
EPG
Target version:
-
Start date:
2015-03-30
Due date:
% Done:

0%

Estimated time:
Found in version:
3.9.2496
Affected Versions:

Description

Hi all;
I use epg working well until summertime change. My epg file xmltv have correct time. my system(openelec) have correct time. But epg show one hour forward. xmltv program starts 19:00; my system time 19:00 but epg shows program start 20:00. How i can change tvheadend time? i think tvheadned time not changed for summer. Or it is bug?

History

#1

Updated by Martin Klayer almost 7 years ago

In my case the EPG display the entries 2 hours too early.

#2

Updated by Prof Yaffle almost 7 years ago

FWIW, my system handled the change without problem, so it's not a universal issue.

Is the problem to do with how you have EPG times defined, perhaps? Configuration -> DVB Inputs -> Networks -> Edit... EIT local time?

#3

Updated by Batuhan Topbaş almost 7 years ago

This is not checked. I not use over the epg. Before the summertime change epg is working exactly. But after this change epg is worng 1 hour. I automaticly created xmltv file on my server with php. And program date is example: programme start="20150401020000 +0200" stop="20150401043000 +0200" so this is 02:00 start and 04:30 finish. My system(Openelec) time is 02:00 but epg says program start 03:00. So 1 hour different here. I trying solve this problem 2 days but i cant find anything. I try to change epg source date -1 hour.

#4

Updated by Jaroslav Kysela almost 7 years ago

Here is the routine which parses the time string:

https://github.com/tvheadend/tvheadend/blob/master/src/epggrab/module/xmltv.c#L63-L101

TVH uses UTC internally. Note that we set tm_isdst to -1 which may apply another correction to the parsed time.

#5

Updated by Martin Klayer almost 7 years ago

I clicked on Configuration -> DVB Inputs -> Networks -> Edit... EIT local time and have the check mark set.
Now I have one hour difference.
Why is there anyway this option? Could this be removed to limited the complexity a bit?

#6

Updated by Martin Klayer almost 7 years ago

Sorry wrong statement above. It is still 2 hour ahead!

#7

Updated by Martin Klayer almost 7 years ago

I unchecked this EIT check mark and had the EPG reloaded. I seems to be correct now!

#8

Updated by Nihil Baxter almost 7 years ago

Same problem here. After change to german summertime all epg is 2 hours back, enabled eit local time but nothing changes.

#9

Updated by Nihil Baxter almost 7 years ago

OK, sorry, problem seems gone by disabling the eit checkmark....seems it needs some time to update epg data. My system runs with local time, so maybe the checkbox did not do what it should do.

Also available in: Atom PDF