Project

General

Profile

Bug #2673

tvheadend does not send ecm-packets to newcamd-server

Added by Stefan Strobel almost 8 years ago. Updated almost 8 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Descrambling
Target version:
-
Start date:
2015-02-10
Due date:
% Done:

0%

Estimated time:
Found in version:
master
Affected Versions:

Description

Hi,

i have a local newcamds-server on my network. What i have seen in the last few weeks is, that tvheadend stops sending ecm-packets
via caclient to the newcamnd-server.
So I guess, that tvheadend does not send ecm-packets if the prefered caid is not available over a caclient.
If I add a caclient with the prefered caid, then tvheadend starts sending ecm-packets and descrambling the service.
But after a while tvheadend change the caclient to the first one and send ecm-packets to the server and descramble the service.
If i deactivate the second one, it does not take a long time and tvheadend stops descrambling.
I guess this happens also with services with active caclients wich provides the prefered-caid for this service (only if network-problems occur or the server is busy - i don't know at the moment).
Is there a way to configure this behavior over the webui or the home-folder?
Is this a Feature or a Bug?

History

#1

Updated by Jaroslav Kysela almost 8 years ago

Actually, the rule is to select one reader. Other readers are put to the idle mode. Note that there should be something in the tvheeadend log, so you may see the decision rules there (just enable --debug descrambler,cwc).

#2

Updated by Stefan Strobel almost 8 years ago

Thanks for the answer.
I enabled debbug-logging and with one active caclient (caid=098c) i see following:

2015-02-10 20:03:13.912 [   INFO]:mpegts: 12031.5H in Test - tuning on Conexant CX24116/CX24118 : DVB-S #0
2015-02-10 20:03:14.184 [  DEBUG]:cwc: Test/12031.5H/Sky Bundesliga 1 using CWC 192.168.0.6:2000
2015-02-10 20:03:14.184 [   INFO]:subscription: 000A: "127.0.0.1 [ xbmc | XBMC Media Center ]" subscribing on "Sky Bundesliga 1", weight: 150, adapter: "Conexant CX24116/CX24118 : DVB-S #0", network: "Test", mux: "12031.5H", provider: "SKY", service: "Sky Bundesliga 1", hostname="127.0.0.1", username="xbmc", client="XBMC Media Center" 
2015-02-10 20:03:14.184 [   INFO]:subscription: 0009: "epggrab" unsubscribing
2015-02-10 20:03:14.406 [  DEBUG]:cwc: ECM state 0
2015-02-10 20:03:14.999 [  ERROR]:descrambler: cannot decode packets for service "Sky Bundesliga 1" 
2015-02-10 20:03:18.417 [  DEBUG]:cwc: ECM state 0
2015-02-10 20:03:29.000 [ NOTICE]:subscription: 000A: No input source available for subscription "127.0.0.1 [ xbmc | XBMC Media Center ]" to channel "Sky Bundesliga 1" 

There is no ecm-request startet?

Info about the Channel Sky Bundesliga 1:

0x170c /  5900 CA CAIDS: 1702:000000
0x180c /  6156 CA CAIDS: 1833:000000
0x1b0c /  6924 CA CAIDS: 09c4:000000
0x1f0c /  7948 CA CAIDS: 09af:000000
0x1a0c /  6668 CA CAIDS: 098c:000000

Then i added a second "Fake"-caclient with caid=1702:

2015-02-10 20:05:49.899 [   INFO]:mpegts: 12031.5H in Test - tuning on Conexant CX24116/CX24118 : DVB-S #0
2015-02-10 20:05:50.016 [  DEBUG]:cwc: Test/12031.5H/Sky Bundesliga 1 using CWC 192.168.0.6:2000
2015-02-10 20:05:50.017 [  DEBUG]:cwc: Test/12031.5H/Sky Bundesliga 1 using CWC 192.168.0.6:2100
2015-02-10 20:05:50.017 [   INFO]:subscription: 0006: "127.0.0.1 [ xbmc | XBMC Media Center ]" subscribing on "Sky Bundesliga 1", weight: 150, adapter: "Conexant CX24116/CX24118 : DVB-S #0", network: "Test", mux: "12031.5H", provider: "SKY", service: "Sky Bundesliga 1", hostname="127.0.0.1", username="xbmc", client="XBMC Media Center" 
2015-02-10 20:05:50.184 [  DEBUG]:cwc: ECM state 0
2015-02-10 20:05:50.184 [  DEBUG]:cwc: Insert prefered ECM (PID 5900) for service "Sky Bundesliga 1" 
2015-02-10 20:05:50.184 [  DEBUG]:cwc: Sending ECM (PID 5900) section=0/0, for service "Sky Bundesliga 1" (seqno: 21)
2015-02-10 20:05:50.196 [  DEBUG]:cwc: Received NOK[0] for service "Sky Bundesliga 1" (PID 5900) (seqno: 21 Req delay: 12 ms)
2015-02-10 20:05:50.196 [  ERROR]:cwc: Can not descramble service "Sky Bundesliga 1", access denied (seqno: 21 Req delay: 12 ms) from cwc-192.168.0.6-2200-1702
2015-02-10 20:05:50.320 [  DEBUG]:cwc: ECM state 0
2015-02-10 20:05:50.320 [  DEBUG]:cwc: ECM state 0
2015-02-10 20:05:50.320 [  DEBUG]:cwc: ECM state 0
2015-02-10 20:05:50.827 [  ERROR]:descrambler: cannot decode packets for service "Sky Bundesliga 1" 
2015-02-10 20:05:55.329 [  DEBUG]:cwc: ECM state 0
2015-02-10 20:05:55.329 [  DEBUG]:cwc: ECM state 0
2015-02-10 20:05:55.329 [  DEBUG]:cwc: ECM state 0

In the second test, tvheadend uses the caclient with caid=1702. The caclient with caid=098c is never used, but can also "descamble" that
service. There are many other services with the same behavior.

If my second test uses a "real" caclient, in some cases (late ecm-receives?) tvheadend switches to the caclient with 098c.
For now, i have no possibilities to reproduce this behavior.

#3

Updated by Karl Hoebling almost 8 years ago

How about setting the wanted caid in services?

I have the same behaviour that every caid is tried until there is one answer - can last up to ten seconds

regards

karl

#4

Updated by Karl Hoebling almost 8 years ago

just on thing i just see now:

cwc-192.168.0.6-2200-1702 <- looks for me that tvheadend wants 1702 instead of 098C

#5

Updated by Stefan Strobel almost 8 years ago

After a grep in the tvheadend home-folder i already found this option (today).
But THANKS for your tip. I didn't know, that i can also change this option over the webui.

Karl Hoebling wrote:

just on thing i just see now:

cwc-192.168.0.6-2200-1702 <- looks for me that tvheadend wants 1702 instead of 098C

Yes, card changed. That's why some services didn't worked.
Now i understand, why tvheadend does this.

But why is the option 'prefcapid' not reset to '0' if no caclient with (for this example) caid=1702 is configured/enabled?
Could this be a feature?

#6

Updated by Karl Hoebling almost 8 years ago

just one more thing.

i also used cwc first but wasnt satisfied and switch over to a local oscam install on the tvheadend server and used dvbapi. looks more stable for me

Also available in: Atom PDF