Bug #2577

No free adapter/transponder

Added by Rajesh Tandon over 8 years ago. Updated over 8 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:
Found in version:
Affected Versions:



I have installed the latest OpenElec (v 5.0.0) on my Acer Revo, with a HD HomeRun Dual Network tuner (DVB-T Australian version).

Upon first installation, everything works fine, TV tuner found, channels scanned and found.

As soon as I reboot the machine I get the 'No free TV adapter' error. I have rebuilt my Acer a few times with OpenElec and I still get this problem.

When I get this error and login to the tvheadend web page (<ip of Kodi machine>:9981), I find the list of TV adapters under DVB Inputs are now empty.

Log file enclosed.

Files (64.9 KB) Rajesh Tandon, 2014-12-29 13:06



Updated by Daniel Ebdrup over 8 years ago

I have found that adding the following to /storage/.config/
#try and rediscover hdhomerun
hdhomerun_config discover &

If you dont have this file, you should add this to as the first line:


Updated by Rajesh Tandon over 8 years ago

Thank you Daniel.

I created the file in /storage/.config

Ran chmod 777 on the file.

Put these lines into it:

#try and rediscover hdhomerun
hdhomerun_config discover &

Saved and ran the file.

The output was: "homerun device 12211275 found at 192.x.x.3'. So seemed good.

However, the webpage for tvheadend still shows empty DVB Input list and XBMC still shows 'No free adapter' (I have tried to reboot too).

Any further ideas?



Updated by Andy Brown over 8 years ago

I'm not an expert on HD homerun, but it may be that after the HD homerun script you need to restart TVHeadend to re-read the adapters?
If so, just modify your script to:

#try and rediscover hdhomerun
hdhomerun_config discover
/etc/init.d/tvheadend restart

(Note I removed the & from the hdhomerun_config discover line so that it blocks before restarting tvheadend)

That may solve the issue as it sounds like tvh is starting before the tuners are detected/configured.


Updated by Daniel Ebdrup over 8 years ago

Alternatively you can change the line to make use of a conditional and:
#rediscover hdhomerun and restart tvheadend
hdhomerun_config discover && /etc/init.d/tvheadend restart

This means the second command wont run until the first one exits with error code 0 (which only happens when that the command succeeded).

Have you enabled the "wait for network before starting" under OpenELEC Settings? It might not be discovering the hdhomerun simply because there is no active network connection when is executed.


Updated by Rajesh Tandon over 8 years ago

Thanks for your help.

I got it working eventually (with your first solution) , I think it was by adding the tvheadend driver in the XBMC Add-ons itself !

Strange but it should either work with the driver or not, but it seemed to only work without the driver on first installation and no reboot.

I'll keep your other solutions in mind, in case I get stuck again !

Version 5.0 of Openelec, coupled with the version of Tvheadend supplied, is much more stable now. I get flawless TV streaming using a 802.11n USB adapter.

I use the Yatse remote on Android, which is great, but if you know of a better remote geared towards Live TV let me know !

Thanks for your help once again.



Updated by Andy Brown over 8 years ago

  • Status changed from New to Resolved

Updated by Jaroslav Kysela over 8 years ago

  • Status changed from Resolved to Fixed

Also available in: Atom PDF