Project

General

Profile

Bug #2340

Autorec: Not all parameters correctly passed (processed?) from EPG to Autorec entry

Added by Prof Yaffle almost 7 years ago. Updated almost 7 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
Category:
PVR / DVR
Target version:
-
Start date:
2014-10-03
Due date:
% Done:

100%

Estimated time:
Found in version:
3.9.1636~g22f0608 (built 10:45 UTC 03-October)
Affected Versions:

Description

I've flailed around the code to find the fault, but the shift to the api has left me behind and I can't trace things any more.

Two issues apparent when I create an autorec rule from an EPG query:

1. The channel tag seems to be ignored, although it can subsequently be set correctly (edited) in the autorec grid. All filters are present in the autorec dialog box, so it's something to do with how the rule is created, not the API call itself, I suspect.

2. The genre isn't rendered correctly, and cannot be corrected. It only applies to Movie/Drama, though - this comes up as Leisure hobbies. Editing it (double-click) causes it to render correctly during editing, but it reverts as soon as this field loses focus. Other genre tags appear to work correctly, so it's either a problem in rendering or in the store itself?

See attached screenshots for the easiest description.


Files

EPG query.png (18.7 KB) EPG query.png Initial EPG query using filters Prof Yaffle, 2014-10-03 12:58
EPG query - autorec dialog.png (17.6 KB) EPG query - autorec dialog.png Resultant autorec dialogue box - all fields correct Prof Yaffle, 2014-10-03 12:59
Autorec rule.png (20.4 KB) Autorec rule.png Resultant autorec rule - channel tag missing, genre incorrect Prof Yaffle, 2014-10-03 12:59
Autorec rule - editing.png (20.3 KB) Autorec rule - editing.png Editing autorec rule - genre corrects on selection, but renders incorrectly again once saved Prof Yaffle, 2014-10-03 12:59

Associated revisions

Revision 8d2c0257 (diff)
Added by Jaroslav Kysela almost 7 years ago

WEB UI: EPG: Fix the channel tag passing to autorec, fix idnode enum renderer, fixes #2340

History

#1

Updated by Jaroslav Kysela almost 7 years ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

Also available in: Atom PDF