Project

General

Profile

Bug #2332

timeshifting seems to be broken

Added by Kai Sommerfeld almost 6 years ago. Updated almost 6 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
Category:
Timeshift
Target version:
-
Start date:
2014-09-28
Due date:
% Done:

0%

Estimated time:
Found in version:
3.9.1573
Affected Versions:

Description

Timeshiftig seems to be broken.

+ Pause/Unpause: works
+ Fast Forward 2x: works
+ Fast Forward 4x: works
+ Everytings else (FF > 4x, REW, Skip+, Skip-): does not work.

Using OpenELEC 4.2 with tvheadend 3.9.1573. Timeshifting is configured to have

+ 50GB max_size (not unlimited)
+ 3 hrs max_time (not unlimited)
+ on demand is off

Have no idea whether this is a regression.

History

#1

Updated by Anonymous almost 6 years ago

This isn't bug you must use pvr.tvh instead default tvheadend plugin.

#2

Updated by Kai Sommerfeld almost 6 years ago

So, you're saying the bug is not in tvh itself, but in the respective xbmx pvr addon, right?

With respect to timeshifting, tvh.hts (the pvr addon bundled with xbmc 13.2, openelec 4.2) is buggy, but pvr.tvh (avail. from https://github.com/adamsutton/xbmc-pvr-addons) works fine? Will test this tonight.

BTW: Is pvr.hts end of life? Is pvr.tvh supposed to replace pvr.hts?

#3

Updated by Kai Sommerfeld almost 6 years ago

Well, does not work. I used the combination of openelec 4.2 (containing xbmc13.2), self-built pvr.tvh (master), self-built tvheadend (master, 3.9.1600).

I guess, timeshifting will only work with a recent openelec master / kodi build.

#4

Updated by Daniel Eiteneuer almost 6 years ago

I compiled tvheadend, XBMC and the reprogrammed pvr addon (tvh), everything from scratch:
http://forum.xbmc.org/showthread.php?tid=187521&pid=1785852#pid1785852
And I also was facing the time shifting flaw described above. In the XBMC forum, they answered this is still a known issue (bug in the pvr addon, XBMC or even tvheadend? no one knows).

#5

Updated by Jaroslav Kysela almost 6 years ago

It seems that it's fixed now: https://github.com/tvheadend/tvheadend/pull/516 . Please, confirm.

#6

Updated by Kai Sommerfeld almost 6 years ago

Confirmed. Works like a charm now. Thank you for the fix, perexg.

#7

Updated by Jaroslav Kysela almost 6 years ago

  • Status changed from New to Fixed

Closing. Create another issue if it occurs again...

Also available in: Atom PDF