Project

General

Profile

Bug #233

UDP IPTV stream corruption

Added by Steven VS - about 9 years ago. Updated about 9 years ago.

Status:
Fixed
Priority:
High
Assignee:
Category:
General
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Found in version:
Affected Versions:

Description

I have a problem with a lot of my UDP streams. Most of them are corrupted. If I play them in VLC, they play fine.

I have attached the TS recorded file in tvheadend and I have also attached the wireshark trace.

I am running svn trunk R4974 (but I also had the problem with earlier releases)

This is the debug from the recorded file:

[WARNING]:dvr: Output directory for video recording is not yet configured. Defaulting to to "/home/xbmc/Videos". This can be changed from the web user interface.
[INFO]:CSA: Using SSE2 128bit parallel descrambling
[NOTICE]:START: HTS Tvheadend version SVN-r4974 started, running as PID:12010 UID:1000 GID:1000, settings located in '/home/xbmc/.hts/tvheadend'
[DEBUG]:AVAHI: Adding service 'Tvheadend'
[INFO]:AVAHI: Service 'Tvheadend' successfully established.
[INFO]:htsp: Got connection from 10.180.129.13
[INFO]:htsp: 10.180.129.13: Welcomed client software: HTS Showtime
[INFO]:subscription: "10.180.129.13 [ HTS Showtime ]" subscribing on "3 girls", weight: 150, adapter: "eth0", network: "<N/A>", mux: "224.1.40.1", provider: "<N/A>", service: "<N/A>", quality: 100
[DEBUG]:Transport: 0.0.0.0/: Status changed to [Hardware input]
[DEBUG]:Transport: 0.0.0.0/: Status changed to [Hardware input] [Input on service]
[DEBUG]:Transport: 0.0.0.0/: Status changed to [Hardware input] [Input on service] [Demuxed packets]
[DEBUG]:Transport: 0.0.0.0/: Status changed to [Hardware input] [Input on service] [Demuxed packets] [Reassembled packets]
[INFO]:htsp: 10.180.129.13 [ HTS Showtime ]: Disconnected
[INFO]:subscription: "10.180.129.13 [ HTS Showtime ]" unsubscribing from "3 girls"
[INFO]:dvr: "video" on "3 girls" starting at Tue Jun 29 11:32:00 2010, scheduled for recording by "127.0.0.1"
[INFO]:dvr: "video" on "3 girls" recorder starting
[INFO]:subscription: "DVR: video" subscribing on "3 girls", weight: 300, adapter: "eth0", network: "<N/A>", mux: "224.1.40.1", provider: "<N/A>", service: "<N/A>", quality: 100
[DEBUG]:Transport: 0.0.0.0/: Status changed to [Hardware input]
[DEBUG]:Transport: 0.0.0.0/: Status changed to [Hardware input] [Input on service]
[DEBUG]:Transport: 0.0.0.0/: Status changed to [Hardware input] [Input on service] [Demuxed packets]
[DEBUG]:Transport: 0.0.0.0/: Status changed to [Hardware input] [Input on service] [Demuxed packets] [Reassembled packets]
[DEBUG]:dvr: File "/home/xbmc/Videos/video.mkv" -- No such file or directory -- Using for recording
[INFO]:dvr: video from adapter: "eth0", network: "<N/A>", mux: "224.1.40.1", provider: "<N/A>", service: "<N/A>"
[INFO]:dvr: 1 MPEG2VIDEO 720 x 576 3600
[INFO]:dvr: 2 MPEG2AUDIO 0 x 0 2351


Files

video-1.mkv (2.24 MB) video-1.mkv Recorded file Steven VS -, 2010-06-29 11:43

History

#1

Updated by Andreas Smas about 9 years ago

  • Status changed from New to Fixed
  • Found in version set to fixed

Fixed in r4983

Also available in: Atom PDF