Project

General

Profile

Bug #2313

Vanished recordings

Added by Harald Nehring about 5 years ago. Updated almost 5 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
Category:
PVR / DVR
Target version:
-
Start date:
2014-09-19
Due date:
% Done:

0%

Estimated time:
Found in version:
3.9.1486~geeb5ac8~precise
Affected Versions:

Description

I'm updating to master regularly. Since a couple of days (SEP 16) I'm missing ALL of my previous recordings in WebUI and XBMC. Looking at my daily backups I see that all of the corresponding dvr/log files where removed. Restoring the backup and restarting tvheadend leads to the dvr log files being deleted again. I'm seeing there's been recent changes in the handling of recording retention, so I'm sure this is related. My retention time is set to 3650 days.


Files

05e3d8348958304777023cf76609337c (855 Bytes) 05e3d8348958304777023cf76609337c Harald Nehring, 2014-09-19 14:18

History

#1

Updated by Harald Nehring about 5 years ago

Attaching one of the recordings affected.

#2

Updated by Jaroslav Kysela about 5 years ago

  • Status changed from New to Fixed

Unfortunately, there was a wrong condition which broke the retention check. It was fixed in v3.9-1488-gd11c919 . You may restore the log entries from a backup.

#3

Updated by Harald Nehring about 5 years ago

Thanks, Jaroslav. Updating to latest master and restoring the log entries from backup worked.

#4

Updated by Oliver K├Âtter almost 5 years ago

Not sure if this belongs here or this should be a new ticket.
I entered a very long value (10000 days) but as I've read somewhere there's a maximum value somewhere at 9000 or higher.
The 10000 value deletes all my logs although 10000 is taken by the GUI.
I'm on 3.9.2293

Also available in: Atom PDF