Project

General

Profile

Bug #2227

Restarting/Crashing Oscam causes tvheadend freeze

Added by Mirko Di Paolo about 5 years ago. Updated about 5 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
Descrambling
Target version:
-
Start date:
2014-08-14
Due date:
% Done:

100%

Estimated time:
Found in version:
3.9.1285
Affected Versions:

Description

If I restart Oscam I got this:
2014-08-14 11:52:58.441 [ TRACE] capmt: setting filter: adapter=0, demux=0, filter=0, pid=4225
2014-08-14 11:52:58.441 [ TRACE] capmt: 80 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
2014-08-14 11:52:58.441 [ TRACE] capmt: FF 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
2014-08-14 11:52:58.441 [ TRACE] capmt: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
2014-08-14 11:52:58.565 [ TRACE] capmt: Received message from socket 28
2014-08-14 11:52:58.565 [ TRACE] capmt: 00 86 6F 10 40 00 00 00 00 00 00 00 00 5F A8 0C [email protected]_..
2014-08-14 11:52:58.565 [ TRACE] capmt: 13 4A 8A 73 47 .J.sG
2014-08-14 11:52:58.565 [ DEBUG] capmt: CA_SET_DESCR adapter 0 par 0 idx 0 5fa80c134a8a7347
2014-08-14 11:52:58.565 [ TRACE] descrambler: Obtained keys 5FA80C134A8A7347:0000000000000000 from capmt-/tmp/camd.socket-15079 for service "Rai 1 HD"
2014-08-14 11:53:01.160 [ INFO] capmt: normal socket shutdown
2014-08-14 11:53:01.160 [ TRACE] descrambler: mux 0x2b049c0 close pid 1081 (4225)
2014-08-14 11:53:01.160 [ INFO] capmt: Automatic reconnection attempt in in 3 seconds
2014-08-14 11:53:04.000 [ DEBUG] capmt: Created socket 28
2014-08-14 11:53:04.000 [ INFO] capmt: mode 4 sockfile /tmp/camd.socket got connection from client (single)
2014-08-14 11:53:08.426 [ TRACE] descrambler: stream key changed to even for service "Rai 1 HD"
2014-08-14 11:53:18.419 [ TRACE] descrambler: stream key changed to odd for service "Rai 1 HD"
2014-08-14 11:53:18.419 [ TRACE] descrambler: ECM late (20 seconds) for service "Rai 1 HD"
2014-08-14 11:53:18.419 [ TRACE] descrambler: stream key changed to odd for service "Rai 1 HD"
2014-08-14 11:53:18.419 [ TRACE] descrambler: flush table data for service "Rai 1 HD"
2014-08-14 11:53:18.834 [ ERROR] descrambler: cannot decode packets for service "Rai 1 HD"
...
2014-08-14 11:53:23.991 [ TRACE] descrambler: cannot decode packets for service "Rai 1 HD"
2014-08-14 11:53:24.000 [ DEBUG] service: Hotbird-Ita/11766V/Rai 1 HD: Status changed to [Hardware input] [Input on service] [Demuxed packets] [Reassembled packets] [Data timeout]
2014-08-14 11:53:24.000 [WARNING] epggrab: EIT: DVB Grabber - data completion timeout for 11766V in Hotbird-Ita
2014-08-14 11:53:24.045 [ TRACE] descrambler: cannot decode packets for service "Rai 1 HD"
...
2014-08-14 11:53:25.982 [ TRACE] descrambler: cannot decode packets for service "Rai 1 HD"
2014-08-14 11:53:26.000 [ TRACE] subscription: unlinking sub 0x7f94540d1680 from svc 0x2954f90
2014-08-14 11:53:26.000 [ DEBUG] mpegts: 11766V in Hotbird-Ita - stopping mux
2014-08-14 11:53:26.230 [ TRACE] mpegts: SAT>IP 1 (10.0.0.7) - flush subscribers
2014-08-14 11:53:26.230 [ TRACE] mpegts: 11766V in Hotbird-Ita - flush tables
2014-08-14 11:53:26.230 [ TRACE] descrambler: mux 0x2b049c0 - flush tables
2014-08-14 11:53:26.230 [ TRACE] mpegts: 11766V in Hotbird-Ita - mi=0x7f944c001480
2014-08-14 11:53:26.230 [ INFO] capmt: Removing CAPMT Server from service "Rai 1 HD" on adapter 0

Then tvheadend becomes unresponsive (even webif) and if I change channel in xbmc (that seems staled too) I got this after a while:

2014-08-14 11:56:37.579 [ INFO] htsp: 10.0.0.18 [ test | XBMC Media Center ]: Write error -- Pipe interrotta

After that xbmc returns working, but I have to kill -9 tvh and restart it to get back TV.

Associated revisions

Revision 1eddf45a (diff)
Added by Jaroslav Kysela about 5 years ago

capmt: do properly the reconnection, fix another mutex bug - fixes #2227

History

#1

Updated by Jaroslav Kysela about 5 years ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

Also available in: Atom PDF