Project

General

Profile

Bug #2215

Problems with usb device "Elgato EyeTV DTT Deluxe properly" /dev/dvb/adapter0/frontend0: unable to open (err=Connection timed out)

Added by Lucky Rings over 7 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Configuration
Target version:
-
Start date:
2014-08-12
Due date:
% Done:

0%

Estimated time:
Found in version:
3.4 wheezy
Affected Versions:

Description

Hello,
I have tried now two seperate installations on two differnet models of Raspberry Pi (Model B and B+) with Tvheadend on Raspbian with the USB Stick and assume there is a bug, because I get error when the device should be deteced by Tvheadend "/dev/dvb/adapter0/frontend0: unable to open (err=Connection timed out)".

The usb device "Elgato EyeTV DTT Deluxe" is conneted via external self-powered USB 2.0 hub to the USB port of the pi.

Detection and Firmware from Elgate EyeTV DTT Deluxe is nicly done.

dmesg:
[ 734.676630] usb 1-1.5: Product: USB 2.0 Hub
[ 734.687576] hub 1-1.5:1.0: USB hub found
[ 734.687816] hub 1-1.5:1.0: 4 ports detected
[ 734.965878] usb 1-1.5.3: new high-speed USB device number 11 using dwc_otg
[ 735.067714] usb 1-1.5.3: New USB device found, idVendor=0fd9, idProduct=002c
[ 735.067748] usb 1-1.5.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 735.067764] usb 1-1.5.3: Product: EyeTV DTT Dlx
[ 735.067778] usb 1-1.5.3: Manufacturer: Elgato
[ 735.067792] usb 1-1.5.3: SerialNumber: 000200104535803
[ 735.069079] as10x_usb: device has been detected
[ 735.069336] DVB: registering new adapter (Elgato EyeTV DTT Deluxe)
[ 735.071606] usb 1-1.5.3: DVB: registering adapter 0 frontend 0 (Elgato EyeTV DTT Deluxe)...
[ 735.181922] as10x_usb: firmware: as102_data1_st.hex loaded with success
[ 735.380857] as10x_usb: firmware: as102_data2_st.hex loaded with success

lsusb:
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 010: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 011: ID 0fd9:002c Elgato Systems GmbH EyeTV DTT Deluxe v2

syslog:Aug 12 13:51:03 mypi tvheadend15164: charset: 71 entries loaded
Aug 12 13:51:13 mypi tvheadend15164: dvb: /dev/dvb/adapter0/frontend0: unable to open (err=Connection timed out)
Aug 12 13:51:13 mypi tvheadend15164: CSA: Using 32bit parallel descrambling
Aug 12 13:51:13 mypi tvheadend15164: epggrab: module eit created
Aug 12 13:51:13 mypi tvheadend15164: epggrab: module uk_freesat created
Aug 12 13:51:13 mypi tvheadend15164: epggrab: module uk_freeview created
Aug 12 13:51:13 mypi tvheadend15164: epggrab: module viasat_baltic created
Aug 12 13:51:13 mypi tvheadend15164: epggrab: module opentv-ausat created
Aug 12 13:51:13 mypi tvheadend15164: epggrab: module opentv-skyuk created
Aug 12 13:51:13 mypi tvheadend15164: epggrab: module opentv-skyit created
Aug 12 13:51:13 mypi tvheadend15164: epggrab: module pyepg created
Aug 12 13:51:13 mypi tvheadend15164: epggrab: module xmltv created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_in created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_se_swedb created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_fr_kazer created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_se_tvzon created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_huro created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_ch_search created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_fr created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_combiner created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_eu_egon created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_uk_rt created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_na_dtv created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_no_gfeed created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_it created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_es_laguiatv created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_pt_meo created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_is created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_ar created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_eu_epgdata created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_dk_dr created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_za created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_uk_bleb created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_fi created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_na_dd created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_hr created
Aug 12 13:51:58 mypi tvheadend15164: epggrab: module /usr/bin/tv_grab_il created
Aug 12 13:51:58 mypi tvheadend15164: dvr: Creating new configuration ''
Aug 12 13:51:58 mypi tvheadend15164: dvr: Output directory for video recording is not yet configured for DVR configuration "". Defaulting to to "/home/hts". This can be changed from the web user interface.
Aug 12 13:51:58 mypi tvheadend15164: START: HTS Tvheadend version 3.4~wheezy started, running as PID:15164 UID:107 GID:44, settings located in '/home/hts/.hts/tvheadend''

device file:
[email protected] ~ $ ls -l /dev/dvb/adapter0/
total 0
crw-rw---T 1 root video 212, 4 Aug 12 13:16 demux0
crw-rw---T 1 root video 212, 5 Aug 12 13:16 dvr0
crw-rw---T 1 root video 212, 3 Aug 12 13:16 frontend0
[email protected] ~ $ ls -l /dev/dvb
total 0
drwxr-xr-x 2 root root 100 Aug 12 13:08 adapter0
[email protected] ~ $

I alread checked several times users and groups, this is why I made a complete clean install but no changes. Tvheadend was installed through package system (deb http://apt.tvheadend.org/stable wheezy main). After starting the service it is running as user "hts" and group "video. That should be fine for accessing the device, but whatever I already tried, it does not work.

The pi is up to date with all packages and also the rpi-update has downloaded and installed newest firmware.

Any idea what to do next?

Luckyrings

Also available in: Atom PDF