Project

General

Profile

Bug #2203

OSCAM descrambling no longer works

Added by Amine Bizid over 8 years ago. Updated over 8 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
Descrambling
Target version:
-
Start date:
2014-08-07
Due date:
% Done:

0%

Estimated time:
Found in version:
3.9.1226~g6c8908c
Affected Versions:

Description

Hello,
Descrambling channels no longer works using OSCAM. Please find hereafter OSCAM logs with the newest TVH version and with an older version.
I don't know why the VPID has changed (new 000B, old 0002)

OSCAM log with New TVH version 3.9.1226~g6c8908c

10:17:16 1BB66D0 c plain dvbapi-client granted (dvbapiuser, au=off)
10:17:16 1BB66D0 c [DVBAPI] Detected /dev/dvb/adapter0/demux0 Api: 0, userconfig boxtype: 11
10:17:24 1BB66D0 c [ADD PID 0] CAID: 1863 ECM_PID: 07D0 PROVID: 000000
10:17:24 1BB66D0 c [ADD PID 1] CAID: 1863 ECM_PID: 158A PROVID: 000000
10:17:24 1BB66D0 c [ADD PID 2] CAID: 0500 ECM_PID: 1973 PROVID: 030B00
10:17:24 1BB66D0 c [ADD PID 3] CAID: 0500 ECM_PID: 1971 PROVID: 032940
10:17:24 1BB66D0 c [ADD PID 4] CAID: 0500 ECM_PID: 1970 PROVID: 043330
10:17:24 1BB66D0 c [ADD PID 5] CAID: 0500 ECM_PID: 196F PROVID: 032830
10:17:24 1BB66D0 c [ADD PID 6] CAID: 0500 ECM_PID: 196E PROVID: 040F40
10:17:24 1BB66D0 c [ADD PID 7] CAID: 1811 ECM_PID: 1588 PROVID: 000000
10:17:24 1BB66D0 c [ADD PID 8] CAID: 0100 ECM_PID: 1588 PROVID: 003317
10:17:24 1BB66D0 c [ADD PID 9] CAID: 1811 ECM_PID: 1587 PROVID: 000000
10:17:24 1BB66D0 c [ADD PID 10] CAID: 0100 ECM_PID: 1587 PROVID: 003315
10:17:24 1BB66D0 c Found 11 ECMpids and 1 STREAMpids in PMT
10:17:24 1BB66D0 c [DVBAPI] Receiver wants to demux srvid 2275 on adapter 0000 camask 0001 index 0000 pmtpid 0000
10:17:24 1BB66D0 c New program number: 2275 (1863:2275 unknown) [pmt_list_management 3]
10:17:24 1BB66D0 c [DVBAPI] Demuxer #0 trying to descramble PID #5 CAID 0500 PROVID 032830 ECMPID 196F ANY CHID PMTPID 0000 VPID 000B
10:17:24 1BB66D0 c [DVBAPI] Demuxer #0 trying to descramble PID #10 CAID 0100 PROVID 003315 ECMPID 1587 ANY CHID PMTPID 0000 VPID 000B
10:17:27 1BB66D0 c [DVBAPI] Demuxer #0 (re)starting decodingrequests on all 11 ecmpids!
10:17:27 1BB66D0 c [DVBAPI] Demuxer #0 trying to descramble PID #5 CAID 0500 PROVID 032830 ECMPID 196F ANY CHID PMTPID 0000 VPID 000B
10:17:27 1BB66D0 c [DVBAPI] Demuxer #0 trying to descramble PID #10 CAID 0100 PROVID 003315 ECMPID 1587 ANY CHID PMTPID 0000 VPID 000B
10:17:30 1BB66D0 c [DVBAPI] Demuxer #0 (re)starting decodingrequests on all 11 ecmpids!
10:17:30 1BB66D0 c [DVBAPI] Demuxer #0 trying to descramble PID #5 CAID 0500 PROVID 032830 ECMPID 196F ANY CHID PMTPID 0000 VPID 000B
10:17:30 1BB66D0 c [DVBAPI] Demuxer #0 trying to descramble PID #10 CAID 0100 PROVID 003315 ECMPID 1587 ANY CHID PMTPID 0000 VPID 000B

OSCAM log with old TVH version 3.9.1089~g9a934e2a

10:20:09 1738880 c plain dvbapi-client granted (dvbapiuser, au=off)
10:20:09 1738880 c [DVBAPI] Detected /dev/dvb/adapter0/demux0 Api: 0, userconfig boxtype: 11
10:20:16 1738880 c [ADD PID 0] CAID: 1863 ECM_PID: 07D0 PROVID: 000000
10:20:16 1738880 c [ADD PID 1] CAID: 1863 ECM_PID: 158A PROVID: 000000
10:20:16 1738880 c [ADD PID 2] CAID: 0500 ECM_PID: 1973 PROVID: 030B00
10:20:16 1738880 c [ADD PID 3] CAID: 0500 ECM_PID: 1971 PROVID: 032940
10:20:16 1738880 c [ADD PID 4] CAID: 0500 ECM_PID: 1970 PROVID: 043330
10:20:16 1738880 c [ADD PID 5] CAID: 0500 ECM_PID: 196F PROVID: 032830
10:20:16 1738880 c [ADD PID 6] CAID: 0500 ECM_PID: 196E PROVID: 040F40
10:20:16 1738880 c [ADD PID 7] CAID: 1811 ECM_PID: 1588 PROVID: 000000
10:20:16 1738880 c [ADD PID 8] CAID: 0100 ECM_PID: 1588 PROVID: 003317
10:20:16 1738880 c [ADD PID 9] CAID: 1811 ECM_PID: 1587 PROVID: 000000
10:20:16 1738880 c [ADD PID 10] CAID: 0100 ECM_PID: 1587 PROVID: 003315
10:20:16 1738880 c Found 11 ECMpids and 1 STREAMpids in PMT
10:20:16 1738880 c [DVBAPI] Receiver wants to demux srvid 2275 on adapter 0000 camask 0001 index 0000 pmtpid 0000
10:20:16 1738880 c New program number: 2275 (1863:2275 unknown) [pmt_list_management 3]
10:20:16 1738880 c [DVBAPI] Demuxer #0 trying to descramble PID #5 CAID 0500 PROVID 032830 ECMPID 196F ANY CHID PMTPID 0000 VPID 0002
10:20:16 1738880 c [DVBAPI] Demuxer #0 trying to descramble PID #10 CAID 0100 PROVID 003315 ECMPID 1587 ANY CHID PMTPID 0000 VPID 0002
10:20:16 1738880 c [DVBAPI] Demuxer #0 continue decoding of SRVID 2275
10:20:16 1738880 c [SKIP STREAM 0] CAID: 1863 ECM_PID: 07D0 PROVID: 000000
10:20:16 1738880 c [SKIP STREAM 1] CAID: 1863 ECM_PID: 158A PROVID: 000000
10:20:16 1738880 c [SKIP STREAM 2] CAID: 0500 ECM_PID: 1973 PROVID: 030B00
10:20:16 1738880 c [SKIP STREAM 3] CAID: 0500 ECM_PID: 1971 PROVID: 032940
10:20:16 1738880 c [SKIP STREAM 4] CAID: 0500 ECM_PID: 1970 PROVID: 043330
10:20:16 1738880 c [SKIP STREAM 5] CAID: 0500 ECM_PID: 196F PROVID: 032830
10:20:16 1738880 c [SKIP STREAM 6] CAID: 0500 ECM_PID: 196E PROVID: 040F40
10:20:16 1738880 c [SKIP STREAM 7] CAID: 1811 ECM_PID: 1588 PROVID: 000000
10:20:16 1738880 c [SKIP STREAM 8] CAID: 0100 ECM_PID: 1588 PROVID: 003317
10:20:16 1738880 c [SKIP STREAM 9] CAID: 1811 ECM_PID: 1587 PROVID: 000000
10:20:16 1738880 c [SKIP STREAM 10] CAID: 0100 ECM_PID: 1587 PROVID: 003315
10:20:16 1738880 c Found 11 ECMpids and 1 STREAMpids in PMT
10:20:16 1738880 c [DVBAPI] Receiver wants to demux srvid 2275 on adapter 0000 camask 0001 index 0000 pmtpid 0000
10:20:16 1738880 c New program number: 2275 (1863:2275 unknown) [pmt_list_management 3]
10:20:17 17368C0 p fafou-pro.dyndns.tv: resolved ip=xxx.xxx.xxx.xxx
10:20:17 17368C0 p fafou [newcamd] connecting to xxx.xxx.xxx:30000
10:20:17 17368C0 p Newcamd Server: xxx.xxx.xxx:30000 - UserID: 2
10:20:17 17368C0 p CAID: 0000 - UA: 0000000000000000 - Provider # 1
10:20:17 17368C0 p Provider ID: 000000 - SA: 00000000
10:20:17 1738880 c dvbapiuser (0500&032830/1317/2275/A0:BDF7CA579002116611619229F70018D3): not found (34 ms) by fafou
10:20:17 1738880 c dvbapiuser (0100&003315/5C00/2275/64:EF7109E5DC6508284FEDC01ABE4A6CED): not found (28 ms) by fafou
10:20:17 1738880 c [DVBAPI] Demuxer #0 (re)starting decodingrequests on all 11 ecmpids!
10:20:17 1738880 c [DVBAPI] Demuxer #0 trying to descramble PID #5 CAID 0500 PROVID 032830 ECMPID 196F ANY CHID PMTPID 0000 VPID 0002
10:20:17 1738880 c [DVBAPI] Demuxer #0 trying to descramble PID #10 CAID 0100 PROVID 003315 ECMPID 1587 ANY CHID PMTPID 0000 VPID 0002
10:20:17 1738880 c dvbapiuser (0500&032830/1317/2275/A0:BDF7CA579002116611619229F70018D3): not found (3 ms) by fafou
10:20:18 1738880 c dvbapiuser (0100&003315/5C00/2275/64:AC6317DC8B4D0EFAD14985C63454FC0F): found (476 ms) by fafou

History

#1

Updated by Jos E over 8 years ago

Looks similar to https://tvheadend.org/boards/13/topics/12803

I think this bug has been introduced between build 1070 (works fine) and build 1094 (not working properly).

On the link above I described as work-around to compile from source an older build 1070 (id: 39b6bc1d). This atleast gave me back a working Oscam descrambling setup. YMMV - hopefully it gets fixed soon :)

#2

Updated by Crazy Fin over 8 years ago

I am on 3.9.1228 and using OSCAM as well (OSCAM 1.20-unstable_svn build r667) and I have no problems with descrambling crypted channels on Nordic Canal Digital channels on the Thor 5 and 6 satellites.

#3

Updated by Rob vh over 8 years ago

3.9.1228, OSCAM 9767 (2 local cards), DVB-S2 with Canal Digitaal, Capmt mode 2, SD and HD descramble perfectly.

#4

Updated by Meindert Oldenburger over 8 years ago

I have no problems with and i have the latest oscam r9816 and latest tvheadend 3.9.1228~g9a49f94 and I use mode 2 for capmt

This evening I had problems with some HD channels of canaldigitaal, but it whas fixed after canaldigitaal sended a new activation signal.

#5

Updated by Amine Bizid over 8 years ago

Crazy Fin wrote:

I am on 3.9.1228 and using OSCAM as well (OSCAM 1.20-unstable_svn build r667) and I have no problems with descrambling crypted channels on Nordic Canal Digital channels on the Thor 5 and 6 satellites.

I'm using OSCam cardserver v1.20-unstable_svn, build r9782

#6

Updated by Amine Bizid over 8 years ago

The problem is caused by linuxdvb_rotor.c, since i did not define the motor rate, it sleeps 2 mins before calling tuning.

#7

Updated by Jaroslav Kysela over 8 years ago

  • Status changed from New to Invalid

Also available in: Atom PDF