Project

General

Profile

Bug #2127

Timeshift not creating new buffers as it should

Added by Henrik Harmsen over 8 years ago. Updated almost 7 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
Category:
Timeshift
Target version:
-
Start date:
2014-06-05
Due date:
% Done:

0%

Estimated time:
Found in version:
3.9.778~ge35085a
Affected Versions:

Description

When timeshifting, the buffer becomes full and no new buffer is created. New buffers should be created.

What I think is happening is that TVH switches buffers every 60 seconds and when it does, it considers the buffer full. But that means timeshift only works for 2x60 seconds as it does for me, which doesn't make sense. I wonder why this has not been seen before. People must have timeshifted more than 2 minutes...?

Debug log shows:
2014-06-05 09:27:13.734 [ DEBUG]:timeshift: ts 1 enter timeshift mode
2014-06-05 09:27:13.734 [ DEBUG]:timeshift: ts 1 change speed 0
2014-06-05 09:27:13.734 [ DEBUG]:htsp: 192.168.0.145 [ pi | XBMC Media Center ] - subscription speed
2014-06-05 09:27:25.299 [ DEBUG]:timeshift: ts 1 change speed 100
2014-06-05 09:27:25.299 [ DEBUG]:htsp: 192.168.0.145 [ pi | XBMC Media Center ] - subscription speed
2014-06-05 09:27:26.085 [ DEBUG]:timeshift: ts 1 change speed 0
2014-06-05 09:27:26.085 [ DEBUG]:htsp: 192.168.0.145 [ pi | XBMC Media Center ] - subscription speed
2014-06-05 09:27:37.899 [ DEBUG]:timeshift: ts 1 change speed 100
2014-06-05 09:27:37.899 [ DEBUG]:htsp: 192.168.0.145 [ pi | XBMC Media Center ] - subscription speed
2014-06-05 09:27:52.362 [ DEBUG]:timeshift: ts 1 remove /h/timeshift/buffer/1/tvh-1446
2014-06-05 09:28:41.527 [ DEBUG]:timeshift: ts 1 change speed 0
2014-06-05 09:28:41.527 [ DEBUG]:htsp: 192.168.0.145 [ pi | XBMC Media Center ] - subscription speed
2014-06-05 09:28:52.384 [ DEBUG]:timeshift: ts 1 remove /h/timeshift/buffer/1/tvh-1447
2014-06-05 09:29:24.975 [ DEBUG]:timeshift: ts 1 change speed 100
2014-06-05 09:29:24.975 [ DEBUG]:htsp: 192.168.0.145 [ pi | XBMC Media Center ] - subscription speed
2014-06-05 09:29:42.441 [ DEBUG]:timeshift: ts 1 change speed 0
2014-06-05 09:29:42.441 [ DEBUG]:htsp: 192.168.0.145 [ pi | XBMC Media Center ] - subscription speed
2014-06-05 09:29:52.367 [ DEBUG]:timeshift: ts 1 buffer full

The timeshift buffers look like this:
[email protected] /h/timeshift $ ls lRh
.:
total 4,0K
drwx-----
3 pi pi 4,0K jun 5 09:26 buffer

./buffer:
total 4,0K
drwx------ 2 pi pi 4,0K jun 5 09:28 1

./buffer/1:
total 62M
rw------ 1 pi pi 27M jun 5 09:28 tvh-1448
rw------ 1 pi pi 35M jun 5 09:29 tvh-1449

It stays like this forever. When I unpause in xbmc, I can watch those buffers but then the video freezes since it runs out of buffers to watch.

My timeshift config is attached in the picture (no ondemand, unlimited size, unlimited time)


Files

timeshift config.png (10.9 KB) timeshift config.png Picture of config Henrik Harmsen, 2014-06-05 09:36

History

#1

Updated by Henrik Harmsen over 8 years ago

Forgot to add this is what the log looks like when it finally runs out of buffers to watch

2014-06-05 10:16:15.776 [ DEBUG]:timeshift: ts 1 change speed 100
2014-06-05 10:16:15.776 [ DEBUG]:htsp: 192.168.0.145 [ pi | XBMC Media Center ] - subscription speed
2014-06-05 10:17:31.726 [ DEBUG]:timeshift: ts 1 sob speed 100
2014-06-05 10:17:31.726 [ DEBUG]:htsp: 192.168.0.145 [ pi | XBMC Media Center ] - subscription speed

#2

Updated by Jaroslav Kysela almost 7 years ago

  • Status changed from New to Fixed

I believe it's fixed now.

Also available in: Atom PDF