Project

General

Profile

Bug #1922

CPU usage after DVB code rewrite

Added by Michal Leinweber over 8 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Timeshift
Target version:
-
Start date:
2014-01-10
Due date:
% Done:

0%

Estimated time:
Found in version:
05635e83
Affected Versions:

Description

I am running tvheadend, git version, revision 05635e83. It consumes much more CPU than older version before DVB code rewrite. On QNAP TS-209 PRO (350MHz armel - orion5x) with 3 USB tunners I was able to record 2-3 programs and other one watch online. Now after upgrade when recording one program it takes over 50% CPU and when watching one another program online then errors appear in both places.

I understand that it is very unpowerfull HW, but I was using it over year without problems.

McLEI

History

#1

Updated by Adam Sutton over 8 years ago

  • Status changed from New to Need feedback
  • Found in version changed from GIT to 05635e83

I'm not going to lie, such low performance devices are certainly not the target market. And so its possible that stuff does get introduced over time that will break such things.

However that being said, I do tend to agree that it should work, there is no obvious reason why the CPU load should be so high.

Can you check which thread is consuming the memory, assuming this information is available on your box. What data sources do you have? Have you tried disabling EPG processing? Just trying to think what could have changed that is that significant. We do now do all SI table processing in TVH rather than relying on the HW. But that should be fairly meagre compared to processing the A/V streams.

Adam

#2

Updated by Michal Leinweber over 8 years ago

U seems to be related to timeshift. In previous version timeshift was not working for me so I had not it enabled. Now I have started using it and it may be the cause for CPU problems. I'm still investigating it.

#3

Updated by Adam Sutton over 8 years ago

  • Category changed from DVB to Timeshift
  • Status changed from Need feedback to Accepted
#4

Updated by Adam Sutton over 8 years ago

  • Status changed from Accepted to Rejected

I'm going to reject this on the basis I see no such increase in CPU load on my box, which isn't all that powerful either. Maybe some hardware issues?

Adam

Also available in: Atom PDF