Project

General

Profile

Bug #1859

Missing adapter in recent unstable (3.9)

Added by Liquid Sky about 9 years ago. Updated about 9 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
DVB
Target version:
-
Start date:
2013-12-07
Due date:
% Done:

0%

Estimated time:
Found in version:
3.9.237~gfcc97df
Affected Versions:

Description

Hi,
I use tvheadend for a long time and I've never had any problems.
using tvheadend sinceversion 2.1 and I've never had any problems, building by myself new releases.
I currently use version 3.5.245~g6c9bff1 and wanted to try version 3.9 but I have a little problem. It seems that tvheadend no longer recognizes my card (WinTV Nova HD-S2).
dmesg reports, as always, the correct firmware upload (dvb-fe-cx24116.fw), but the log shows that by running "tvheadend-C" does not recognize the card.
Any ideas/suggestions?

Thanx!

ls la /dev/dvb/adapter0/
total 0
drwxr-xr-x 2 root root 120 Dec 7 12:12 .
drwxr-xr-x 3 root root 60 Dec 7 12:12 ..
crw-rw---
+ 1 root video 212, 1 Dec 7 12:12 demux0
crw-rw----+ 1 root video 212, 2 Dec 7 12:12 dvr0
crw-rw----+ 1 root video 212, 0 Dec 7 12:12 frontend0
crw-rw----+ 1 root video 212, 3 Dec 7 12:12 net0

The log version 3.5:
Dec 07 19:38:07.052 [ INFO] charset: 71 entries loaded
Dec 07 19:38:07.056 [ INFO] dvb: Found adapter /dev/dvb/adapter0 (Conexant CX24116/CX24118) via PCI
Dec 07 19:38:07.057 [ INFO] v4l: /dev/video0: cx8800 Hauppauge WinTV-HVR4000 D PCI:0000:04:01.0 capabilities: 0x05010011
----------------------------------------------------------------------------------------
Dec 07 19:38:07.068 [ INFO] CSA: Using SSE2 128bit parallel descrambling
Dec 07 19:38:07.068 [ INFO] epggrab: module eit created
Dec 07 19:38:07.068 [ INFO] epggrab: module uk_freesat created
----------------------------------------------------------------------------------------
Dec 07 19:38:08.418 [ INFO] dvr: Creating new configuration ''
Dec 07 19:38:08.418 [ NOTICE] START: HTS Tvheadend version 3.5.245~g6c9bff1 started, running as PID:4961 UID:0 GID:0, settings located in '/home/xbmc/.hts/tvheadend'
Dec 07 19:38:14.000 [ INFO] epgdb: saved
Dec 07 19:38:14.000 [ INFO] epgdb: brands 0
Dec 07 19:38:14.000 [ INFO] epgdb: seasons 0
Dec 07 19:38:14.000 [ INFO] epgdb: episodes 0
Dec 07 19:38:14.000 [ INFO] epgdb: broadcasts 0
Dec 07 19:38:14.000 [ NOTICE] STOP: Exiting HTS Tvheadend

The log version 3.9:
2013-12-07 19:38:26.122 [ INFO] CSA: Using SSE2 128bit parallel descrambling
2013-12-07 19:38:26.122 [ INFO] epggrab: module eit created
2013-12-07 19:38:26.122 [ INFO] epggrab: module uk_freesat created
2013-12-07 19:38:26.122 [ INFO] epggrab: module uk_freeview created
2013-12-07 19:38:26.122 [ INFO] epggrab: module viasat_baltic created
-----------------------------------------------------------------------
2013-12-07 19:38:27.409 [ INFO] dvr: Creating new configuration ''
2013-12-07 19:38:27.409 [WARNING] dvr: Output directory for video recording is not yet configured for DVR configuration "". Defaulting to to "/home/xbmc". This can be changed from the web user interface.
2013-12-07 19:38:27.412 [ NOTICE] START: HTS Tvheadend version 3.9.237~gfcc97df started, running as PID:5012 UID:0 GID:0, settings located in '/home/xbmc/.hts/tvheadend'
2013-12-07 19:38:34.000 [ INFO] epgdb: saved
2013-12-07 19:38:34.000 [ INFO] epgdb: brands 0
2013-12-07 19:38:34.000 [ INFO] epgdb: seasons 0
2013-12-07 19:38:34.000 [ INFO] epgdb: episodes 0
2013-12-07 19:38:34.000 [ INFO] epgdb: broadcasts 0
2013-12-07 19:38:34.000 [ NOTICE] STOP: Exiting HTS Tvheadend

History

#1

Updated by Liquid Sky about 9 years ago

sorry I made ​​some mistakes copy and paste ... and I can not change them :)

#2

Updated by Adam Sutton about 9 years ago

  • Status changed from New to Need feedback

What is the output from:

ls /dev/dvb/adapter*/

I can't think of any obvious reason it shouldn't detect a tuner.

Adam

#3

Updated by Liquid Sky about 9 years ago

As written above... :)

ls -la /dev/dvb/adapter0/
total 0
drwxr-xr-x  2 root root  120 Dec 7 12:12 .
drwxr-xr-x  3 root root   60 Dec 7 12:12 ..
crw-rw----+ 1 root video 212, 1 Dec 7 12:12 demux0
crw-rw----+ 1 root video 212, 2 Dec 7 12:12 dvr0
crw-rw----+ 1 root video 212, 0 Dec 7 12:12 frontend0
crw-rw----+ 1 root video 212, 3 Dec 7 12:12 net0

I can't think of any obvious reason it shouldn't detect a tuner.

Me too...
I also tried to change the access permissions of the dvb/adapter0 files with chmod o+rw, but it did not work...

Anyways... Merry XMas and Happy New Year to all!! :D

#4

Updated by Liquid Sky about 9 years ago

Solved!
Missing parameter --enable-bundle in configure...

:)

#5

Updated by Adam Sutton about 9 years ago

  • Status changed from Need feedback to Invalid

That option should have ZERO effect on your problem, unless you simply installed incorrectly. But I'll assume that since the issue is no longer happening I'll close.

Adam

Also available in: Atom PDF