Project

General

Profile

Bug #1836

Channel icons apear on wrong channels

Added by Raymond Paulsen about 7 years ago. Updated almost 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
General
Target version:
-
Start date:
2013-11-19
Due date:
% Done:

0%

Estimated time:
Found in version:
3.9.249~gc7d0335~wheezy
Affected Versions:

Description

Adding channel icons by URL from LYNGSAT in channel tab.
Will appear on wrong channel in both xbmc and tvhguid.

History

#1

Updated by Raymond Paulsen about 7 years ago

This is still not fixed. Its a very annoying problem

#2

Updated by Adam Sutton about 7 years ago

What (git) version of TVH?

Adam

#3

Updated by Raymond Paulsen about 7 years ago

Iam on latest unstable. The problem has persisted sins the introduction to the new framework on all compiled relases for debian 7 i386

#4

Updated by Adam Sutton about 7 years ago

Sorry, git version please, latest unstable doesn't mean anything to me.

I'll try and take a look, do they all end up on the wrong channels or just some?

#5

Updated by Raymond Paulsen about 7 years ago

3.9.249~gc7d0335~wheezy

#6

Updated by Adam Sutton about 7 years ago

  • Found in version changed from latest unstable to 3.9.249~gc7d0335~wheezy

OK,

had a quick check on my test system, all seems well, all the icons (I admit I only scanned the list, but checked around 50), were fine.

Can you get a debug log from XBMC (though I can't remember if all the relevant stuff got disabled in a build switch)? See what it might be requesting.

Adam

#7

Updated by Raymond Paulsen about 7 years ago

i use xbmc and tvhguide app for android, both showing wrong channel icons, it also has problems with channel numberings.

#8

Updated by Raymond Paulsen about 7 years ago

ok the bug is located inside the "image cache" feature, disabling this fix the image order.
the image cache function stores the images in the old framework way. 1,2,3 not by hash??

#9

Updated by Adam Sutton about 7 years ago

Great, that helps narrow it down. Indeed some stuff has not been fully migrated, or can't for compatibility reasons, I will take a look and see what can be done.

Adam

#10

Updated by Adam Sutton about 7 years ago

OK, reminded myself what I actually did for imagecaching. The ID/UUID stuff is a red-herring.

The imagecache linking is from the URL of the image, something like this:

1. HTSP outputs channel info:
a. If an ICON url exists, it ask imagecache for internal ID (integer) for that URL.
b. If no existing entry exists in imagecache, one is created.
2. HTSP returns channel icon URL as /imagecache/ID
3. HTSP clients requests /imagecache/ID from TVH.

I've checked and this works fine.

One thing to check, have you completely reset your XBMC PVR database since updating TVH?

Adam

#11

Updated by Raymond Paulsen about 7 years ago

Hi

Yes settings is after the new framework. I have reinstalled the server from scratch to make shure its no config or leftovers from old install.. its a error in the code some place. Have you tryed ticking ssl and changed refetch time? Iam 100% shure its not a setting error or files. Image cachfolder has been manualy deleted and its recreated by tvh with linking error.

#12

Updated by Adam Sutton about 7 years ago

It's working fine here is all I can say. I'd like to see some XBMC debug logs, even if they don't have anything useful in. I'd also like you to try another reset of the PVR database, and then see if what you get is random or the same mis-alignment as before?

Also check the configuration in the TVH channels tab is actually still correct.

Adam

#13

Updated by Adam Sutton about 7 years ago

  • Status changed from New to Rejected

Completely unable to reproduce this problem. Would need more details logs, from XBMC, to see what its doing. I think that requires build switches though.

Adam

#14

Updated by Raymond Paulsen about 7 years ago

Is it possible to use tvhguide or any other systems to get the bug report? This is not uniq to xbmc..
I can give access to my server if you want to have a look..

Anyway there is a problem with image cache on ALL relases for debian 7 i386.

Your test enviroment is not correctly setup. I use openelec so its not easy to get the bug reports.

#15

Updated by Raymond Paulsen about 7 years ago

I have deactivated image cache and the correct order is now showing on all client devices. Iam not going to spend anymore time on this, evetualy the problem will be resolved.

I did a new install for a pal of my. Same setup dell poweredge 2850 with 2 nova s2. This server has same problem with image cache. Deactivating caching fixes the issue.

Let me know how you tested this. What os and what settings you used.

#16

Updated by Hanspeter Müller almost 7 years ago

I just tested XBMC13 Beta, it seems to work there :-). Can someone confirm this?

#17

Updated by Hanspeter Müller almost 7 years ago

Hanspeter Müller wrote:

I just tested XBMC13 Beta, it seems to work there :-). Can someone confirm this?

Ok, it got even stranger; XBMC13b ran on another Machine for a month without that problem. Then i upgraded my "production" openelec (who had the wrong icon problem) to XBMC13b5, where it still presisted. So i went on and configured shared librarys (mysql and Thumbs-Storage), and now even the new one had the problem?!?! I cleared the database and storage (and of course also the Live-TV settings inside XBMC), still f-ed up. Turned out, XBMC seems to cache "something" in the Textures13.db file (which i copied over from the old machine to the new one, as suggested in the shared-librarys-howto). After deleting (and rebuilding the other databases) it's now working on both machines :)

/hp

#18

Updated by Raymond Paulsen almost 7 years ago

Hanspeter Müller wrote:

Hanspeter Müller wrote:

I just tested XBMC13 Beta, it seems to work there :-). Can someone confirm this?

Ok, it got even stranger; XBMC13b ran on another Machine for a month without that problem. Then i upgraded my "production" openelec (who had the wrong icon problem) to XBMC13b5, where it still presisted. So i went on and configured shared librarys (mysql and Thumbs-Storage), and now even the new one had the problem?!?! I cleared the database and storage (and of course also the Live-TV settings inside XBMC), still f-ed up. Turned out, XBMC seems to cache "something" in the Textures13.db file (which i copied over from the old machine to the new one, as suggested in the shared-librarys-howto). After deleting (and rebuilding the other databases) it's now working on both machines :)

/hp

Hi

yes iam aware of the xbmc issues. But the problem is also apearing on non xbmc devices like the tvhguide app for androind. This would not have happend if this was a front end problem, its a server side problem with tvheadend.

disabling image cache in tvheadend fixes the problem.

#19

Updated by Hanspeter Müller almost 7 years ago

Hi,

Raymond Paulsen wrote:

yes iam aware of the xbmc issues. But the problem is also apearing on non xbmc devices like the tvhguide app for androind. This would not have happend if this was a front end problem, its a server side problem with tvheadend.

Ah, i wasn't aware that it also happens on other frontends...

disabling image cache in tvheadend fixes the problem.

Yes, that is also the case here, but my XBMC's are in an isolated network, i really want/need the caching. Maybe a red herring, but i think it started to mess up the icons (after working for weeks with only a few important channels configured) after i added new channels, with the only visible pattern, that where it's messed up, there's allways a number somethere in the chain of the channel name. Example of a "chain":

"Das Erste" shows the icon configured at "SRF 1 HD"
"SRF 1 HD" show the icon configured at "3+"
"3+" shows the icon configured at "SRF zwei HD"
"Das Erste HD" shows the icon configured at "Star TV"
"Star TV" shows the icon configured at "Tele 1"
"Tele 1" shows the correct icon configured

Is it possible, that the number in the channelname messes up the ID of the cache? Any idea why there even is a separate ID for the images, and not simply the channel-id (that looks like md5) is used?

Also available in: Atom PDF