Project

General

Profile

Bug #1701

Tvheadend 3.4 locks up my machine

Added by Patric Gustavsson over 8 years ago. Updated over 8 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
General
Target version:
-
Start date:
2013-04-19
Due date:
% Done:

100%

Estimated time:
Found in version:
3.4
Affected Versions:

Description

Dear Sir/Madam,

I have tried in the past to use the beta version of tvheadend with the timeshift feature, and it always locked up my machine completely at random intervals.
I then used to go back to the older 3.2.34 version, and all was well again.

Now 3.4 has been released, i updated to it, but my machine still locks up (i have to press the power button to kill it, cannot ssh into the box or use mouse / keyboard)
so i tried going back to 3.2.34 , but that version now no longer works for me, the service stops instantly with a segfault.

So i am now currently running 3.2.34~gfaee94b~oneiric , and have to power off my pc 4-5 times a day.

I am running Linux Mint 12 (based on Oneiric) , and xbmc 12.1 under lightdm
i have an nvidia gforce 210 with 304.84 driver.
I use an Technotrend S2-1600 card for tv

When it locks up, i seem to get nothing in the logfiles indicating what went wrong.

Can you guys help me trobleshoot this? , i will happily provide any more details as needed.

Many Thanks
Best Regards
Patric


Files

panic.txt (6.86 KB) panic.txt Kernel Error Bianco Veigel, 2013-04-21 10:48

History

#1

Updated by Patric Gustavsson over 8 years ago

EDIT : Sorry i typed in the wrong version, i.e it is 3.4 i am using now!

#2

Updated by Adam Sutton over 8 years ago

  • Found in version changed from 3.2.34~gfaee94b~oneiric to 3.4
  • Affected Versions 3.4 added

What are you doing when it locks? Watching channels, recording stuff? Is it just idling?

That's a PCIe card correct? so probably running in full mux rx mode (see adapter config). You could try disabling that in case its causing the device grief.

Adam

#3

Updated by Adam Sutton over 8 years ago

Just a quick question, because ironically a friend has just told me he was using that card after I asked him about an issue he'd been having...

Are you using 32bit or 64bit?

Adam

#4

Updated by Patric Gustavsson over 8 years ago

Hi,

Usually locks up when idling mostly, but can also happen when i watch tv or recorded content.

Its a PCI card :

Hardware
Device path:
/dev/dvb/adapter0
Device name:
STV090x Multistandard
Host connection:
PCI
Intermediate Frequency range:
950000 kHz - 2150000 kHz, in steps of 0 kHz
Symbolrate range:

I have now set "Full mux reception" to Off , and idle scanning to Off

Will check if things work better now. :)

Br
Patric

#5

Updated by Patric Gustavsson over 8 years ago

32bit

Br
Patric

#6

Updated by Adam Sutton over 8 years ago

The reason I ask about 32 v 64 bit. Is my mate had been having trouble with this for one of his cards. By some weird coincidence this issue cropped up in #hts, I checked which card it was and its the same as yours! Very odd coincidence :)

So worth checking...

#7

Updated by Adam Sutton over 8 years ago

Ah, crossed, ignore that then.

#8

Updated by Patric Gustavsson over 8 years ago

I thought you cracked it with those setting changes, but after 11 hours, here is my first system hang.

Just checked my syslog, and before the hang, i have nothing logged at all.

Perhaps the hangs are less frequent now (never lasted more then 2-3 hours before) but they are still there.

Br
PG

#9

Updated by Rob vh over 8 years ago

Patric, this STV090x is not by any chance a Digital Devices, ngene based card?
I have had significant trouble with the DuoFlex S2 lately using a "plain" Mythbuntu. I opened an issue with Adam about the I2C timeout and resulting hang that started to happen a month or so ago. Check https://tvheadend.org/issues/1678
Reading the vdr forum I found out that significant development on the dvb drivers had been made but not upstreamed. With Roger Endriss' code I now have a stable server again.

#10

Updated by Bianco Veigel over 8 years ago

I gues I have the exact same error. I've updated to the 3.4 2 days ago (changed to the apt.tvheadend.org Repository since the old launchpad repo returned a 404).

I had the opportunity to get a message from my Kernel via a running SSH session, when the server died.

I've openened a bug for Ubuntu linux at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1171096

#11

Updated by Patric Gustavsson over 8 years ago

@rob_vh i don't think it is ngene based card?

Its a technotrend s2-1600 , here is a link to some info about it : http://linuxtv.org/wiki/index.php/TechnoTrend_TT-budget_S2-1600

But in tvheadend it is detected as STV090x so perhaps it is using the same drivers?

Br
Patric

#12

Updated by Patric Gustavsson over 8 years ago

Hello,

I have not changed or updated any packages, but :

14:38:06] [email protected]:[/home/hts]: uptime
14:39:00 up 4 days, 17:04, 1 user, load average: 0.99, 1.00, 0.98

So almost 5 days without a system lock :)

/Patric

#13

Updated by Gero Graubner over 8 years ago

Hello,

same Problem here, running

Ubuntu 12.04 Server, Kernel 3.2.0-41-generic with XBMC 12.2 and tvheadend 3.4.
I have an nvidia gforce 210 with 304.84 driver, and an L4M Cine S2 V.6.2.

03:00.0 Multimedia controller: Digital Devices GmbH Octopus LE DVB adapter
Subsystem: Digital Devices GmbH Device 0020
Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 16
Region 0: Memory at fb100000 (64-bit, non-prefetchable) [size=64K]
Capabilities: [50] Power Management version 3
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [70] MSI: Enable- Count=1/2 Maskable- 64bit+
Address: 0000000000000000 Data: 0000
Capabilities: [90] Express (v2) Endpoint, MSI 00
DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
MaxPayload 128 bytes, MaxReadReq 128 bytes
DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s, Latency L0 unlimited, L1 <1us
ClockPM- Surprise- LLActRep- BwNot-
LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
DevCap2: Completion Timeout: Range A, TimeoutDis+
DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-
LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-, Selectable De-emphasis: 6dB
Transmit Margin: Normal Operating Range, EnterModifiedCompliance
ComplianceSOS-
Compliance De-emphasis: -6dB
LnkSta2: Current De-emphasis Level: -6dB
Capabilities: [100 v1] Vendor Specific Information: ID=0000 Rev=0 Len=00c
Kernel driver in use: DDBridge
Kernel modules: ddbridge

In TVHeadend the card is detected as STV090x.

With tvheadend 3.2 all things ran smoothly, but since the Upgrade to Version 3.4 there are random lockups.

When the Server died, there is no opportunity to get a message from it (via ssh), also there are no helpfull entries in the logs.

Mostly the lockups are visible when tvheadend is in idle, in XBMC just listen to music on Harddisk.

Gero

#14

Updated by Patric Gustavsson over 8 years ago

Hi,

I still have not had a single lockup.

I think "Full mux reception" to Off did the trick, i just did not restart the tvheadend service afterwards.

Does turning this feature off have any side effects? , i.e will i loose any functionality?

Br
Patric

#15

Updated by Adam Sutton over 8 years ago

No, it was added for various reasons, though for the most part I think I will be making it OFF by default in future versions and let users enable it only as required (normally its only really useful for debug at this stage, though I think Andreas has some other ideas going forwards).

Adam

#16

Updated by Menco Bolt - over 8 years ago

Just a 'me to'. Als my server started crashing on my since 3.4. At first I thought the hdd was broken, so I replaced it. Then while working on the system (booted from fresh disk), the system started freezing again on me at random. One time I saw 'cpu stuck for xx seconds [tvheadend:xxx]' on the console. Also do I have a STV090x (Mystique) on Debian wheezy amd64 (with kernel 3.2).
Since I've understood it didn't happen in tvheadend 3.2 I downgraded tvheadend to 3.2 and hope indeed it doesn't happen in tvheadend 3.2 (since Dexter is airing soon... ;-))

#17

Updated by Martin Mrvka over 8 years ago

Same here, a complete freeze of my ubuntu 12.04 server without any additional information.

I'm searching for the reason since two months now, however I didn't put this in relation with tvheadend yet. If tvheadend is the reason for this, then I may be can help to narrow down the commit.

The first freeze happened after the build from master I did on the 31st of March. Since I'm regularly building from master each couple of days, I would say it happend somewhere between https://github.com/tvheadend/tvheadend/commit/5e7950275daca9a58b6c94a51565cb1c205e4100 and https://github.com/tvheadend/tvheadend/commit/e9ce02138e81d0dd94a2b155e57fda282063c008.

I now reverted back to 5e7950275daca9a58b6c94a51565cb1c205e4100 to see if this is the case.

#18

Updated by Johann Reisner over 8 years ago

Hi,

same problem here with (L/K)Ubuntu 12.04.2. Tried with different kernels (3.2, 3.5) on 64bit. I'm using the DVBSky S952 with the dvb drivers from dvbsky site. The drivers where ever the same and everything worked with a previous version. Crashes (very often without messages) happens since I'm using the repositories versions. Btw I tried every repository (stable, beta, unstable). Problem persists.

I've not got the logs by hand, but if I get a message in syslog, then it's like Bianco Veigels:

BUG: soft lockup - CPU#x stuck for XXs!

The whole server hangs without any response (no mouse, keyboard, ssh...); most of the time there are no logs and even REISUB does not help...

No Problem with self compiled (from master with timeshift) version (some kind of 3.4-pre, downloaded and compiled in about february/march). I'm sorry, but tvheadend does not show me a version, so I can't say it precisely, but somewhere I've got the sources. If you need them, please call...

If I can provide some more helpful informations, please write to me...

Thanks!

#19

Updated by Martin Mrvka over 8 years ago

I'm running 3.5.64~g5e79502 since 6 days now without any freeze. Only memory consumption is a quite high (1.4G virtual and 218M physical).

Kernel is 3.8.0-23-generic on 64bit, meanwhile ubuntu 13.04 system with two Tevii s480 and one Hauppauge HVR4000. No liplianin drivers are installed. Honestly I don't know if liplianin drivers are needed anyways since the Tevii is detected and basically working.

#20

Updated by Johann Reisner over 8 years ago

Currently running on beta version from repository. I turned off full mux rx and had no problems since. Please turn off this feature in all coming versions by default; it causes too much problems which cannot be related to tvheadend and therefore wastes much time for debugging and finding the reason. Tvh is great, and I love it, but this "feature" had cost me and others weeks of unstable and unusable systems without knowing the problem, so please disable fmrx by default to safe other systems.

#21

Updated by Thomas K over 8 years ago

Hello Guys!

I had same problems after upgrading (fresh install) to Ubuntu 13.04 (Kernel 3.8) and TVHeadend 3.4. The server was unresponsible after a couple of hours. Before this i was on Ubuntu 12.04 LTS and TVheadend 3.2.34 with no such problem. Over one week I have tried to fix this behavior with no efforts. I was allready thinking about a hardware failure.

Bianco has mentioned a BUG report on Launchpad and they recommend for testing pruposes to try the latest Kernel 3.9. So I have tried the latest Kernel (3.9.0) from here: http://kernel.ubuntu.com/~kernel-ppa/mainline/ . Now im on Kernel 3.9.4 and since switching to (3.9.X) for about over one month the server is running without these problems.

Therefore I don't think this is a TVHeadend bug.

#22

Updated by Thomas K over 8 years ago

Forgot to mention that i have also a Cine S2 V5.5 card with an addon dual tuner. So this must be driver related.

#23

Updated by Andy Brown over 8 years ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

Thanks guys, looks like this was combination of driver and full mux reception so I'll close this down for now.

Also available in: Atom PDF