Project

General

Profile

Bug #1695

empty service names

Added by Yon Belew over 5 years ago. Updated almost 5 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
DVB
Target version:
-
Start date:
2013-04-13
Due date:
% Done:

0%

Estimated time:
Found in version:
3.5.97
Affected Versions:

Description

Duplicate of Bug #1429 that is now marked as Fixed.
HDHR Prime ATSC: 87 Muxes, 473 Services all with empty Service Name.
Running 3.5.97~g4670400.

tvh.log (14.6 KB) tvh.log Yon Belew, 2013-04-23 04:40
tvh.png (132 KB) tvh.png tvh dvb services tab David Feng, 2013-04-26 08:21
tvh2.png (109 KB) tvh2.png tvh dvb general tab David Feng, 2013-04-26 08:21
tvh.log (21.6 KB) tvh.log David Feng, 2013-04-26 08:21
RealtekRTL2832.jpg (229 KB) RealtekRTL2832.jpg Hank Rarop, 2013-06-03 09:07
ss.jpg (216 KB) ss.jpg no services Nic Fischer, 2013-06-15 04:52

History

#1 Updated by Adam Sutton over 5 years ago

  • Status changed from New to Need feedback

Please provide some more input, is this all service names? or just some?

Do the muxes you have include full identification, network ID etc...

Can you try updating to latest master (a couple of recent mods added) and run with "--trace --subsys +nit,+sdt,+tdt -l tvh.log" this will generate a log file with a LOT of crap in it that might be useful.

Ta
Adam

#2 Updated by Yon Belew over 5 years ago

Hi Adam,

All service names are empty.
Network, NetworkID and MuxID columns are empty on the Multiplexes page.
Built the latest git tonight, 3.5.116~ga2ccbb2.
Log file attached.

#3 Updated by David Feng over 5 years ago

I have a similar issue, where >100 services are found, but zero service names. The HDHR ATSC is hooked up to OTA and is not the prime version. I have tried the current stable package (3.4), the unstable package (3.5.116), and the beta version (3.3.?).

Yesterday, I was running 2.99, which worked fine.

#4 Updated by Hank Rarop over 5 years ago

Hi All,

For your information: I have the same issue.
See prior my prior post (link): https://tvheadend.org/boards/5/topics/8372

Too many muxes are found, too many services are found and only one-fifth of the services have names, the other ones have no service name, no channel name and cannot be played (not even when I manually give them names and add them to a channel).

#5 Updated by Nic Fischer over 5 years ago

I posted on another similar bug report #1418, but this one seems more recent, with the same issues.

I ran a fresh install of raspbmc which packaged tvheadend 3.4. Using an HDHR3-US with an OTA antenna, I was able to successfully scan for muxes, however I am facing the same problem described by a lot of the posts in this thread: Services are unnamed when the mux search finishes, and pressing the map DVB services to channels does not appear to do anything. Seems that the mux parser is having a hard time processing the data from the HDHR3-US?

The debug log at the bottom prints:
Jun 14 22:07:57.608 web interface: Service probe started on "Tuner 2"

I'd be happy to provide more debug logs if it will help in further diagnosis.

#6 Updated by Mike Harsch over 5 years ago

I'm able to reproduce this issue at will. Using git bisect, I've isolated the failure to this change:

https://github.com/tvheadend/tvheadend/commit/1cc67b75e8f7a90ef0d6aaaf88cf5cf633c8c840

#7 Updated by Mike Harsch over 5 years ago

Just to be clear - the failure mode is still present in the current master.

#8 Updated by Mike Harsch over 5 years ago

Raw mux dump from HDHR3-US per Adam's request:

https://dl.dropboxusercontent.com/u/22165996/1695_0.ts

(100M file)

#9 Updated by robert l about 5 years ago

Mike Harsch wrote:

Just to be clear - the failure mode is still present in the current master.

Same issue here.. using avermedia m780 tuner on newest openelec, using OTA ATSC in the us.. scans muxed, finds about 30 services with no names or info. Has anyone found a work around this? Searching aroud the web it seems this bug has existed for a year or more now..

#10 Updated by Adam Sutton almost 5 years ago

  • Status changed from Need feedback to Invalid

Relates to code that has now been re-written. Closing.

Also available in: Atom PDF