Project

General

Profile

Bug #1494

tvheadend and viaccess cards

Added by Ovidiu Nicolae about 8 years ago. Updated about 8 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
Category:
Descrambling
Target version:
-
Start date:
2013-01-03
Due date:
% Done:

0%

Estimated time:
Found in version:
3.2.18
Affected Versions:

Description

Hello Adam
it looks like the viaccess cards cannot be setup to work in the combination of tvheadend / oscam / newcamd

im receiving constantly same error

Jan 03 01:02:59 cwc: Attemping to connect to 127.0.0.1:34010
Jan 03 01:02:59 cwc: Connected to 127.0.0.1:34010
Jan 03 01:03:00 cwc: 127.0.0.1:34010: Request card data: Read error (header): Connection reset by peer
Jan 03 01:03:00 cwc: Disconnected from 127.0.0.1:34010
Jan 03 01:03:00 cwc: 127.0.0.1:34010: Automatic connection attempt in in 3 seconds

can be fixed?

History

#1

Updated by Adam Sutton about 8 years ago

  • Assignee set to Mariusz Białończyk
  • Affected Versions 3.2, 3.3 added

Mariusz, another one for you possibly?

Adam

#2

Updated by Mariusz Białończyk about 8 years ago

It's hard for me to reproduce it (i don't have viaccess card). If you're using oscam, you can try capmt mode. Is it working?

#3

Updated by Ovidiu Nicolae about 8 years ago

Hello Mariusz and thank you Adam
well i have a c-line from my brother's dbox , the line contain 2 cards conax and viaccess , conax is working fine but viaccess not . i am afraid im not able to use capmt mostly because of the fact that i am using the downloadable fusion version of openelec which is precompiled without cccam.
So i am using tvheadend - oscam - newcamd combination to read the c-line.
If you need any logs or anything helpfull i can provide you but not direct access to viaccess card :( , but i am pretty sure that on the forum i've read some more requests regarding viaccess type of crypt.

Regards

#4

Updated by Mariusz Białończyk about 8 years ago

I don't know if we understand each other correctly. You don't need cccam at all! In other words: tvheadend capmt is not cccam! You can connect directly to oscam via capmt (using dvbapi). It is new a feature in tvh. You just have to set it correctly, i think it's not compilicated. Make sure you have enabled "Oscam mode" in tvh and add a proper users on oscam side, it will then use oscam dvbapi interface.
One important thing: i don't know your configuration, but it will work only if your oscam and tvh is running on the same machine (it may be a blocker for you), anyway you can always install oscam and run it as a client to another one (there are few ppl on the #hts irc channel running it this way).

And regarding your issue - it seems that tvh cannot obtain card information because id doesn't "understand" what server is saying.

Another tip: you can separate these two cards on the server (put it on different newcamd port) and give it a try...

#5

Updated by Ovidiu Nicolae about 8 years ago

hello mariusz and thank you for your answer and for clarification

tvh oscam newcamd runing on same machine in my case so it won't be a blocker.
i will try to setup to connect oscam directly via capmt (by dvbapi) but i don't understand what do you mean with ("Oscam mode" in tvh) is it an specific command line or a trick or something please clarify .
Anyway this weekend will gonna try both methods dvbapi and different port in newcamd configuration for viaccess card (hope it will work).

Regards

#6

Updated by Mariusz Białończyk about 8 years ago

"Oscam mode" is a tick in capmt tvh webinterface. If you don't have it - it may be because you have too old version and you need to compile/upgrade. More information about setting oscam is in "help" in tvh webui.

#7

Updated by Ovidiu Nicolae about 8 years ago

well in the latest beta openelec 3.0 beta 6 TVH is at latest official version 3.2.18 or so.Is there a newer version of TVH?

#8

Updated by Ovidiu Nicolae about 8 years ago

capmt tab is present in the webui .
same like in this description https://www.lonelycoder.com/redmine/projects/tvheadend/wiki/Capmt_Connections
i presume this is the oscam mode for TVH right?

#9

Updated by Mariusz Białończyk about 8 years ago

No, it is not the oscam mode. The wiki you provided has outdated info - i just updated it.

#10

Updated by Ovidiu Nicolae about 8 years ago

is this small addition available in TVH 3.2.18?

#11

Updated by Mariusz Białończyk about 8 years ago

I am only using own builds from git, so i am not very familiar with the releases, you need to ask Adam about it...

#12

Updated by Ovidiu Nicolae about 8 years ago

as i thought ....the openelec version of TVH doesn't have this feature included i mean the oscam mode tick.

#13

Updated by Ovidiu Nicolae about 8 years ago

Mariusz
openelec being precompiled solution i think it doesn't offer the posibility of an manual simple update right?
unless Adam can place it as feature and tell Sraue from openelec to compile it inside the future builds of openelec.

#14

Updated by Mariusz Białończyk about 8 years ago

  • Assignee changed from Mariusz Białończyk to Adam Sutton

Assigning to Adam to take a look - i am not an expert in the releases area ;)

#15

Updated by Igosr Petroff about 8 years ago

Check this:
http://webcache.googleusercontent.com/search?q=cache:i8koGps6o4AJ:www.streamboard.tv/oscam/ticket/2660+ECMs+origin+has+the+same+ip+as+reader&cd=1&hl=en&ct=clnk&client=ubuntu

Key phrase is:Commented the check (the two if's) out and it worked like before.
I can confirm that's working

#16

Updated by Adam Sutton about 8 years ago

Mariusz (or other),

Can I just check, do we believe this is a non-issue if using capmt? In which case I'm inclined to close this bug.

OE users will need to either compile from master or wait for 3.4 to be released. Or bug Stefan et al to include a dev build somewhere (though I think he'll object to that).

Adam

#17

Updated by Ovidiu Nicolae about 8 years ago

can be closed safe ....my TVH was outdated .... vpeter and me succeded to make an adition (fix) to the addon more info's here https://github.com/OpenELEC/OpenELEC.tv/issues/1703

Will ask sraue to make if possible the addition in the next RC of OE.

Anyway thank you for consideration.

Regards

#18

Updated by Adam Sutton about 8 years ago

  • Status changed from New to Invalid

No change required.

Also available in: Atom PDF