Project

General

Profile

Bug #1418

Map DVB services to channels (not working but not greyed out either)

Added by Gerrit Bosch over 8 years ago. Updated over 7 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
DVB
Target version:
-
Start date:
2012-11-21
Due date:
% Done:

0%

Estimated time:
Found in version:
3.1.694
Affected Versions:

Description

System Synology NAS DS211J, TVH 3.1.694 (from http://packages.synocommunity.com) and pinnacle usb dvb-t 73e Nano stick (adapter recognized by TVH as DiBcom 7000PC)and TVH webinterface http://192.168.10.162:9981/extjs.html tested on WIndows 7 Notebook and Windows Vista Desktop.
DS Video Station is working smooth with the pinnacle usb dvb-t 73e Nano stick and the Synology Diskstation DS211J, streaming the public channels Nederland 1, 2 and 3 on Ipad3 without problems.

Hardware
Device path:
/dev/dvb/adapter0
Device name:
DiBcom 7000PC
Host connection:
USB (480 Mbit/s)
Frequency range:
45000 kHz - 860000 kHz, in steps of 62 kHz
Status
Currently tuned to:

Services:
32
Muxes:
31
Muxes awaiting initial scan:
0

Add DVB network by location (works I choose Netherlands, nl_All and add DVB network)
After I press the button Map DVB services not channels (this option is not greyed out)

On system log i see:
Nov 21 19:20:41 web interface: Service probe started on "DiBcom 7000PC"
Further nothing is happening. I tryed to add the channels manually to rename the channelname, but that didn't work. I also stopped video station on my Synology. But that dind't help either. I remember that once i had an issue with video station. There i left the username and password empty and after it works. Can i do that somehow with TVH ? Does anybody know what is the problem ?


Files

TVHeadend 21 november 2012.docx (470 KB) TVHeadend 21 november 2012.docx Gerrit Bosch, 2012-11-21 19:34
bisect.log (2.18 KB) bisect.log bisect log Alexei Chetroi, 2013-10-27 02:12
v3.3-29-g16fdfd2-debug.txt (45.7 KB) v3.3-29-g16fdfd2-debug.txt working debug log for commit 16fdfd2547eedc0008802adde139a1681519a9f0 Alexei Chetroi, 2013-10-27 02:41
v3.5-245-g6c9bff1-debug.txt (23 KB) v3.5-245-g6c9bff1-debug.txt no svc names log for commit 6c9bff1179ef0dcdbb995e0d26c008fd1b6aeb06 Alexei Chetroi, 2013-10-27 02:41

History

#1

Updated by Gerrit Bosch over 8 years ago

Working with workaround

Map DVB services to channels doesn't work but I could press press play in the services. The link didn't openen automaticly in VLC player. I copied the link and openend it with VLC player with "open network stream". After that i could watch the Free To Air channels from Dutch digitenne. Manually i changed the channelname (services), so they showed up in Channels.

After I downloaded XBMC with the addon PVR TVHeadend from http://xbmc.opdenkamp.eu/ after that I oould watch the channels on XMNC live TV, by a very friendly user interface.

#2

Updated by m 321liftoff over 8 years ago

I may have seen something similar. When I upgraded to git version 5d2197c30f (Dec 03, 2012) from a different branch version from August 2012, I found the same behavior that you are describing. I investigated a bit, and found that after the Mux scan was complete, none of the services got named: the "Service Name" column was blank for all services on the Services tab under the adapter config settings. I think this was causing no action to occur when clicking the enabled "Map DVB Services to channels" button. I am in the US and use ATSC. Downgrading back to the older version allowed me to scan the muxes again and have them be named automatically, then map them to channels.

Hope this helps...

#3

Updated by m 321liftoff over 8 years ago

If I'm correct, keep an eye out for Bug 1429. Just saw that one...

#4

Updated by Adam Sutton over 8 years ago

  • Category changed from Streaming to DVB
  • Assignee deleted (John Törnblom)
#5

Updated by Adam Sutton over 8 years ago

  • Status changed from New to Need feedback

Can you possibly check if this is still happening, I've made several mods to the scanning code and I'm trying to figure out what has/hasn't been fixed.

Adam

#6

Updated by Mike Frisco over 8 years ago

I'm experiencing this exact same behavior with a different adapter.

I'm on TVH 3.3.485~gf4dda1b. I'm using a HDHomeRun (HDHR3-US) for over-the-air ATSC broadcasts in the US.

I get blank service names too, and clicking 'map dvb services' will only insert this line in the log:
web interface: Service probe started on "HDHomeRun ATSC 1"

#7

Updated by Mike Frisco over 8 years ago

One other note - when I go back to an older version of TVH installed on my Synology (3.2.18~g40a8920) the problem is not there.

#8

Updated by Adam Sutton over 8 years ago

The problem is that US services (or HDHR, its not entirely clear which). Do horrible things that are not very compliant, and unfortunately we added stuff in 3.4 to improve performance in other areas. This appears to have caused issues with the ATSC/HDHR stuff.

But I would like to get to the bottom of this. Can you please provide a full debug log for both 3.2 and git master, starting from fresh and running through the setup etc..

Adam

#9

Updated by Gerrit Bosch over 8 years ago

Thanks for the feedback. I use a HDHomerun HDHR3-EU device now with DVB-C, the last time I scanned the service name was not empty anymore. When the service name is empty I just fill in the service name myself and after the services are mapped to service. Further the system is working. I use TVHeadend, Oscam as a server on my NAS DS211J with Smargo smartreader plus, I put my the smartcard provided by the cable provider in the NAS in combination with XBMC on my Notebook and PC and InstaTVPro on my Ipad, to view the streams, II can view the scrambled channels on my Notebook and PC, smoothly decoded by Oscam and I can watch the free to air channels on my Ipad because TVHeadend is not supported by Apple (in my case Ipad3) and InstaTVPro is directly talking with HDHomerun. XBMC Is also running and working on my Raspberry Pi in combination with TVHeadend on my NAS. However on a laptop or PC it is working more smoothly (faster). Practical the first HDHomerun channel is used by TVHeadend and the second HDHomerun channel used by InstaTVPro.

#10

Updated by Gerrit Bosch over 8 years ago

Hello Adam,

Thank you for your answer. I Have Connected a HDhomerun de device now. So basicly new architecture. See my post before. So I can provide no feedback anymore, because in the present situation it is working. But I see I was not the only one who had this problem.

Gerrit

#11

Updated by Tom S over 8 years ago

If I can provide additional details to help track this down let me know as im having the same issue on my setup.

Using HDHomeRun Prime ATSC I can scan 248 Muxes (Standard center frequencies QAM256) and it finds an un-holy 539 unnamed services and clicking "Map DVB services to channels" spits a "web interface: Service probe started on "HDHomeRun ATSC 2" with nothing exciting that results from it.

I unfortunately don't even have the luxury of doing the workaround one of the users suggested by filling in the service names myself because when I click the "play" link after about a minute I get a popup option to download a link and I have no way of watching the streams to make any guesses. I randomly picked 100 services and add them manually to channels but when I try to view it in the built in VLC player I get a blank screen with "Waiting for video" on all of them.

Adam Sutton wrote:

The problem is that US services (or HDHR, its not entirely clear which). Do horrible things that are not very compliant, and unfortunately we added stuff in 3.4 to improve performance in other areas. This appears to have caused issues with the ATSC/HDHR stuff.

But I would like to get to the bottom of this. Can you please provide a full debug log for both 3.2 and git master, starting from fresh and running through the setup etc..

Adam

#12

Updated by Gerrit Bosch over 8 years ago

Hello Tom S,

Do you run TVHeadend on a Synology Diskstation ? The VLC problem I recognize, I once used a workaround I copied the url from TVheadend and started VLC Manually, I went in the menu to Media after I selected "Open Network Stream" and pasted the URL, then it worked.
If somebody have TVH running on a Synology Diskstation in combination with A HDHomerun device, the link below can maybe help you. It helped me a lot. After I could choose the correct broadcast standard (DVB-T, DVB-C or ATSC)and the channels were recognized. A tip use XBMC in combination with TVHeadend, VLC is too basic.
http://forum.synology.com/enu/viewtopic.php?f=190&t=55075

#13

Updated by Gerrit Bosch over 8 years ago

For Synology users (tested and working on DS211J)
USB Drivers synology ( serial drivers tested and working for HDHomerun HDHR3-EU)
usb-driver-kernel-2.6.32-mfr-1.0-syno-88f628x.spk
http://www.fischer-net.de/hausautomation/downloads/file/21-usb-driver-kernel-2-6-32-mfr-1-0-syno-88f628x-spk.html

#14

Updated by Adam Sutton over 8 years ago

Do we know if this is still happening, some improvements have been made that may mean some HDHR stuff now works. Though there is the possibility we will make more significant improvements in 3.6/4.0.

Adam

#15

Updated by Chris N over 8 years ago

I was experiencing this exact same problem when I tried upgrading my Synology DS213 to TVHeadend 3.4 Stable Release. When I scanned for channels on my HD Homerun, over 150 services were found, but all of the service names were blank. I was able to play the streams in VLC, but I just didn't know what services were which. I was also unable to map any services to channels. Nothing happened when I clicked on the 'Map' button. I didn't try manually entering any service names, so I'll give that a try on my next day off. For now, I just went back to TVHeadend 3.0 and everything is working fine again. I am in the Los Angeles area, so my setup is ATSC.

#16

Updated by Chris N over 8 years ago

Just an update that I was able to enter the channel names manually. What I did when I was still running TVH 3.0 was write down the multiplex and pid's of each service. Then after I installed TVH 3.4, I was able to easily figure out which channel was which.

#17

Updated by Mike Echevarria over 8 years ago

I am having the same issue with 3.4 stable and ATSC channel mapping. The services are discovered just fine, but pressing the Map button does not pick up any channel names. As with others, previous versions of TVheadend worked fine.

[[https://dl.dropboxusercontent.com/u/18055299/atsc_no_mapping.png]]

#18

Updated by Nic Fischer about 8 years ago

I ran a fresh install of raspbmc which packaged tvheadend 3.4. Using an HDHR3-US with an OTA antenna, I was able to successfully scan for muxes, however I am facing the same problem described by a lot of the posts in this thread: Services are unnamed when the mux search finishes, and pressing the map DVB services to channels does not appear to do anything.

The debug log at the bottom prints:
Jun 14 22:07:57.608 web interface: Service probe started on "Tuner 2"

I'd be happy to provide more debug logs if it will help in further diagnosis.

#19

Updated by Alexei Chetroi almost 8 years ago

I'm running HDHR3-US and experiencing the same issue. The muxes and services are detected, but service names are missing and map services to channels doesn't do anything.
Git branch v3.3 is running fine, so i did git bisect between v3.3 and 3.4patch1.
The 1cc67b75e8f7a90ef0d6aaaf88cf5cf633c8c840 commit seem to be the culprit. I don't get service names with this commit, yet the previous one 6fdfd2547eedc0008802adde139a1681519a9f is working just fine.

How do I capture the TS dump so I could attach it to this issue as well. Please let me know what other information i can provide to fix this issue.

#20

Updated by Alexei Chetroi almost 8 years ago

I'm attaching debug log for last working commit 16fdfd2547eedc0008802adde139a1681519a9f0 and git master. Both were cleanly compiled and configured from scratch.

#21

Updated by Sam Stenvall almost 8 years ago

@Alexei you grab a TS dump by clicking Play on the multiplex tab. It will start downloading a file so you'll have to cancel the download and copy the unfinished download someplace safe.

#22

Updated by Mark Lennox over 7 years ago

I am having the same problem with v3.4 stable and ATSC channels. Everything scans fine, but I can't map services to channels. When I click the map button, the debug log says:

Nov 02 17:33:30.468 web interface: Service probe started on "Auvitek AU8522 QAM/8VSB Frontend"
Nov 02 17:33:30.469 serviceprobe: Starting
Nov 02 17:33:30.469 serviceprobe: : checking...
Nov 02 17:33:30.469 dvb: "/dev/dvb/adapter0" tuning to "491,028 kHz" (Transport start)
Nov 02 17:33:30.469 subscription: "serviceprobe" direct subscription to adapter: "Auvitek AU8522 QAM/8VSB Frontend", network: "", mux: "491,028 kHz", provider: "", service: "", quality: 100
Nov 02 17:33:40.000 Service: Auvitek AU8522 QAM/8VSB Frontend/491,028 kHz: Status changed to [Graceperiod expired]
Nov 02 17:33:40.000 subscription: "serviceprobe" unsubscribing
Nov 02 17:33:40.000 serviceprobe: : skipped: No input detected
Nov 02 17:33:40.000 serviceprobe: Now idle

If this bug is not reproducible in V3.3, is there a way to install the old version in Ubuntu (without compiling from source). Secondly, what is the workaround for this (is there a step by step for manually adding channels)? I'm trying to switch from MythTV - but if I can't get it to work, then I may stop investigating TVHeadEnd :(

#23

Updated by Adam Sutton over 7 years ago

  • Status changed from Need feedback to Invalid

Closing this as it relates to code that has been replaced, that's not to say the new code isn't also broken, but need to start drawing a line under old features.

#24

Updated by Mark Lennox over 7 years ago

Is this replaced code available in a stable build? How does one get a hold of this changed feature under Ubuntu (what repo is it?). Instead of closing the bug, isn't there another status that can be used until someone verifies that this feature works in the new version (which I'm assuming will be v3.6 stable)?

I can't use TVHeadEnd until this is working.:(

Also available in: Atom PDF