Project

General

Profile

Bug #1397

Webui allows access only to admin users

Added by Walter Purcaro almost 8 years ago. Updated almost 8 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
User Interface
Target version:
Start date:
2012-11-12
Due date:
% Done:

100%

Estimated time:
Found in version:
fcaf92e1ab6cc6dfa8eb8671d8e4545601610aa1
Affected Versions:

Description

When I try to login as not-admin user, the server constantly asking for credentials, but if I give it the same every time, it continues to load ui, piece by piece. :S


Files

screen.png (101 KB) screen.png User "test" is not an admin user Walter Purcaro, 2012-11-12 13:53

Associated revisions

Revision e74f5357 (diff)
Added by Adam Sutton almost 8 years ago

Fix #1397 - only load adapter config if tab is enabled.

Revision 3aae0928 (diff)
Added by Adam Sutton almost 8 years ago

Fix #1397 - only load adapter config if tab is enabled.
(cherry picked from commit e74f53574cf1449c8e94d22da0bb2fca50473b65)

History

#1

Updated by cocoa 117 almost 8 years ago

I can also confirm this bug. However I don't think the Webui disallow access other user, it just you have to at least type in your username and password three times or few more, then just click cancel to certain point and then type in your username and password again before auth window can disappear.

I am running Tvheadend 3.2.18~g40a8920~precise.

#2

Updated by Walter Purcaro almost 8 years ago

I think I've understood what's wrong... :)

#3

Updated by Adam Sutton almost 8 years ago

  • Status changed from New to Need feedback

Walter,

I've just submitted a fix for #1393, I wonder if this fix may also fix this issue?

Could you check.

Ta
Adam

#4

Updated by Walter Purcaro almost 8 years ago

Apparently not. :(
I think this issue is simply an effect of have components under a same tabpanel with higher access permission level than that panel has.

#5

Updated by Adam Sutton almost 8 years ago

  • Status changed from Need feedback to Accepted
  • Target version set to 3.4
  • Affected Versions 3.2, 3.3 added

I think the problem is basically the same problem as #1393, but its a more pervasive problem.

I'll take a quick look, but its not my area of expertise.

Adam

#6

Updated by Adam Sutton almost 8 years ago

Ok,

same problem different file. I believe it now works, however because I don't fully understand how the browsers handle auth changes (and it probably varies from browser to browser) it can be a bit contrived to get it to switch from one user to another.

But I consider that a separate issue that probably needs better management of auth on the UI.

Adam

#7

Updated by Adam Sutton almost 8 years ago

  • Status changed from Accepted to Fixed
  • % Done changed from 0 to 100
#8

Updated by Adam Sutton almost 8 years ago

  • Target version changed from 3.4 to 3.2
#9

Updated by Adam Sutton almost 8 years ago

  • Status changed from Fixed to Resolved
#10

Updated by Adam Sutton almost 8 years ago

  • Status changed from Resolved to Fixed

Also available in: Atom PDF