Project

General

Profile

Bug #1393

digital video recorder post-processor command format string

Added by cocoa 117 almost 8 years ago. Updated almost 8 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
Category:
PVR / DVR
Target version:
Start date:
2012-11-10
Due date:
% Done:

100%

Estimated time:
Found in version:
3.2.18~g40a8920~precise
Affected Versions:

Description

The digital video recorder post-processor command format string %f "full path to recording" gives // slash, which make it impossible to use in bash script.

E.g.
/srv/tvRecordings//Hairy Dieters_ How to Love Food and.ts

I decide to use %b basename of recording instead, but i think it is simple error.

Associated revisions

Revision c05f93da (diff)
Added by Adam Sutton almost 8 years ago

Issue #1393 - minor aesthetic change, remove trailing slash from user config DVR directory.

Revision 4f9f3485 (diff)
Added by Adam Sutton almost 8 years ago

Fix #1393 - minor aesthetic change, remove trailing slash from user config DVR directory.

(cherry picked from commit c05f93da5321a8b14f209814e78a6a1581232540)

History

#1

Updated by Adam Sutton almost 8 years ago

  • Status changed from New to Accepted
  • Affected Versions 3.2, 3.3 added

Hmmm, not sure why that would make it "impossible" to use in a bash script :p Pretty trivial to work-around if you ask me:

$> T="this//is/a/bad/path"
$> X=${T//\/\//\/}
$> echo $T
this/is/a/bad/path

However I will see if I can figure out where the // comes from.

Adam

#2

Updated by Adam Sutton almost 8 years ago

Just a quick question, have you included a trailing slash on your DVR configuration directory?

Adam

#3

Updated by Adam Sutton almost 8 years ago

  • Status changed from Accepted to Need feedback
#4

Updated by cocoa 117 almost 8 years ago

Adam Sutton wrote:

Just a quick question, have you included a trailing slash on your DVR configuration directory?

Adam

Yes, I realised this was due to I have put trailing slash on my DVR configuration. So it is not a bug after all.

It would be great if we can upgrade the help, so the user don't put trailing slash in the end.

#5

Updated by Adam Sutton almost 8 years ago

  • Status changed from Need feedback to Resolved
#6

Updated by Adam Sutton almost 8 years ago

  • Target version set to 3.2
#7

Updated by Adam Sutton almost 8 years ago

  • Status changed from Resolved to Fixed
  • % Done changed from 0 to 100

Also available in: Atom PDF