Project

General

Profile

Bug #1369

Asking for authentication where it shouldn't really

Added by Moritz Schlarb almost 8 years ago. Updated almost 8 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
User Interface
Target version:
Start date:
2012-10-28
Due date:
% Done:

100%

Estimated time:
Found in version:
3.2
Affected Versions:

Description

I have configured Tvheadend ACLs to allow streaming and webui access from localhost without username and password for the HTTP reverse proxy at :80, and I have an administrational account with password, which I access through :9981.

Since in newer releases, the system log seems to belong to the administrational information (which I think is very right), this leads to the browser prompting for authentication when I access the interface on Port 80. That dialog can be cancelled and the rest of the webui works fine.

Attached are screenshots of the ACL config tab and the authentication prompt with the rest of the website visible in the background.


Files

Associated revisions

Revision 254872a8 (diff)
Added by Adam Sutton almost 8 years ago

Issue #1369 - move iptv service type store inside main tab function else it causes a 401 error for non-admin UI users.

Revision 0e589a3a (diff)
Added by Adam Sutton almost 8 years ago

Fix #1369 - move iptv service type store inside main tab function else it causes a 401 error for non-admin UI users.

(cherry picked from commit 254872a8f8ec5c43c0dce86f1e521f9c22e361df)
(cherry picked from commit 777e4108b96e6fa15ce3ed2bd0592a3e427bcea2)

History

#1

Updated by Walter Purcaro almost 8 years ago

I'll take a look, maybe could do something on webui side. :)

#2

Updated by Moritz Schlarb almost 8 years ago

My initial guess, that it is due to the logging pane might be wrong!

I observed that the authentication dialog comes at a point of initial page loading when only the EPG tab is shown. If I cancel the dialog, DVR and About get shown.
Maybe it's because authentication for the Configuration tab is checked then.

Just a vague guess...

#3

Updated by Walter Purcaro almost 8 years ago

I agree and made some changes about tab loading sequence, but not sure I've fix all issues... So, I'm still in "testing phase". ;)

#4

Updated by Adam Sutton almost 8 years ago

  • Category set to 11
  • Status changed from New to Accepted
  • Affected Versions 3.3 added
#5

Updated by Moritz Schlarb almost 8 years ago

I nailed it down to a request to

/iptv/services

I'm now just intercepting that request in the HTTP proxy configuration by returning a 404.

This leads to the authentication dialog not showing anymore and no functional losses so far.

#6

Updated by Adam Sutton almost 8 years ago

Reproducible on my setup. I'll have a quick look at what's going on, but Walter if you have some useful input let me know.

Still waiting for that PR ;)

Adam

#7

Updated by Adam Sutton almost 8 years ago

OK, I've tracked down where this is going wrong. I just need to understand what the fix is.

Adam

#8

Updated by Adam Sutton almost 8 years ago

OK,

problem found and fixed, I'll push later when I've been through all the other bits and pieces. If you want to test short term, try the attached patch.

Adam

#9

Updated by John Törnblom almost 8 years ago

I can't seem to add a new entry (iptv service) after this was fixed:

Uncaught TypeError: Cannot call method 'getById' of undefined  (iptv.js:119)
#10

Updated by Adam Sutton almost 8 years ago

  • Status changed from Accepted to Resolved
  • Target version set to 3.2
#11

Updated by Adam Sutton almost 8 years ago

  • Status changed from Resolved to Fixed
  • % Done changed from 0 to 100

Also available in: Atom PDF