Project

General

Profile

Bug #1356

Scheduling a standalone +1 recording and then the identical programme on the non-timeshifted channel deletes the first event

Added by Prof Yaffle almost 8 years ago. Updated almost 8 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
Category:
PVR / DVR
Target version:
Start date:
2012-10-23
Due date:
% Done:

100%

Estimated time:
Found in version:
3.1.776~ge3231ec~oneiric
Affected Versions:

Description

Search for a programme to record on a +1 channel... record this one event. Goes into the schedule correctly, and the dvr/log file is created accordingly.

Now change the filter to the non-timeshifted variation of the same channel, and record the same programme one hour earlier. Instead of creating a new event, tvheadend deletes the first one - so neither timeshifted nor non-timeshifted programmes now appear in dvr/log.

If you do it the other way around (normal then +1), the event remains scheduled but the second event isn't created (similar to issue 1355?)

Associated revisions

Revision fbe2db07 (diff)
Added by Adam Sutton almost 8 years ago

Refs #1355, Refs #1356 - Fix problem with DVR dup detect.

I have completely removed global duplicate detection at this stage until
such time as I can do things properly. This means a user can ALWAYS manually
override and force a recording of a show.

For now duplicate detection only exists within the context or a series
link. So it will only record the "first?" instance of a given episode in
a give series link.

This is still a bit of a hack until I provide the user with the ability
to control the configuration and implement all the hooks properly.

Revision 2aa067c7 (diff)
Added by Adam Sutton almost 8 years ago

Fix #1355, #1356 - Fix problem with DVR dup detect.

I have completely removed global duplicate detection at this stage until
such time as I can do things properly. This means a user can ALWAYS manually
override and force a recording of a show.

For now duplicate detection only exists within the context or a series
link. So it will only record the "first?" instance of a given episode in
a give series link.

This is still a bit of a hack until I provide the user with the ability
to control the configuration and implement all the hooks properly.
(cherry picked from commit fbe2db07101806acdfe9a667ff9daf6766b1a199)

History

#1

Updated by Adam Sutton almost 8 years ago

Looking at the code, I have to admit it doesn't look entirely correct.

I think part of the problem is that I started to add updates to the DVR code back when I was first doing the EPG updates. Unfortunately I don't think they were ever properly finished, but stuff moved on my involvement grew and I never properly revisited that code.

I think this could be quite a big cockup in the DVR code that I'll need to fix :( Unfortunately 3.2 is basically now in the can, so I guess we'll be having a patch release in the not too distant future to pick this (and a few other minor bits up).

Adam

#2

Updated by Adam Sutton almost 8 years ago

  • Category changed from DVB to PVR / DVR
  • Assignee changed from Hein Rigolo to Adam Sutton
  • Target version set to 3.2

I think this will need to be back-ported to 3.2, once I've found a fix.

#3

Updated by Adam Sutton almost 8 years ago

  • Status changed from New to Accepted
#4

Updated by Adam Sutton almost 8 years ago

  • Affected Versions 3.2 added
#5

Updated by Adam Sutton almost 8 years ago

  • Status changed from Accepted to Resolved

I think the latest commit will resolve this issue. If you could try this out on git master I will look to include in next 3.2 patch release.

Adam

#6

Updated by Prof Yaffle almost 8 years ago

Confirmed that it appears to function correctly with this commit - I can't test it fully as I've got some hideous frankenconfig trying to compile and run this alongside my production PPA version. But it seems to work!

Thanks for the rapid attention.

#7

Updated by Adam Sutton almost 8 years ago

  • Status changed from Resolved to Fixed
  • % Done changed from 0 to 100

Also available in: Atom PDF