Project

General

Profile

Feature #1354

Feature #1232: dynamic dvb device management

TVHeadEnd should wait until TV tuners are up at boot.

Added by Fabian Rodriguez almost 8 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
DVB
Target version:
-
Start date:
2012-11-21
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)

Description

I've come across this bug in new installs under Ubuntu 12.04 LTS and Trisquel 6 alpha (GNU/Linux).

This doesn't seem to be a problem with adapters that are in the same system (ie. PCI/USB) but has come up when using the HDHomeRun network-based TV tuners.

I followed this guide to perform a clean-room install of 12.04 LTS:
https://www.lonelycoder.com/redmine/boards/14/topics/3368?r=3548#message-3548

I intentionally didn't follow any of the "start file helpers" etc. advice, but tested this:

1) Go to TVHeadEnd interface
2) Verify adapters aren't up (they aren't) under Configuration > TV adapters > dropdown list
3) Restart TVHeadend:
sudo service tvheadend restart
4) Check again (step 3): adapters are there after a few seconds

At the end of that guide the problem is discussed.

Basically after adding XBMC, TVHEadEnd and DVBHDHomerunPPAs, everything installs properly and the web interface for TVHEadEnd performs as expected. However, the tvheadend service has to be restarted to make the adapters visible to TVHEadEnd. Dmesg and /var/log/syslog show the HDHomerun coming up/visible as expected, but TVHeadEnd won't see them until restarted.

This XBMC forum post provides more details and a workaround:
http://forum.xbmc.org/showthread.php?tid=127803

Waiting for any adapters (not only the HDHomerun) to be up should not slow down startup for other setups.

I don't know enough about upstart to tackle this, but it seems /etc/init/tvheadend.conf should include a condition to wait for the TV tuners hardware to be up, much like it waits for network.

Rebooting


Subtasks

Feature #1419: Delay start of tvheadendRejected

Actions

History

#1

Updated by Adam Sutton almost 8 years ago

  • Tracker changed from Bug to Feature
  • Category set to DVB

This is not a bug, its clearly state (somewhere) that the adapters must be up before TVH can be started, this includes USB adapters (which also shouldn't be unplugged while TVH is running).

Simply waiting for adapters to be "up" isn't a simple task, we'd need to know which adapters to expect (I guess you could assume those which have been previously configured etc.. but what then if stuff isn't available anymore).

However there are plans to restructure things and make this sort of thing easier, as we are aware that some tuners do take a while to start up and causes particular problems with things like HDHomerun and on embedded systems like OpenELEC.

Adam

#2

Updated by Adam Sutton over 7 years ago

  • Status changed from New to Rejected
  • Parent task set to #1232

Making this dup of #1232

Also available in: Atom PDF