Project

General

Profile

Bug #1327

/home/hts/.hts/tvheadend/dvr/config over-ridden by /home/xbmc/.hts/tvheadend/dvr/config

Added by Prof Yaffle almost 9 years ago. Updated almost 9 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
User Interface
Target version:
-
Start date:
2012-10-13
Due date:
% Done:

0%

Estimated time:
Found in version:
3.1.769~g4303374~oneiric
Affected Versions:

Description

... which may not be a bug, but it's damned annoying when the web interface modifies the former!

It may be that the latter file is a leftover from a previous version that simply hasn't been cleaned out. However, in this scenario, it's impossible to change the DVR configuration (lead time, lag time, file name...) since the changes are saved into a file that apparently isn't read...

Compare:

[email protected]:/home/hts/.hts/tvheadend/dvr# more config
{
        "storage": "/home/xbmc/Recordings",
        "container": 1,
        "retention-days": 31,
        "pre-extra-time": 1,
        "post-extra-time": 5,
        "day-dir": 0,
        "channel-dir": 0,
        "channel-in-title": 0,
        "date-in-title": 1,
        "time-in-title": 1,
        "whitespace-in-title": 0,
        "title-dir": 0,
        "episode-in-title": 0,
        "clean-title": 0,
        "tag-files": 1
}


with
[email protected]:~/.hts/tvheadend/dvr$ more config
{
        "storage": "/home/xbmc/Recordings",
        "retention-days": 31,
        "pre-extra-time": 1,
        "post-extra-time": 1,
        "day-dir": 0,
        "channel-dir": 0,
        "channel-in-title": 0,
        "date-in-title": 1,
        "time-in-title": 1,
        "whitespace-in-title": 0,
        "title-dir": 0,
        "episode-in-title": 0,
        "tag-files": 1
}
[email protected]:~/.hts/tvheadend/dvr$

... and I only get 1 minute trailing no matter how often I change it in the web interface...

History

#1

Updated by Prof Yaffle almost 9 years ago

Interestingly, I've just spotted the same with accesscontrol - that's also defaulting to the /home/hts version.

Is it just a change of user for the tvheadend process? Is it best to simply trash the /home/xbmc tvheadend config, then?

Confused.

#2

Updated by Prof Yaffle almost 9 years ago

Mornin' - dog with a bone here :-)

I think it's a PPA/version/installation clash... I notice that my old recordings were recorded as xbmc/video, but the new ones by hts/video. I assume that, somewhere in the move between the Pulse8 version and the beta (maybe 3.0 to 3.1.732?), the user under which tvheadend runs has changed/reverted to default - possibly fingerpokingproblems on my part, possibly automatically.

Anyway, whyever, this means that all config files have shifted to /home/hts instead of wherever-they-were-before. What's interesting, though, is that they're still being over-ridden by the current-user configs - which is xbmc in my case. So the webui alters the default set, but the old "ghosts" seem to still prevail, and only manually editing these files changes anything.

/etc/default/tvheadend confirms this, user is defaulted to hts in line 11, with associated config in line 19.

Simply removing /home/xbmc/.hts/tvheadend seems to solve the problem and not affect anything else in the slightest, because all channel configs, dvr configs, access control, etc. are now in /home/hts instead.

#3

Updated by Adam Sutton almost 9 years ago

  • Status changed from New to Rejected

I can't speak for any unofficial packages such as the ones provided by Lars, but as far as I'm aware the default configuration directory for the deb packages has always been ~hts/.hts/tvheadend. This is definitely true for 2.12, 3.0 and 3.2.

If the unofficial packages had different installation directories that could indeed result in the problems noted about missing configuration. Though I don't really follow the point about it mixing the configs, I really don't see this being possible (for one the files will be owned by the wrong user).

Closing this as its not a problem with Tvheadend, merely a possible configuration diff between unofficial and official packages.

Adam

#4

Updated by Prof Yaffle almost 9 years ago

MMm, understand why you'd reject it - but why would it still pick up a config that you can't actually edit? Is that function as intended, or an artefact of "account precedence"?

It may be that I've just created an odd situation with usernames or something, but it's still a little strange. I've solved it, so I'm happy, but I'm left wondering if it could happen to someone else for similar reasons (as well as wondering how it happened!).

Thanks, as always.

Also available in: Atom PDF