Project

General

Profile

Bug #1276

DiBcom 7000PC: Not able to scan for services on Raspberry Pi

Added by Ladislav Jozsa over 7 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-09-29
Due date:
% Done:

0%

Estimated time:
Found in version:
HTS Tvheadend 3.3.6.gf2681
Affected Versions:

Description

Hi,

I'm having issues with tvheadend with Pinnacle PCTV 73e (DiBcom 7000PC), firmware dvb-usb-dib0700-1.20.fw. I'm trying to run it on Raspberry Pi, I have cloned the latest compose from git. When scanning for services I'm getting errors

Sep 29 18:37:45 [ERROR]:dvb: "/dev/dvb/adapter0" tuning to "586,000 kHz" -- Front configuration failed -- No such device, frequency: 586000000
Sep 29 18:38:05 [DEBUG]:dvb: "/dev/dvb/adapter0" tuning to "570,000 kHz" (Initial autoscan)
Sep 29 18:38:05 [ERROR]:dvb: "/dev/dvb/adapter0" tuning to "570,000 kHz" -- Front configuration failed -- No such device, frequency: 570000000
Sep 29 18:38:25 [DEBUG]:dvb: "/dev/dvb/adapter0" tuning to "562,000 kHz" (Initial autoscan)
Sep 29 18:38:25 [ERROR]:dvb: "/dev/dvb/adapter0" tuning to "562,000 kHz" -- Front configuration failed -- No such device, frequency: 562000000
Sep 29 18:38:45 [DEBUG]:dvb: "/dev/dvb/adapter0" tuning to "538,000 kHz" (Initial autoscan)
Sep 29 18:38:45 [ERROR]:dvb: "/dev/dvb/adapter0" tuning to "538,000 kHz" -- Front configuration failed -- No such device, frequency: 538000000

Running the same on my x86_64 machine works and tvheadend sees multiplexes. What information do you need from me in order to track the problem?

History

#1

Updated by Adam Sutton over 7 years ago

  • Status changed from New to Rejected

This is almost certainly a driver or firmware issue and not a tvh problem. As you pointed out tvh works fine with the same tuner in another machine.

I'd suggest contacting the driver author or the rpi guys.

Adam

#2

Updated by Eric Valette over 7 years ago

I use a dual adapter on the PI and the problem is that the USB port does not deliver more than 147 mA. My dual tuner requires 210 mA minimum and does not work. You should probably use a powered USB hub and see if the problem persists.

#3

Updated by Ladislav Jozsa over 7 years ago

Hi Eric,

thanks for the tip! I tried to connect the adapter behind a powered USB hub and it's working. :-)

Ladislav

Also available in: Atom PDF