Project

General

Profile

Bug #1269

Bug #1257: TVHeadend segfaults

Random crashes

Added by S├ębastien Aubry almost 10 years ago. Updated almost 10 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-09-28
Due date:
% Done:

0%

Estimated time:
Found in version:
3.1.1~git201209182221.2099~0ubuntu1~ppa1~oneiric1
Affected Versions:

Description

Since my tvheadend version was updated from 2.99-9~oneiric to 3.1.1~git201209182221.2099~0ubuntu1~ppa1~oneiric1 (following ppa:jabbors/hts-stable), I have the following problem:
After a few hours, TvHeadend will just crash:

Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: Signal: 6 in PRG: tvheadend () [2f4024c1e505b07367dbb5e9dd09dedc1836d8be] CWD: /home/spontex  
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: Fault address 0x46c3 (N/A)
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: Loaded libraries: /lib/i386-linux-gnu/libcrypto.so.1.0.0 /lib/i386-linux-gnu/libz.so.1 /usr/lib/i386-linux-gnu/libavahi-common.so.3 /usr/lib/i386-linux-gnu/libavahi-client.so.3 /lib/i386-linux-gnu/librt.so.1 /lib/i386-linux-gnu/libdl.so.2 /lib/i386-linux-gnu/libpthread.so.0 /lib/i386-linux-gnu/libc.so.6 /lib/i386-linux-gnu/libdbus-1.so.3 /lib/ld-linux.so.2  
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: Register dump [19]: 00000033 00000000 0000007b 0000007b b74ebff4 b74abd5e bf99c5e8 b6122a10 000046c3 00000006 000046c7 00000000 00000000 00000000 b7708424 00000073 00000206 b6122a10 0000007b 
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: STACKTRACE
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: ??:0 0x806caa2
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: __kernel_rt_sigreturn+0x0  ()
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: __kernel_vsyscall+0x10  ()
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: gsignal+0x4f  (/lib/i386-linux-gnu/libc.so.6)
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: abort+0x175  (/lib/i386-linux-gnu/libc.so.6)
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: __assert_fail+0xf6  (/lib/i386-linux-gnu/libc.so.6)
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: ??:0 0x8050f40
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: ??:0 0x8050f8b
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: ??:0 0x8051ff1
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: ??:0 0x80772d6
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: ??:0 0x8078159
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: ??:0 0x808fe57
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: ??:0 0xb74f7d31
Sep 28 22:40:16 pchc tvheadend[18115]: CRASH: clone+0x5e  (/lib/i386-linux-gnu/libc.so.6)

Attached is the complete TvHeadend syslog.
I did not have this problem with version 2 (uptime of several days without any problem).


Files

log_tvheadend.txt (14 KB) log_tvheadend.txt S├ębastien Aubry, 2012-09-28 23:42

History

#1

Updated by Adam Sutton almost 10 years ago

  • Status changed from New to Rejected
  • Parent task set to #1257

I'm gonna close this for 2 reasons:

1. There isn't really any info to go on (which I know is not your fault)
2. Most importantly I'm gonna make a judgement call and say this is a duplicate of #1257 which has been fixed.

Adam

Also available in: Atom PDF