Project

General

Profile

Bug #1198

TVHeadend Crash While Idle (Idle Scanning?) - 2.99.53.4502158

Added by Prof Yaffle almost 9 years ago. Updated almost 9 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
DVB
Target version:
-
Start date:
2012-09-03
Due date:
% Done:

0%

Estimated time:
Found in version:
2.99.53.4502158
Affected Versions:

Description

I appreciate that these are hard to track down, but I'm hoping there's sufficient information here to at least point to the right module. Maybe the issue is already fixed in pre-3.

The system was just sitting there, not doing anything to my knowledge (perhaps updating the EPG or something like that, but not playing or recording). I'd just booted a laptop so the only event could have been the already-open web page trying to refresh, but I don't think so - it was when I went to refresh it that I noticed tvheadend's absence.

A quick look in syslog revealed the following:

Sep  3 11:43:04 revo kernel: [427664.080257] tbsqboxs2: tbsqboxs2_set_voltage 0
Sep  3 11:43:12 revo tvheadend[1068]: dvb: New mux "11,661 kHz" created by automatic mux discovery
Sep  3 11:43:12 revo tvheadend[1068]: CRASH: Signal: 11 in PRG: /usr/bin/tvheadend (2.99.53.4502158) [a39c870770438080f379ee47218fb5e4defe5544] CWD: /
Sep  3 11:43:12 revo tvheadend[1068]: CRASH: Fault address (nil) (Address not mapped)
Sep  3 11:43:12 revo tvheadend[1068]: CRASH: Loaded libraries: /lib/i386-linux-gnu/librt.so.1 /lib/i386-linux-gnu/libdl.so.2 /usr/lib/i386-linux-gnu/libavahi-common.so.3 /usr/lib/i386-linux-gnu/libavahi-client.so.3 /lib/i386-linux-gnu/libcrypto.so.1.0.0 /lib/i386-linux-gnu/libpthread.so.0 /lib/i386-linux-gnu/libc.so.6 /lib/ld-linux.so.2 /lib/i386-linux-gnu/libdbus-1.so.3 /lib/i386-linux-gnu/libz.so.1 /lib/i386-linux-gnu/libnss_compat.so.2 /lib/i386-linux-gnu/libnsl.so.1 /lib/i386-linux-gnu/libnss_nis.so.2 /lib/i386-linux-gnu/libnss_files.so.2
Sep  3 11:43:12 revo tvheadend[1068]: CRASH: Register dump [19]: 00000033 c1530000 ffff007b 0000007b b6572ea0 00000000 b1e27fb0 b54fbad0 0042dff4 00000000 00000000 00000000 0000000e 00000004 0032b6a1 00000073 00010246 b54fbad0 0000007b
Sep  3 11:43:12 revo tvheadend[1068]: CRASH: STACKTRACE
Sep  3 11:43:13 revo tvheadend[1068]: CRASH: ??:0 0x8067aa2
Sep  3 11:43:13 revo tvheadend[1068]: CRASH: __kernel_rt_sigreturn+0x0  ()
Sep  3 11:43:13 revo tvheadend[1068]: CRASH: ??:0 0x32b6a1
Sep  3 11:43:13 revo tvheadend[1068]: CRASH: __strdup+0x26  (/lib/i386-linux-gnu/libc.so.6)
Sep  3 11:43:13 revo tvheadend[1068]: CRASH: ??:0 0x8063d36
Sep  3 11:43:13 revo tvheadend[1068]: CRASH: ??:0 0x8087052
Sep  3 11:43:13 revo tvheadend[1068]: CRASH: ??:0 0x8088469
Sep  3 11:43:13 revo tvheadend[1068]: CRASH: ??:0 0x8083454
Sep  3 11:43:13 revo tvheadend[1068]: CRASH: ??:0 0x8083c5a
Sep  3 11:43:13 revo tvheadend[1068]: CRASH: ??:0 0x6b2d31
Sep  3 11:43:13 revo tvheadend[1068]: CRASH: clone+0x5e  (/lib/i386-linux-gnu/libc.so.6)
Sep  3 11:43:13 revo kernel: [427673.040922] tvheadend[1212]: segfault at 0 ip 0032b6a1 sp b54fbad0 error 4 in libc-2.13.so[2b4000+178000]
Sep  3 11:43:13 revo kernel: [427673.156576] dvb-usb: error while stopping stream.
Sep  3 11:43:13 revo kernel: [427673.268041] tbsqboxs2: tbsqboxs2_set_voltage 2
Sep  3 12:10:24 revo tvheadend[13642]: dvb: Found adapter /dev/dvb/adapter0 (DiBcom 7000PC) via USB (480 Mbit/s)
Sep  3 12:10:24 revo tvheadend[13642]: dvb: Found adapter /dev/dvb/adapter1 (Conexant CX24116/CX24118) via USB (480 Mbit/s)
Sep  3 12:10:25 revo kernel: [429305.036335] tbsqboxs2: tbsqboxs2_set_voltage 1
Sep  3 12:10:28 revo tvheadend[13642]: EPG: Injected 4340 event from disk database
Sep  3 12:10:28 revo tvheadend[13642]: dvr: Creating new configuration ''
Sep  3 12:10:28 revo tvheadend[13642]: CSA: Using SSE2 128bit parallel descrambling
Sep  3 12:10:28 revo tvheadend[13642]: START: HTS Tvheadend version 2.99.53.4502158 started, running as PID:13642 UID:1000 GID:44, settings located in '/home/xbmc/.hts/tvheadend', dataroot: /usr/share/tvheadend
Sep  3 12:10:28 revo tvheadend[13642]: htsp: Got connection from 127.0.0.1
Sep  3 12:10:28 revo tvheadend[13642]: htsp: 127.0.0.1: Welcomed client software: XBMC Media Center
Sep  3 12:10:28 revo tvheadend[13642]: htsp: 127.0.0.1 [ XBMC Media Center ]: Identified as user xbmc
Sep  3 12:10:29 revo tvheadend[13642]: AVAHI: Service 'Tvheadend' successfully established.
Sep  3 12:10:30 revo tvheadend[13642]: xmltv: Grabbing "Combine data from several other grabbers" using command "/usr/bin/tv_grab_combiner" 

... I kept the lines pertaining to the subsequent service restart (sudo service tvheadend start) in case they're relevant in some way. You can see that tvh had just reported finding a new mux, but whether that's linked or not I have no idea.

First time I've seen this, so it could be a while before it could be reproduced.

Cheers,

Ian

History

#1

Updated by Adam Sutton almost 9 years ago

  • Category changed from General to DVB
  • Status changed from New to Rejected
  • Assignee changed from Hein Rigolo to Adam Sutton

Yeah unfortunately there is almost nothing to go on there. Especially if the issue is not repeatable.

Plus the code has changed a lot since this version.

I think it very unlikely this will be investigated so I'm going to close. However if it can be repeated and a gdb trace be collected it might be possible to investigate.

However there have been similar problems to this (difficult to be sure there the same due to lack of info) which have definitely been fixed in latest code.

Adam

#2

Updated by Prof Yaffle almost 9 years ago

Understood - I'm happy to run it in gdb for a while to see if it happens again if you wish, but won't lose any sleep.

I'm guessing it's more complicated than a simple sudo gdb <progname> <pid> - looks like I'd have to start with source, and at that point I'd probably go to the later version versus the PPA binary anyway. Let me know if it's worth pursuing, but it sounds doubtful.

#3

Updated by Adam Sutton almost 9 years ago

I'm tempted to say don't waste your time. There is at least one fix that was for a problem which superficially caused a similar crash.

Unfortunately those changes are not back ported to 3.0 series, so you'd have to run git master. Which has its own problems at this stage.

Sorry I can't be much clearer. But if you do still get problems with 3.0 or git master let me know.

Adam

#4

Updated by xraynorm - almost 9 years ago

Ian Harper wrote:

I appreciate that these are hard to track down, but I'm hoping there's sufficient information here to at least point to the right module. Maybe the issue is already fixed in pre-3.

The system was just sitting there, not doing anything to my knowledge (perhaps updating the EPG or something like that, but not playing or recording). I'd just booted a laptop so the only event could have been the already-open web page trying to refresh, but I don't think so - it was when I went to refresh it that I noticed tvheadend's absence.

A quick look in syslog revealed the following:

[...]

... I kept the lines pertaining to the subsequent service restart (sudo service tvheadend start) in case they're relevant in some way. You can see that tvh had just reported finding a new mux, but whether that's linked or not I have no idea.

First time I've seen this, so it could be a while before it could be reproduced.

Cheers,

Ian

#5

Updated by xraynorm - almost 9 years ago

Sorry posted the last message in error!

#6

Updated by Prof Yaffle almost 9 years ago

Just to let you know that this is still apparent in 3.0 - exact same behaviour, it's picking up a new mux and shooting itself. Log extracts:

Sep 19 10:48:37 revo tvheadend[1071]: dvb: New mux "11,661 kHz" created by automatic mux discovery
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: Signal: 11 in PRG: /usr/bin/tvheadend (3.0) [b41941717f11ef3a78ea2e9bd61f6da283712c1a] CWD: /
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: Fault address (nil) (Address not mapped)
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: Loaded libraries: /lib/i386-linux-gnu/librt.so.1 /lib/i386-linux-gnu/libdl.so.2 /usr/lib/i386-linux-gnu/libavahi-common.so.3 /usr/lib/i386-linux-gnu/libavahi-client.so.3 /lib/i386-linux-gnu/libcrypto.so.1.0.0 /lib/i386-linux-gnu/libpthread.so.0 /lib/i386-linux-gnu/libc.so.6 /lib/ld-linux.so.2 /lib/i386-linux-gnu/libdbus-1.so.3 /lib/i386-linux-gnu/libz.so.1 /lib/i386-linux-gnu/libnss_compat.so.2 /lib/i386-linux-gnu/libnsl.so.1 /lib/i386-linux-gnu/libnss_nis.so.2 /lib/i386-linux-gnu/libnss_files.so.2
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: Register dump [19]: 00000033 c1530000 ffff007b ffff007b 089bd8d8 00000000 094d70e0 b5775ad0 00fd2ff4 00000000 00000000 00000000 0000000e 00000004 00ed06a1 00000073 00010246 b5775ad0 0000007b
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: STACKTRACE
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: ??:0 0x8067cf2
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: __kernel_rt_sigreturn+0x0  ()
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: ??:0 0xed06a1
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: __strdup+0x26  (/lib/i386-linux-gnu/libc.so.6)
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: ??:0 0x8063ea6
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: ??:0 0x8087312
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: ??:0 0x80886f9
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: ??:0 0x80836f4
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: ??:0 0x8083ca7
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: ??:0 0x2c8d31
Sep 19 10:48:37 revo tvheadend[1071]: CRASH: clone+0x5e  (/lib/i386-linux-gnu/libc.so.6)
Sep 19 10:48:37 revo kernel: [346815.826239] tvheadend[1194]: segfault at 0 ip 00ed06a1 sp b5775ad0 error 4 in libc-2.13.so[e59000+178000]


Sep 20 03:44:55 revo tvheadend[1056]: dvb: New mux "11,661 kHz" created by automatic mux discovery
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: Signal: 11 in PRG: /usr/bin/tvheadend (3.0) [b41941717f11ef3a78ea2e9bd61f6da283712c1a] CWD: /
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: Fault address (nil) (Address not mapped)
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: Loaded libraries: /lib/i386-linux-gnu/librt.so.1 /lib/i386-linux-gnu/libdl.so.2 /usr/lib/i386-linux-gnu/libavahi-common.so.3 /usr/lib/i386-linux-gnu/libavahi-client.so.3 /lib/i386-linux-gnu/libcrypto.so.1.0.0 /lib/i386-linux-gnu/libpthread.so.0 /lib/i386-linux-gnu/libc.so.6 /lib/ld-linux.so.2 /lib/i386-linux-gnu/libdbus-1.so.3 /lib/i386-linux-gnu/libz.so.1 /lib/i386-linux-gnu/libnss_compat.so.2 /lib/i386-linux-gnu/libnsl.so.1 /lib/i386-linux-gnu/libnss_nis.so.2 /lib/i386-linux-gnu/libnss_files.so.2
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: Register dump [19]: 00000033 c1530000 ffff007b 0000007b b6673188 00000000 b3adb010 b55fbad0 004d8ff4 00000000 00000000 00000000 0000000e 00000004 003d66a1 00000073 00010246 b55fbad0 0000007b
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: STACKTRACE
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: ??:0 0x8067cf2
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: __kernel_rt_sigreturn+0x0  ()
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: ??:0 0x3d66a1
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: __strdup+0x26  (/lib/i386-linux-gnu/libc.so.6)
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: ??:0 0x8063ea6
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: ??:0 0x8087312
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: ??:0 0x80886f9
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: ??:0 0x80836f4
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: ??:0 0x8083ca7
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: ??:0 0xd40d31
Sep 20 03:44:55 revo tvheadend[1056]: CRASH: clone+0x5e  (/lib/i386-linux-gnu/libc.so.6)
Sep 20 03:44:55 revo kernel: [16283.546886] tvheadend[1163]: segfault at 0 ip 003d66a1 sp b55fbad0 error 4 in libc-2.13.so[35f000+178000]

As above, it's possible this has been addressed in master but I don't really want to get into compiling a new version for use on my production server because of the other issues you mention. I will if necessary, though (especially if those "other issues" are less fatal!).

However, I'm happy to get this running with gdb if that's useful... give me some pointers and I'll get something running. In the meantime, I've just turned off MUX autodetection... might take me a week or so to get it running, I'm away at the moment and not around to restart the service daily if it does die.

Cheers,

Also available in: Atom PDF