Project

General

Profile

Bug #1094

Some failed recordings have the "Completed OK" status

Added by Sébastien Aubry over 10 years ago. Updated about 10 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
PVR / DVR
Target version:
Start date:
2012-08-07
Due date:
% Done:

100%

Estimated time:
Found in version:
2.99.53.4502158
Affected Versions:

Description

Hi,
I have been investigating my 404 errors: sometimes, when I schedule several recordings at the same time, some of them are unable to start. This is normal (at the same time, my tuners are recording some other programs). But when the failed programs are ended, these recordings are listed as "Completed OK" in the HTTP interface and in XBMC, which results in 404 errors when trying to play them.

Attached are:
  • a syslog file showing such recordings. Here is one of them:
    Aug  7 20:44:30 pchc tvheadend[9567]: dvr: "La malédiction du plastique" on "ARTE HD" recorder starting
    Aug  7 20:44:30 pchc tvheadend[9567]: dvr: Recording unable to start: "La malédiction du plastique": Adapter in use by other subscrip
    tion
    Aug  7 20:44:30 pchc tvheadend[9567]: subscription: No transponder available for subscription "DVR: La malédiction du plastique" to channel "ARTE HD" 
    Aug  7 20:44:58 pchc tvheadend[9567]: dvr: Recording unable to start: "La malédiction du plastique": No input detected
    [...]
    Aug  7 21:18:57 pchc tvheadend[9567]: dvr: Recording unable to start: "La malédiction du plastique": No input detected
    [...]
    Aug  7 22:14:20 pchc tvheadend[9567]: dvr: Recording unable to start: "La malédiction du plastique": No input detected
    Aug  7 22:20:00 pchc tvheadend[9567]: subscription: "DVR: La malédiction du plastique" unsubscribing from "ARTE HD" 
    Aug  7 22:20:00 pchc tvheadend[9567]: dvr: "La malédiction du plastique" on "ARTE HD": End of program: OK
    

    Aug  7 22:36:25 pchc tvheadend[9567]: HTTP: 127.0.0.1: /dvrfile/12308 -- 404
    
  • a screenshot of the TvHeadend Server web interface showing this recording as "Completed OK"

Quite weirdly, the first error is "Adapter in use by other subscription" and the next errors are "No input detected".


Files

TVH_server_showing_Completed_OK.png (210 KB) TVH_server_showing_Completed_OK.png Sébastien Aubry, 2012-08-08 00:12
syslog (530 KB) syslog Sébastien Aubry, 2012-08-08 00:12

History

#1

Updated by Adam Sutton about 10 years ago

  • Category set to PVR / DVR
  • Status changed from New to Accepted

I have to admit I have a feeling I have seen this myself. Unfortunately I don't think I will get a chance to look at this before 3.2 is released. Though I was hoping to do some updates to the DVR code in 3.3.

Adam

#2

Updated by Adam Sutton about 10 years ago

It looks like the problem is that the error status is always cleared whenever a dvr entry timer expires (i.e. complete). However in this case the event never even started.

For now I'm going to put in a bit of hack which says that if the recording never started and the timer expires it'll be set to MISSED_TIME (i.e. an error state).

However there are definitely some areas here that need to be improved, since partial recordings (i.e. where it fails at the start or end but does manage some recording) will be marked good.

Adam

#3

Updated by Adam Sutton about 10 years ago

  • Status changed from Accepted to Fixed
  • % Done changed from 0 to 100

Applied in changeset commit:b65a3a4ebd4162c2cec9d9a941fafa801abb1b99.

#4

Updated by Sébastien Aubry about 10 years ago

This is great. I do not think seeing the incomplete recordings in XBMC, since they may still contain an interesting part (e.g. complete subshows).
Thank you very much. I will try to test this using the hts-unstable PPA, which I just found.

#5

Updated by Adam Sutton about 10 years ago

No problem,

Someone did mention they'd setup and autobuild PPA system. However I had a quick look and it seems to be somewhat unreliable/broken.

However we're nearly ready to enter 3.2 beta, at which point I'll start providing builds myself. Though not in a PPA, so you'll have to manually download/install for now.

Though we're working on that too.

Adam

#6

Updated by Sébastien Aubry about 10 years ago

Then I just broke my HTPC :-)
I have not tested the PPA yet but will revert to the pulse-eight version if I have any problems.
The first thing I have noticed is that the "Configuration" tab has disappeared on the web UI.

#7

Updated by Adam Sutton about 10 years ago

  • Target version set to 3.2

Also available in: Atom PDF