Project

General

Profile

Bug #1040

xmltv grabber grab interval not honoured if tvheadend restarted

Added by Richard Lloyd about 10 years ago. Updated about 10 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2012-06-24
Due date:
% Done:

90%

Estimated time:
Found in version:
2.12 (and current git g4ef72fb)
Affected Versions:

Description

I've written my own suspend+RTC wake script for deciding when my backend PC should stop
running tvheadend (when the PC resumes, it has to reboot sadly, because the TV tuner
drivers are in a bad state after a suspend). Very annoyingly, tvheadend fails to honour
the xmltv grab interval between runs and always starts a grabber when it is fired up.

Hence, I've written a simple patch (which you can improve upon if you wish) to keep a
semi-permanent timestamp file in /tmp that means that tvheadend will properly honour
the grab interval, even if it tvheadend is killed and restarted (which happens several
times a day with my suspend/wake script).

The patch attached here is against src/xmltv.c from git g4ef72fb (19th June 2012) and
whilst it will always run the grabber the very first time tvheadend is started (which is
what you want), it will strictly keep to the grabber interval specified, even if tvheadend
is regularly restarted. Considering the grabber I use is for the UK and takes 5 solid minutes
of CPU time, this is a good thing!


Files

xmltv.c.diff (1.98 KB) xmltv.c.diff Richard Lloyd, 2012-06-24 20:21

History

#1

Updated by Adam Sutton about 10 years ago

  • Status changed from New to Rejected

This is intended behaviour. However I've rewritten the EPG code and there is now an "external" XMLTV interface that will allow you to send data into TVH via a unix domain socket. If you want to have more control over scheduling of XMLTV, this is the way to do it.

Also available in: Atom PDF