Channels found, but not viewable

Added by Bob C over 10 years ago

I installed tvheadend two days ago onto my Ubuntu 11.04 system, configured it to use my WinTV-HVR 950Q and watched it scan all the muxes, after which I had to add the channels manually. Then I added a wildcard entry in Access Control, and tried to watch some TV. I'm seeing several problems:

1. The OTA EPG does not appear to ever get scanned.

2. I am completely unable to watch any of the channels from either the Configuration->Channels page or from the Configuration->TV Adapters->Services page.

From the Channels page, VLC opens with no content.

From the Services page, Firefox complains about not understanding RTSP. I copied the URL to mplayer, and got the following:

$ mplayer rtsp://
MPlayer 1.0rc4-4.5.2 (C) 2000-2010 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing rtsp://
Resolving for AF_INET6...
Couldn't resolve name for AF_INET6:
Connecting to server[]: 9981...
librtsp: server responds: 'RTSP/1.0 503 No input detected'
rtsp_session: unsupported RTSP server. Server type is 'unknown'.
STREAM_LIVE555, URL: rtsp://
Stream not seekable!
 file format detected.
Failed to get a SDP description from URL "rtsp://": 503 No input detected

Exiting... (End of file)

In the tvheadend System Log:

May 18 21:01:55 subscription: "RTSP" direct subscription to adapter: "HD Cable", network: "", mux: "549,000 kHz", provider: "", service: "", quality: 100
May 18 21:02:05 subscription: "RTSP" unsubscribing
May 18 21:02:05 RTSP: rtsp:// -- No input detected

Any and all clues would be greatly appreciated!


Replies (1)

RE: Channels found, but not viewable - Added by Bob C over 10 years ago

Update: I fetched the SVN tip and rebuilt, and now the Channels page works to view HD channels, but SD channels do not work, and I haven't yet found a way to get the RTSP links on the Services page to work. Still no OTA EPG.